1. kelvinlin's Avatar
    I am using an 8320 without a data plan for now. When I try to connect to my unsecured home wifi network, i get an "Unable to connect Reason: connection terminated" message. then it automatically connects to the network and works for around a minute or two, during which time i can get reasonable speeds. After this minute or two, when i try to load a page, it shows "requesting.." and no more activity. also, the wi-fi logo stays gray throughout this time.
    I have successfully used wifi on other networks, secured and unsecured, and am only running into trouble on my home network. has anyone else had this problem or know what is causing it? I have tried to reset my router and internet modem to no avail
    05-01-08 08:38 PM
  2. sunkast's Avatar
    Sounds like an issue with your wireless router...
    05-01-08 08:42 PM
  3. kelvinlin's Avatar
    as in it's broken or improperly configured? my laptop gets wifi just fine, and i'm not really sure how i should be configuring a router for my blackberry, thoughts?
    05-01-08 08:43 PM
  4. sunkast's Avatar
    Don't know. Would need more info about the router. Could be that the BB is not compatible with whatever router you have or how it's configured. I have heard that if you don't have the SSID broadcast enabled that the BB won't work.
    05-01-08 09:07 PM
  5. kelvinlin's Avatar
    how do i enable SSID broadcast? in my wi-fi options, the SSID shows up as linksys, which is also what the network is called
    05-03-08 01:33 PM
  6. sunkast's Avatar
    What kind of Linksys do you have? What is the model number?
    05-03-08 01:38 PM
  7. Reed McLay's Avatar
    Your router can be configured through an internet browser.

    Enter as the URL address. It is the routers address, from there, you can modify settings.

    It might be best, for trouble shooting purposed to restore the factory defaults. If you can connect to an open signal, security is easy to add on.

    I forgot my LinkSys Router Password?

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by Stoner; 05-03-08 at 09:53 PM.
    05-03-08 03:05 PM
  8. kelvinlin's Avatar
    when i run wi-fi diagnostics, everything looks fine except for status, which says "IP address no longer valid", and i have no values for anything under Primary DNS

    my curve still shows me that it's connected to the network
    05-04-08 02:50 PM