1. Marauder2's Avatar
    I have a 9700, but bought a 9900 and used it for the past couple months, but I am back to using my 9700. The problem is, calls constantly fail and it will say "Invalid SIM card' which can't be fixed without restarting the device 1-3 times, and it won't last long. I updated the software and still the same thing. I used the guide online here on Crackberry to unlock my phone, and for some reason I think that must be the cause, although it worked fine for 2 days. The SIM page says SIMDisabled, NetworkDisabled, Network SubsetDisabled, Service ProviderDisabled, CorporateDisabled.

    Please help me!
    01-18-13 08:32 PM
  2. lunaticwithin's Avatar
    It may be worth contacting your carrier and getting a replacement SIM card
    01-19-13 01:26 AM
  3. sedalia066's Avatar
    Unlocking shows the disabled code. That is correct. Sounds like either a bad SIM or bad phone.
    01-19-13 06:07 AM
  4. Branta's Avatar
    Which "unlock guide"? If it was one which had you download a code generator to your computer I suggest you upload the program to VirusTotal. I found and removed a bunch of bad stuff in our Unlock forum recently.
    01-19-13 07:20 AM
  5. Marauder2's Avatar
    Thanks for the help guys. I went down to my local Bell and they said my SIM was probably fried, and turns it was an original card, the "007" they said (the last three digits of the sim number) and they are at 420 now haha they actually replaced it free of charge because it was the older one.

    Thanks a lot!
    01-19-13 04:42 PM

Similar Threads

  1. Help! Strange problem with SIM card
    By forzanetti in forum BlackBerry Torch Series
    Replies: 3
    Last Post: 10-23-12, 08:44 AM
  2. Battery/Sim Problems. Help!
    By dp45 in forum BlackBerry Curve Series
    Replies: 4
    Last Post: 04-28-09, 01:14 PM
  3. Help with sim problem.
    By Mars12343 in forum BlackBerry Curve Series
    Replies: 13
    Last Post: 10-23-08, 07:28 PM
  4. HELP! BIS problems.
    By uncle_tony in forum BlackBerry Pearl Series
    Replies: 3
    Last Post: 10-17-07, 09:22 AM
  5. Help! Browser problems
    By JtothaR in forum New to the Forums? Introduce Yourself Here!
    Replies: 4
    Last Post: 08-03-07, 08:55 PM
LINK TO POST COPIED TO CLIPBOARD