1. magic rat's Avatar
    My old Motorola bluetooth headset stopping taking a charge, so I bought a new headset today. It's a Plantronics Explorer 240. I paired it with the phone (Curve 8530) and it works when I manually go into the Bluetooth settings and press menu-connect. However even though I made sure "connect on power-up" is selected to "yes" and all the check boxes are selected, it refuses to auto-connect when I turn on the headset. I see the Bluetooth icon appear on the phone when I turn on the headset, but it just won't auto-connect. This is very frustrating because it worked fine on my old headset. Help please! (And yes I tried the basic stuff like re-pairing, removing/reinserting the battery, etc.)
    11-15-10 11:04 PM
  2. magic rat's Avatar
    Weird .... I re-paired it a second time and now it works!

    I did one thing different. The first two times, I continued holding the phone's feature button down even after the Blackberry discovered it. I thought you were supposed to do that until the pairing process completed. I had no way of knowing that could be problematic, because the pairing process continued and succeeded each time. This time, I let go of the headset's feature button immediately after the phone discovered it. Much to my surprise the pairing procedure still worked fine -- and now the phone auto-connects to the headset. Weird!!! For my education and for the education of anyone else who finds this thread in the future, can someone here explain why this happened the way it did?

    For the record, both Plantronics' support and Sprint's first/second level support were USELESS in helping me solve this problem.
    11-15-10 11:13 PM
  3. magic rat's Avatar
    Update (and this feels oddly like I'm talking to myself) .... I decided to RTFM ... it DOES say to hold the feature button only until the light flashes .... so the whole issue was that I was being a DFU. But I'd still like to know why it APPEARED to successfully pair even after I did it wrong. Anyone got insight?
    11-15-10 11:35 PM
  4. magic rat's Avatar
    Reviving my own thread from two years ago.

    Another new phone, this time a 9930 -- and the same problem. This time letting go of the headset button didn't make a difference. Help please?
    11-14-12 12:58 PM