1. Snapper235's Avatar
    Hi all,
    I've been looking for a solution to my GPS not working for a while now and getting nowhere, can anyone offer any suggestions?

    I've done all the usual stuff, gone in options then GPS while stood in a field and refreshed the GPS. I've done battery pulls and tried switching things on and of but I just can't get anywhere.

    The phone was originally on Vodafone UK but was unlocked and is now on O2 UK, could that have something to with it? Is there a sewcive book missing? I spoke to O2 who didn't really help.

    Many Thanks


    Posted from my CrackBerry at wapforums.crackberry.com
    04-02-11 08:19 AM
  2. jeffh's Avatar
    Have you run the internal self-test? If not, go to Options / Status and type test. You won't see the letters repeated on the screen. You'll be prompted to run the Self-test. Select the GPS module. I'm not familiar with either Vodaphone or O2 UK. I don't know if either of them restricts GPS use.
    04-02-11 08:27 AM
  3. Snapper235's Avatar
    Hi, yes i`ve run the self test and it just times out waiting for something to happen.
    I used to have a Nokia 5800 on O2 UK with GPS that worked fine but I don't know if they restrict for certain phones? Also my brother has a Bold with GPS also on O2 he has no problems.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-02-11 08:32 AM
  4. jeffh's Avatar
    If the GPS in your brother's Bold works on O2, then the GPS in your Storm 2 should also. If you are the original owner, and the phone is less than a year old, you have a warranty claim.
    04-02-11 08:37 AM
  5. Snapper235's Avatar
    Ah, unfortunately I'm not. I bought the phone second hand. It's a shame because everything else woks fine and I love the phone.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-02-11 08:39 AM
  6. i7guy's Avatar
    Doubt it's a "real" hardware problem. Search the internet for GPS problems on Tour or Storm. You should find the name of a tool that can change the GPS settings as well as a host of other settings.

    Maybe that tool was used on your phone.
    04-02-11 09:32 AM
  7. Snapper235's Avatar
    I'm of the same opinion, I don't think it's a problem with the device itself,
    I'll give that a try and see what I can find, thanks

    Posted from my CrackBerry at wapforums.crackberry.com
    04-02-11 10:04 AM