1. fordmn1966's Avatar
    i just got a 8330 curve with gps of course and for some reason it's real iffy. i have instamapper and finally got it to work after a while but now i try again and it doesn't work. in order to get it to work i need to go to blackberry maps and hit "start gps tracking" then exit out quickly and hit instamapper. then it will work. if i hit "find location" and "where am i" it doesnt work. whats the deal? any ideas?
    12-27-08 10:21 PM
  2. jeffh's Avatar
    Some of the smaller CDMA carriers really struggle with GPS support. USCellular users have reported numerous problems. I think (but don't know) that they may have trouble providing the ephemeris data required by Assisted GPS mode, which is the normal CDMA GPS function.

    I use an external GPS that synchs by Bluetooth and provides autonomous GPS. That's an option. Several models are available from the CrackBerry store. One USCellular user that I worked with for a long time finally gave up and bought one because he could never get his internal GPS to work reliably.
    12-28-08 12:27 AM
  3. fordmn1966's Avatar
    Nevermind i fixed it! I just downloaded telenav's free trial and once i did that everything worked. Thanks for your help guys!
    12-30-08 06:21 PM