1. ShadyDooly's Avatar
    Device - BB 8330 (CDMA) on Verizon
    v4.5.0.77 (platform 3.2.0.51)

    After receiving a couple weeks ago I did some searching on these forums about why I couldn't seem to utilize the onboard GPS. My understanding is that with the standard included GPS chip that I should be able to utilize BB maps. Everytime I try, BB maps can never find a satellite. I broke down and purchased a Freedom Keychain GPS 2000 figuring it would help.

    I have paired up the device with no problem and I still am unable to lock onto a gps signal. Since I am sure I will get asked, below are some things I have done.

    - In the GPS settings it is set to the Keychain device and the services were switched from 911 only to location on.

    - I set the BB Maps permissions to allow for everything.

    - I have tried refreshing services.

    - I have done a few battery pulls...

    Nothing has worked EXCEPT...

    On Friday I did a battery pull, and I did lock on to my loction within 3m using the keychain as the GPS device once....but...after that I have not been able to do it again.



    I have done numerous searches on this topic...just can't seem to find any stories of people having the same issues with me while using the keychain....
    09-14-09 09:43 AM
  2. Xopher's Avatar
    I can't help with the keychain part, but BBMaps will use the internal GPS with OS 4.5.0.131 and greater (that is when the PDE change went into BBMaps).
    09-14-09 11:14 AM
  3. ShadyDooly's Avatar
    thanks...i am actually trying to upgrade the OS now...i had the default 4.5.0.77
    09-14-09 11:53 AM
  4. jeffh's Avatar
    This info may help with the Freedom Keychain 2000...

    After you have paired with the Blackberry, and with the Freedom Keychain 2000 turned ON, go to Manage Connections / Bluetooth Options / Keychain GPS 2000 / Menu / Device Properties / Menu / Refresh Service List.

    You will first see the message: "Waiting for Keychain GPS 2000"

    Watch closely. If next you see this message: "Unable to connect to Keychain GPS 2000" flash on the screen, turn the Keychain 2000 off and back on again and try again. You have to watch. The message will appear momentarily, then go away.

    Once you have successfully refreshed the list, the blue light on the phone should start blinking.

    Note: Google Maps cannot keep the Freedom Keychain 2000 locked. The puck requires a regular acknowledgement from the device, or it goes into battery-saver mode and drops the bluetooth connection. Google Maps is unable to provide this acknowledgement. Blackberry Maps can. So if you want to run Google Maps, it will be necessary to start Blackberry Maps first, let it sync with the GPS, then exit it without closing it and start Google Maps. If you do this, Google Maps will run with no problem
    09-14-09 12:10 PM
  5. ShadyDooly's Avatar
    Jeff H - I will try that in a few...

    I have succesfully upgraded the OS to v4.5.0.138

    utilizing the internal verizon gps chip, i am still unable to get GPS service through BB maps. It keeps saying "searching for satellites"

    anyone have any ideas on that?

    I will try external puck now..
    09-14-09 12:35 PM
  6. ShadyDooly's Avatar
    Ok...not working with the keychain either....

    I followed your instructions...it is paired..and did the refresh and blue light is blinking...but BB maps cannot get a satellite lock.
    09-14-09 12:44 PM
  7. ShadyDooly's Avatar
    update - So with the keychain...using BB Maps I was able to get a GPS location lock once....again..now I cannot.
    09-14-09 01:19 PM
  8. jeffh's Avatar
    In Options / Status, do you have an MEID or an ESN?
    09-14-09 01:23 PM
  9. bgredjeep's Avatar
    This may be a silly question, but are you inside or outside? In my house, or in my office, the GPS will not respond very well, and will not always lock. Outdoors it takes about 10 seconds to lock 10 satellites on my Storm.
    09-14-09 04:02 PM
  10. ShadyDooly's Avatar
    JeffH = I have MEID

    does that make a dif?

    Bjredjeep = good point...never works from in the office...the two or three connections I have had were outside...but doesn't always work.
    09-14-09 04:13 PM
  11. jeffh's Avatar
    Having an MEID device may be the root of your problem. I can't check it right now, but if you search for GPS MEID or GPS 8330m I think you'll find several threads about problems with nav software and MEID devices.

    MORE INFO: This link might help: http://forums.crackberry.com/f41/rea...v1-0-a-192999/
    Last edited by JeffH; 09-14-09 at 04:54 PM. Reason: more info
    09-14-09 04:25 PM
  12. ShadyDooly's Avatar
    Thanks..I will take a look...but here is an update..

    After upgrading the OS..I now seem to be able to utilize the internal GPS with BB Maps, and I can utilize google maps as long as I run BB maps in the back ground.

    My keychain external GPS works with BB maps as well..but for some reason google maps does not work with it.
    09-15-09 10:27 AM
  13. jeffh's Avatar
    Upgrading your OS to at least 4.5.0.131 will enable BBMaps to use the internal GPS. There is no upgrade that will enable Google Maps to use the internal GPS on an 8330. Is Google Maps showing your location with 3-m accuracy? If it is, then running BBMaps is enabling it. That would be news to me. Google Maps requires BBMaps to be running when you use the external GPS for the reasons I gave in a post earlier this thread.
    09-15-09 01:23 PM
  14. ShadyDooly's Avatar
    Yes...

    Internal GPS = BB Maps works and Google Maps works with BB maps in background

    External GPS = Same as above..

    google maps does not support external gps as i have found out.
    09-15-09 01:59 PM
LINK TO POST COPIED TO CLIPBOARD