1. Techworked's Avatar
    Hey guys, I'm new to the site. So first off... What Up fellow blackberry's?

    Ok so everytime I open VZ Navigator, google maps or maps and click "Find my location" it tries for about 3 minutes then says connection timed out please try again. I'm really hoping someone could help me out here. I've tried googling the issue and dont seem to find any answeres. Also, I've talked to a couple of local friends who have tried to fix the problem but are stumped. Any help on this issue would be awesome. I just need my gps to work. I run 2 businesses that require directions all over the US. This would really help. Thanks in advance!
    02-24-09 11:16 AM
  2. kokuryuha's Avatar
    Well first off, welcome to CB.

    Secondly, VZ Nav won't work if you're on T-Mobile, It's a verizon subscription service.

    Check your location settings. Go to Options > Advanced Options > GPS > Set GPS Servies to Location On.

    If you have already done this, try to Disable Location Aiding in the same menu, and see if that works.

    Be aware though if you set Location to On, it can have a negative impact on your battery life. It's generally recommended you only turn it on when you need to use it.
    02-24-09 11:19 AM
  3. Techworked's Avatar
    Right on. I just turned of loactaion aiding and it's still doing the same thing. I also have google maps. When I try to find my location it says connection unavailable. However, on google maps, vz nav and maps, I can look up an address, it just give me turn by turn (GPS) directions.
    02-24-09 11:34 AM
  4. Techworked's Avatar
    It just WON'T give me turn by turn directions... Sorry mis-type
    02-24-09 11:35 AM
  5. kokuryuha's Avatar
    Wait, you're on T-Mo and VZ Nav works? That's not right...Gotta be paying Verizon for that to work. Also, try outside with open sky for the gps? without location aiding it can take up to about 45 seconds to get a fix. Are you running the latest Google Maps 3.0.2? GPS didn't work on them til then.
    02-24-09 11:39 AM
  6. Techworked's Avatar
    Yes I'm on T-Mobile. I have tried with open sky as well. Actually I just now deleted google maps and I'm going to reinstall. Looking for google maps again to reinstall.
    02-24-09 11:44 AM
  7. kokuryuha's Avatar
    http://m.google.com/gmm from your phone's browser
    02-24-09 11:47 AM
  8. Techworked's Avatar
    Yeah, I'm installing the version you listed as we "type" :P
    02-24-09 11:48 AM
  9. Techworked's Avatar
    Same thing. man what a pain.
    02-24-09 11:52 AM
  10. kokuryuha's Avatar
    Have you given each app that is requesting GPS it's proper permissions? ie access to location information?
    02-24-09 12:00 PM
  11. Techworked's Avatar
    No Sir. How might I go about doing that?
    02-24-09 12:05 PM
  12. kokuryuha's Avatar
    lol that might be the problem right there. go to options > advanced > applications > find the programs you want to have access to GPS and highlight it (dont click) > hit BB menu, go to Edit Permissions. Under the first drop down there should be a section that says Location Information. Set that to On if it isn't already. If it's an app you specifically trust, you can just hit allow on all, on the main three drop downs you see just to be quick
    02-24-09 12:08 PM
  13. DCMack's Avatar
    Hello, I am using an un-locked Storm on T-mobile and I have been using VZ Navigator for a month with no problem. The guy I bought it from told me how to use it. When I first bought it the navigator wouldn't work. You need to delete it from your storm and then re-load it using the desk top manager. I don't know why but it should work then. Don't take my word for it, give it a try and then post your results.
    02-24-09 12:30 PM
  14. kokuryuha's Avatar
    Interesting, never heard of that before, but good to know.
    02-24-09 12:33 PM
  15. zenstorm's Avatar
    I have VZ Navigator on my storm. And I am running .323. I am on Tmobile and it works I SWEAR!


    Try to use the APP loader to remove it, battery pull, then use APP loader to reinstall. TADA!

    I have a few other fixes on my blog. I can't post links yet, but it's at

    BLOGGER the blackberry review

    Good Luck
    11-04-09 03:02 PM
  16. zenstorm's Avatar
    Just wanted to repost. I put out a quick youtube video to show it works.

    watch?v=V1DkDS0EOmU (put this after the youtube url) cant post links yet sry
    11-04-09 04:26 PM
LINK TO POST COPIED TO CLIPBOARD