1. KingScyld's Avatar
    Purchased a Sprint Curve 8530.

    OS version Google maps version 3.2.1

    Tried everything I could think of to get Google maps to use GPS. It doesn't. It either triangulates with cell towers, or if I am connected to a Wi-Fi, it will use that.

    I have read threads saying that people who have 8330s have gotten it to work with GM v2.0whatever. It stands to reason however that 3.2.1 would also have those same fixes in it.

    Does anyone know if there is a patch out there, or if Sprint has locked the GPS?

    I am lost without this. Someone please help me to find myself.
    02-09-10 03:51 PM
  2. jcknight007's Avatar
    Same problem here man. I did get sat connection ONE time. Then nothing. It's odd that BB Maps works fine but not Google. I've tried editing permissions and loading an older version of Google Maps. Nothing.
    02-19-10 07:17 PM
  3. DbleK55's Avatar
    It is a Google problem. Started using Bing maps in the mean time.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-20-10 10:28 AM
  4. Nathan1981's Avatar
    Be patient. I had the exact same problem when I got a replacement 8330, then about 4-6 months later, Google Maps updated their software and it worked. Now I just got an 8530, and it's the same story. If this is anything like last time, Google knows about it, and will release a fix in the next couple months.
    03-10-10 04:22 PM