1. xxsashixx's Avatar
    Forgive me if this is the wrong forum to post this in

    I have two Gmail accounts, I'm trying to sync all the folders in them to view them on my blackberry

    When I view some folders, it shows some emails but not all, and some folders don't even have any emails.
    I have already enabled folder sync

    Thanks

    - Sashi

    Posted via CB10
    03-15-14 10:46 AM
  2. Ecm's Avatar
    Can you tell us what device and OS version you're using? The steps will depend on your device.
    03-15-14 11:00 AM
  3. xxsashixx's Avatar
    Thanks for the reply

    I'm using a z30 with 10.2.1.2102

    Posted via CB10
    03-15-14 11:19 AM
  4. xxsashixx's Avatar
    Hey guys

    Sorry for the bump, I have moved all my emails and contacts to outlook.com, which really I would love to keep gmail

    Anyways, if I set my sync limit to forever, my emails in folders disappear"?
    03-15-14 09:42 PM
  5. Ecm's Avatar
    From your description of all your Gmail folders being synced, but not all emails showing in those folders, it sounds like the sync time period is the culprit. Example, one of my Gmail accounts is set to sync 30 days worth of email. So, messages 31+ days drop out of my sub folders. My main Gmail account is set to "forever". All messages remain, no matter how old. (I have a fiew going back as far as 2004.)

    The setting "Initial Retrieval Amount", which determines how long messages stay on your device for an IMAP account like Gmail, is only available when setting up the account. It can't be edited afterward. So, if you want to stick with the Gmail account, you'd need to delete and re-add the account, using the advanced option to specify "forever". Then, after you've synced folders, everything will stay available on your device. Depending on how much email you have, you might want to be on WiFi when you do so, so you don't kill your data allowance.

    Hope this helps.
    03-16-14 06:03 PM
  6. xxsashixx's Avatar
    I have set it to forever however that doesn't seem to work

    I've read that gmail uses labels instead of folders

    I have moved emails to my "folders" on the web in Gmail instead of just labeling them

    Do I have to file them on my z30 to the folder?

    I've set my "folders" on gmail as "Show in IMAP" but that doesn't seem to work

    Edit: also how can I sent a different reply as email if I only have one account setup on the device, but have two emails on gmail web?

    Thanks

    - Sashi



    Posted via CB10
    03-16-14 09:21 PM
  7. Ecm's Avatar
    I have set it to forever however that doesn't seem to work

    I've read that gmail uses labels instead of folders

    I have moved emails to my "folders" on the web in Gmail instead of just labeling them

    Do I have to file them on my z30 to the folder?

    I've set my "folders" on gmail as "Show in IMAP" but that doesn't seem to work

    Edit: also how can I sent a different reply as email if I only have one account setup on the device, but have two emails on gmail web?

    Thanks

    - Sashi



    Posted via CB10
    OK, let's address these points separately:

    Due to Gmail's "creative" method of dealing with email, Gmail labels become folders on your device. So, if you apply more than one label to an email message on Gmail/web and archive it, that email will show in each folder on your device under the corresponding folder. A message with a label assigned to it that is not archived will show in your device Inbox (and Hub). Filing on device equates to archiving in Gmail.

    So, if on Gmail you label a message "Work" and archive it, it will show under the folder "Work" on your device.

    ***Note that the "All Mail" label will not show on your device. So, don't archive any messages without labeling them, if you want to access them on the go.

    Also, if you wish to have Gmail on device set up so that email deleted on device deletes within Gmail, take a look at this article. http://crackberry.com/how-get-gmail-...hout-archiving

    As for "send as", BB 10 (like most mobile OS's) does not support sending as an alias.
    03-16-14 11:16 PM
  8. xxsashixx's Avatar
    Thanks

    However I don't know why I still have the problem of having no emails on the device in the folders

    What's weird is that I have them in inbox but not under say.. "Work"

    As for alias, I would have to add multiple emails and have duplicate emails showing up in hub?

    Edit: I just reset BlackBerry Hub via the swipe gestures and all my emails showed up.. weird (I still have that alias question though)

    Thanks

    - Sashi

    Posted via CB10
    03-16-14 11:54 PM
  9. xxsashixx's Avatar
    Sorry

    Just encountered another problem

    My attachments won't download, it just stops at like 80% then it stops and never opens

    Thanks

    Posted via CB10
    03-17-14 08:49 AM
  10. Ecm's Avatar
    Is that for all attachments, or one type of attachment in particular.

    Let's try a hard reboot. Press and hold the volume up/down buttons until the screen shot notice appears, the device powers down, powers up, and you see the startup animation. Wait a few minutes, then try opening the attachment again.
    03-17-14 01:08 PM
  11. xxsashixx's Avatar
    This only happens with html files

    Rebooted still no luck

    Posted via CB10
    Last edited by xxsashixx; 03-17-14 at 07:31 PM.
    03-17-14 06:29 PM
  12. xxsashixx's Avatar
    Bump, im now on 10.2.1.2234 and the same problem still exists (Html files not opening)

    Thanks

    Posted via CB10
    03-19-14 07:54 PM

Similar Threads

  1. How do you Sync ?
    By bessibb in forum BlackBerry Z10
    Replies: 4
    Last Post: 03-16-14, 02:14 PM
  2. Verizon Z30 Question COMPLETE NOOB be gentle!
    By piercybill in forum BlackBerry Z30
    Replies: 21
    Last Post: 03-15-14, 09:02 PM
  3. Just received my Q10 a few quick questions (More later)
    By Thalakar in forum BlackBerry Q10
    Replies: 4
    Last Post: 03-15-14, 10:30 AM
  4. Phone Sale Questions
    By shibby080 in forum BlackBerry Z10
    Replies: 3
    Last Post: 03-15-14, 07:42 AM
  5. Question about 10.2 and sim.
    By Watcher777 in forum BlackBerry Z10
    Replies: 1
    Last Post: 03-14-14, 04:00 PM
LINK TO POST COPIED TO CLIPBOARD