1. RahulM's Avatar
    So I upgraded to .144 and it could not restore the backup and I lost all my phone and application data and settings. This did not happen the first time I upgraded from the stock OS to .133.

    I manually updated from the backup file, but still it could not update all the entries, only a few of them. It would still give me the error message regardless.

    Why did this happen and how can I prevent it from happening in the future?

    02-13-09 09:16 PM
  2. RahulM's Avatar
    02-14-09 01:43 AM
  3. ArmaK's Avatar
    It sounds like that there could be a corruption in one or more of the database files. I have two suggestions for you. The first is to downgrade to .133 and try to see if it will restore the backup. If it does, then try reloading .144 again and see if the problem occurs. If it does occur or you still get the error with .133 installed, try restore the databases one by one. It might be tedious but it will help you find the problem database(s). After getting everything restore and fixed to how you previously were, I would do a backup and save this to a location to use for a restore point incase this problem happens again.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-14-09 11:04 AM
  4. anon(2488840)'s Avatar
    I solved my problem using the BBSAK application, and selecting Factory Reset. After that the Restore function of BB Desktop Manager worked without a hitch.

    BBSAK link:
    08-29-09 12:01 PM