1. anon1097328's Avatar
    Hey everyone,

    The full version of ETRADE Mobile has been released today, I just downloaded it. Pretty sharp layout. Visit Etrade.com/mobile for the download
    07-01-08 01:06 PM
  2. rpalumbo's Avatar
    Thanks man, just downloaded and did my first trade, great software now I have another reason why I should never be off my Blackberry

    Posted from my CrackBerry at wapforums.crackberry.com
    07-01-08 02:58 PM
  3. anon1097328's Avatar
    Ya I am experiencing some glitches though.. Etrade should have the problem solved in a few weeks, the interface looks great. Very user friendly....
    07-01-08 04:30 PM
  4. kevcro's Avatar
    I noticed they have a link to it on the BlackBerry mobile page under applications.
    07-01-08 05:14 PM
  5. gameboy213's Avatar
    The app is killer. I have been using it for like 2 weeks now. Made quite a few trades and transfers. It's pretty amazing really. And free.
    07-01-08 06:17 PM
  6. aamirh's Avatar
    i go to etrade.com/mobile on the BB, but which link is the one which will download the application? every link i click just reloads the same page. PLEASE HELP!! thanks
    08-08-08 05:30 AM
  7. srplummer's Avatar
    i go to etrade.com/mobile on the BB, but which link is the one which will download the application? every link i click just reloads the same page. PLEASE HELP!! thanks

    Hello!
    Try going to mobile.blackberry to DL it.
    08-08-08 05:37 AM
  8. aamirh's Avatar
    tried this, clicked on the application via mobile.blackberry.com, and the "download" link from mobile.etrade.com took me to the same general etrade page which doesn't have a link to the application. any other ideas?
    08-08-08 05:53 AM
  9. srplummer's Avatar
    tried this, clicked on the application via mobile.blackberry.com, and the "download" link from mobile.etrade.com took me to the same general etrade page which doesn't have a link to the application. any other ideas?

    Hmm... It started to DL for me.

    Make sure your browser settings are correct. While in browser- Menu>Options>Browser Configuration.

    These should be checked.
    08-08-08 06:01 AM
LINK TO POST COPIED TO CLIPBOARD