1. uofmrapper's Avatar
    I got to play w/ the demo at my local Circuit city last night (it was ver .65) and the first thing I did (before even trying out the keyboard) was go and download Google Maps to check out the GPS. While it was downloading I went back and tried the keyboard (not super impressed but I literally only type like 30 characters so I'll reserve judgement for a week or two until I thoroughly try it out) and watched the first few seconds of the Babylon trailer (I agree w/ others, great screen). Went back to the browser and said the app was done downloading so I clicked run and it fired up. It was version 2.3.2 and it loaded up like it normally does on any other phone.

    After accepting the terms of service, it loaded the map and......lo and behold.......I had a blue dot w/ a big ring around it (indicating approx location)!!! NO!!! I was hoping it would say searching for satellites or something but it didn't. I hit the Menu button to see if there were any options for GPS but there wasn't. I backed out to the main menu, went to options --> advanced options --> GPS, and the first option (can't remember what it said) had "Device GPS" selected. Then the lady snatched it away because someone else walked up and wasn't supposed to be letting me look at it

    So I have an 8100 pearl (no GPS) and don't really know what should happen when you run Google Maps indoors where satellites can't be acquired. I'm interested to hear you guys' thoughts on this and whether this means GPS is NOT unlocked or maybe there's a setting that needs to be changed to enable it?
    11-20-08 07:16 AM
  2. dhendriksen's Avatar
    The GPS is unlocked. GPS can take a while to acquire satellites the FIRST time. When I say a while, I mean it's taken up to 30 minutes before. On top of that, being indoors is a challenge. The first time you use it launch that GPS screen in options and go hang out in a wide open spage until it acquires 6-10 satellites. After that it should re-acquire them much quicker while outdoors, and occasionally while in doors. Google maps just defaults to the cell triangulation while it is waiting on the GPS. Also, google maps will cue the gps, it just doesn't make you aware of it.

    Don't worry, the gps is unlocked and what you experienced is normal behaviour.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-20-08 07:24 AM
  3. p3tchy's Avatar
    Just tried what you said and if you hit the blackberry key it gives you the option to scan for satellites, I'm indoors at the mo so its not picking anything up.
    11-20-08 07:27 AM
  4. cannonballgsu's Avatar
    that was poor customer service
    11-20-08 07:27 AM
  5. dhendriksen's Avatar
    Yeah, I believe she would snatch it from you to show another customer.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-20-08 07:31 AM
  6. uofmrapper's Avatar
    *PHEW* I'm glad to hear that. I really want to be able to use my own GPS on this thing! Can't wait to get it still and I hope they update the OS. It wasn't SUPER laggy, but did have its times - like when scrolling thru the applications in the Menu.

    And she didn't snatch it to give it to someone else, she snatched it to hide it.

    I actually went to the Verizon store in the same mall as the CC store and asked them to play w/ the demo and they flat out said "No, no one can see it til Friday." Bunch of dummies. I'm not excited about switching back to Verizon for this phone but I'm just hoping I don't have to interact w/ them much.
    11-20-08 08:17 AM
  7. edster's Avatar
    I've been fiddling with my Storm for a while now and the built in GPS does work with the built in "Maps" but not with Google Maps. It keeps saying "GPS temporarily unavailable" or "waiting for GPS" while if you switch to Maps, it will be tracking 12 satellites. Anyone know why? I hope Google will fix this soon. Google map is so much better than any other maps out there.
    Storm is so slooooow....
    11-30-08 07:55 AM
  8. pulsarxz's Avatar
    Google Maps will work with a future update to Google Maps for the Storm. GPS is unlocked, however, Google Maps by design attempts to locate your position through AGPS (assisited GPS) first, and then it utilizes GPS to lock your position. Because of this, it will not work yet. The AGPS function is restricted to third party apps. on Verizon phones for security reasons, this is because AGPS allows satellites to locate your general position using the Verizon Network towers nearest your position and then GPS to lock on. So, unfortunately do to the fact that Google Maps software initializes tracking by AGPS first, it will not work. But a future update to Google Maps should remedy this.
    12-03-08 04:01 PM
  9. pattont's Avatar
    I hope they update more than just this in google maps...
    12-03-08 05:00 PM
  10. silv3rskeeter's Avatar
    when i downloaded google maps and tried it for the first time, the gps took a while so i turned on the regular bb maps on top of that and did the satelite search. then i went back to the google maps and suddenly it found me.. whaddaya know..
    12-03-08 05:21 PM
  11. jiabao's Avatar
    Thanks for your help!

    I have an gps problem.

    I am in China.

    I use 9530

    but my cell's gps may be not work.

    when i use the blackberrymap and search the sattlelite,it show "Unable to acquire GPS lock"

    what is wrong?

    please help me.
    05-10-11 11:09 AM
  12. gregs87's Avatar
    Do you have it turned on? Go to options (the wrench) Advanced Options, GPS - make sure GPS services is on Location ON and see if that works.
    05-10-11 11:23 AM