1. designguy67's Avatar
    Mine seems to work fine. In fact, it works like a charm at my home...even using WEP security. But yesterday, I tried to use it at a Panera Bread and a Border Books and even though it SAID it was "connected", it wasn't working. In the WiFi options, there was a small black box with a dash in it next to the WiFi setting. I cannot find what that means. Everything was "green", though and if I rescanned for hotspots at both places, it said I was already connected. I DID notice at Borders, I never got any sort of logon browser screen asking me to accept terms, etc. I think that's supposed to happen when using a laptop.
    So, is there something I'm just missing? An advanced setting to use hotspots?
    11-01-09 03:21 PM
  2. paulwright1's Avatar
    Was the wifi logo grey or white?
    11-01-09 03:23 PM
  3. designguy67's Avatar
    It WAS grey, now that you mention it
    11-01-09 03:24 PM
  4. designguy67's Avatar
    I disconnect and then reconnect and get the same problem. It never connects to any hotspots...only my HOME internet...
    11-02-09 09:17 PM
  5. cegha's Avatar
    Epic Fail on S2 with wifi. There have been so many problems with this, sure hope the one that i'm getting doesn't have excessive problems.
    11-02-09 09:24 PM
  6. RicanMedic78's Avatar
    theres a fix for this....



    I just dont know what it is
    11-02-09 10:43 PM
  7. gtstang462002's Avatar
    Epic Fail on S2 with wifi. There have been so many problems with this, sure hope the one that i'm getting doesn't have excessive problems.
    Epic fail due to operator error. This is the real reason they never put WiFi in these devices.
    Mine seems to work fine. In fact, it works like a charm at my home...even using WEP security. But yesterday, I tried to use it at a Panera Bread and a Border Books and even though it SAID it was "connected", it wasn't working. In the WiFi options, there was a small black box with a dash in it next to the WiFi setting. I cannot find what that means. Everything was "green", though and if I rescanned for hotspots at both places, it said I was already connected. I DID notice at Borders, I never got any sort of logon browser screen asking me to accept terms, etc. I think that's supposed to happen when using a laptop.
    So, is there something I'm just missing? An advanced setting to use hotspots?
    After you configure your phone to connect to the "hotspot" there is the option to perform a hotspot login. Do that and the phone will confirm that you are logged into the hotspot router. Keep in mind that it the public location has port 443 blocked you will not connect to the RIM servers so your icon will remain grey and you will have a dash with the network name on your connections box.
    11-02-09 10:49 PM
  8. designguy67's Avatar
    Keep in mind that it the public location has port 443 blocked you will not connect to the RIM servers so your icon will remain grey and you will have a dash with the network name on your connections box.
    Ah, ha!...THAT is what THAT means...see I just couldn't find anything in the documentation telling me what "the dash" meant...okay, now sense has been made!
    Thank you!
    11-02-09 11:21 PM
LINK TO POST COPIED TO CLIPBOARD