1. ChrisS's Avatar
    I just got a Freedom Keychain GPS 2000 Receiver. I paired the Curve and GPS and the GPS now appears on the Paired Device screen on my Curve. But the GPS and Curve don't appear to be communicating with each other. The blue LED blinks on the GPS. But the Blue LED on the BB is not blinking - it's not turned off in the menu. And the Bluetooth Icon on the home screen does not indicate it is paired with another device. The help information on the bb says to go to the bluetooth screen, click on a paired device, and the click connect. I do this, but there is no connect on the menu.

    Any help greatly appreciated. I tried the Verizon tech support and they were aweful. The support person repeatedly asked me if I was "trying to connect to a bluetooth?"
    06-20-08 07:11 PM
  2. davesax36's Avatar
    try starting navigation in BBMaps. that might trick it into looking again.
    06-20-08 07:19 PM
  3. jeffh's Avatar
    First, go to Options/Advanced Options/GPS and make sure GPS Data Source is set to Keychain GPS 2000 and GPS Services is set to "911 only." GPS Data Source defaults to Device GPS, which won't help you with a Verizon phone. You don't need GPS services set to "Location On" because that only affects the internal GPS.

    If you'd already done that and it still didn't work, then try the BBMaps suggestion.

    If that doesn't work, then go to Manage Connections/Bluetooth Options and select the Freedom Keychain 2000, click and select Device Properties. Then push the Menu button and select Refresh Service List. You'll get a prompt that says it's waiting for Keychain GPS 2000...you have to keep watching, because the next dialog box that may come up only stays on-screen a few seconds. If it says Unable to Connect to Keychain GPS 2000, then turn the GPS off and back on and try again.

    Let us know how it works out. I'm hoping my first suggestion is the answer.
    06-20-08 08:52 PM
  4. ChrisS's Avatar
    Thanks guys I tried all of your suggestions. It now works. But, it will only work if I have GPS Services set to "Location On." The blue LED light on the BB flashes, the bluetooth icon on the home screen flashes, and I get a good GPS signal in both BBMaps and Google Maps.

    Seems odd.
    06-21-08 08:06 AM
  5. jeffh's Avatar
    ...it will only work if I have GPS Services set to "Location On."...
    I'd like to understand that better. I have the 8830, not the 8330, but I have the same Freedom Keychain 2000, and I have mine set as I described. Would you be willing to try a test?
    • Get it working with BBMaps
    • Then exit BBMaps, leaving it running in the background
    • Options/Advanced Options/GPS/GPS Services: change to "911 only"
    • Return to BBMaps and see if it continues working.
    06-21-08 08:18 AM
  6. ChrisS's Avatar
    Yes, it worked after I changed to 911 only. And when I returned to BBMaps it still worked. However, I tried shuting down BBMaps and restarting it and it would not worked. I also tried Google Maps and it will just use cell tower info.
    06-21-08 08:32 AM
  7. jeffh's Avatar
    When you restarted BBMaps, did you use the Start GPS Navigation command?

    Google Maps Mobile doesn't have the ability to start an external GPS, or to keep it running. You'll always have to use BBMaps in the background with Google Maps. The Freedom Keychain 2000 has battery-saving mode that causes it to shut down if it doesn't get acknowledgement from the blackberry. GMM can't send that ack to a bluetooth device. BBMaps can.
    06-21-08 08:39 AM
  8. ChrisS's Avatar

    Yes I did use the start GPS nav command. It seems to work fine as long as I have the GPS Services set to "Location On." If I change it to "911 only" its a no go. But it works and I'm happy. Thanks for all the help.
    06-22-08 09:17 AM
  9. jeffh's Avatar
    Thanks for replying. I'm very glad it's working for you. I always want to know if there's an exception to what I consider the norm. I don't know why you have to enable Location On, but I'll add that to my list of debugging tips.

    I wonder if you have a BBMaps service book. I've read elsewhere that Rim was going to modify their OS to include a service book for BBMaps, in response to some carriers. I don't have that service book. If you do, that might explain the difference with Location On.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-22-08 10:57 AM
  10. azcavalier's Avatar
    I can't get mine to connect, and I just got it today. It connected once, but I couldn't get any apps other than BBMaps to seem to work, so I double-checked my GPS settings, and they were set to "Device GPS". I HAD changed it to the keychain, but I must not have saved it.

    In any case, it no longer connects. I have tried the above steps, and nothing works.

    Every time that I go into the Bluetooth Options, choose the keychain, go to device properties, and then choose the "Refresh Service List", I get the message that it's waiting for the keychain, but that goes away after a few seconds. I never get that it fails to connect. At this point, the LEDs on the keychain stop blinking and are lit solid, just as on boot-up. It's like when the Curve tries to connect, it causes the keychain to reboot, but it never connects. I have also tried deleting the device and pairing them again, which always has no issue. So, I can pair all day long, but I can not connect.

    09-23-09 02:47 PM
  11. azcavalier's Avatar
    And of course, SECONDS after I post this, it connects. Sheesh.
    Last edited by azcavalier; 09-23-09 at 02:58 PM.
    09-23-09 02:49 PM