11-12-09 03:02 PM
64 123
tools
  1. Pete6's Avatar
    has anyone gotten this to work with the BOLD9000? it hangs while reading memory for me..
    It worked fine on my Bold while I had it. You must have Desktop Manager installed for it to work.
    10-10-08 01:03 PM
  2. jeffh's Avatar
    I downloaded CrackPic 1.1 on top of 1.0.

    It correctly prompts me for my password and remembers it, but after it takes the picture, it does not open Paint. At first I thought it wasn't taking the picture, but it is. The picture is stored in C:\Program Files\CrackPic\bb.bmp. I can double-click bb.bmp and the picture opens just fine.

    I tried it in Not Mass Storage Mode (as designed) and in Mass Storage Mode. Even though your instructions say not to use it in Mass Storage Mode, it still takes the picture just fine. You can probably remove that restriction.

    I tried it at work, with all my network drives mapped, and at home, with no network drives mapped. The same result: it takes the picture, but doesn't open Paint. My BlackBerry is assigned drive letter "I" to avoid conflicts with network drives at work.

    Version 1.0 did not have this problem, but unfortunately I saved the download on top of it and no longer have it.

    You are correct to recommend removing 1.0 before installing 1.1. I didn't the first time and got program not found errors from the shortcut.

    Sorry to be so slow responding, but I wanted to try all the scenarios before I reported, to give your CrackProgramming team the best report possible.
    10-17-08 05:00 PM
  3. Pete6's Avatar
    JeffH, I will try to locate a copy of CrackPic v1.0 here. I may have one on a Backup someplace. I will PM you you when/if I find it.

    The reason I said not to use Mass SToreage mode is to stop people taking pics of the Mass Storage Screen.
    10-17-08 05:03 PM
  4. SK1's Avatar
    10-17-08 05:12 PM
  5. PvT's Avatar
    Well, is this ever the Cats Pajamas!

    Thank you so much Pete6. I've perused some threads on this and then couldn't be bothered as it wasn't really a big priority for me. Though, I wanted to be able to do this. You made it real easy, by me seeing this thread up'd today and I:

    Downloaded it / extracted it / installed it / ran it / clicked it / and paint opened right up with my BBB screenshot.

    Nice Now I have it for when I need it and the process couldn't have been simpler. Thanks to you... and the kids

    10-17-08 06:00 PM
  6. jeffh's Avatar
    JeffH, I will try to locate a copy of CrackPic v1.0 here. I may have one on a Backup someplace....
    Here is a temp link to CrackPic 1.0...
    Thanks, Pete. Thanks, SK1. I d/l 1.0, so you can drop the temp download link. Thanks very much. Unfortunately, 1.0 won't launch Paint either. I know it worked before. I can't figure out what changed, but I have one clue. Between the last time I used 1.0, when it worked, and the first time I tried to use 1.1, which didn't, the security people rolled out a major change to the way we login to our computers. My laptop boots much faster now than it did before. I don't know how CrackPic knows where to find Paint, but I'm guessing that whatever changed in my login settings is what's causing CrackPic not to be able to find Paint.
    10-17-08 11:39 PM
  7. SK1's Avatar
    I know that in Vista I had to right click on it and run as admin for it to work for me.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-17-08 11:46 PM
  8. jeffh's Avatar
    I know that in Vista I had to right click on it and run as admin for it to work for me.

    Posted from my CrackBerry at wapforums.crackberry.com
    I'm running XP SP2.
    10-17-08 11:57 PM
  9. SK1's Avatar
    I was afraid you were going to say that. I don't have an XP machine here. If I visit the "parental units" this weekend, I'll try it on my Dads machine.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-18-08 12:00 AM
  10. Pete6's Avatar
    I bl00dy knew this was your d^mn PC, Mr. H .

    What concerns me however is that what used to work now does not.

    have you tried the same thing with that alpah-version of CrackUtil I sent you? That has the same functionality as CrackPic built in and, it worked on my PCs (XP and Vista Home premium).

    Does Paint launch when you run it from the Start Menu (Start, Accessories, Paint)?

    Paint must be located in %SystemRoot%\System32\mspaint.exe for CrackPic to find it. This usually translates to C:\WINDOWS\System32\mspaint.exe. CrackPic will find whatever %SystemRoot% translates to on any disk because there are system variables telling what this translates to and these are used by many other programs.

    If Paint is not where the program expects it then its not gonna run it.
    Last edited by Pete6; 10-18-08 at 07:09 AM.
    10-18-08 07:06 AM
  11. jeffh's Avatar
    I bl00dy knew this was your d^mn PC, Mr. H .

    What concerns me however is that what used to work now does not.

    have you tried the same thing with that alpah-version of CrackUtil I sent you? That has the same functionality as CrackPic built in and, it worked on my PCs (XP and Vista Home premium).

    Does Paint launch when you run it from the Start Menu (Start, Accessories, Paint)?

    Paint must be located in %SystemRoot%\System32\mspaint.exe for CrackPic to find it. This usually translates to C:\WINDOWS\System32\mspaint.exe. CrackPic will find whatever %SystemRoot% translates to on any disk because there are system variables telling what this translates to and these are used by many other programs.

    If Paint is not where the program expects it then its not gonna run it.
    Great suggestion re CrackUtil. It works. It prompts for my password, takes the picture, and runs Paint. Just like CrackPic1.0 used to.

    Paint does launch when I run it from Start, Accessories, Paint.

    On my system, Paint is located at: C:\WINNT\system32\Paint

    So if CrackUtil uses the same path and routine as CrackPic, why does CrackUtil work and CrackPic not?
    10-18-08 09:55 AM
  12. Pete6's Avatar
    Great suggestion re CrackUtil. It works. It prompts for my password, takes the picture, and runs Paint. Just like CrackPic1.0 used to.

    Paint does launch when I run it from Start, Accessories, Paint.

    On my system, Paint is located at: C:\WINNT\system32\Paint

    So if CrackUtil uses the same path and routine as CrackPic, why does CrackUtil work and CrackPic not?
    There's the problem Jeff. CrackPic will look for Paint in C:\Windows\system32\mspaint.exe

    The C: drive will be the boot drive and can be any letter.

    I will look into this to see what changed in CrackPic v1.0 > v1.1 and CrackUtil.

    It has to be a programming change. I'll get on it.
    10-21-08 01:16 PM
  13. jeffh's Avatar
    If I cmd to a dos prompt, here's my path statement:
    PATH=C:\WINNT\system32;C:\WINNT;C:\WINNT\System\Wb em;C:\Program Files\Common Files\Roxio Shared\9.0\DLLShared\;C:\Program Files\QuickTime\QTSystem\

    If I look at the SET variables,
    SystemDrive=C:
    SystemRoot=C:\WINNT
    windir=C:WINNT

    With these settings, shouldn't CrackPic1.1 be able to find Paint as easily as CrackPic1.0 and CrackUtil? I can't be sure that nothing changed in my settings between CrackPic1.0 and CrackPic1.1, since the Login process changed, but CrackUtil worked before the change and still works after, so that would seem to imply that something changed in the programming between CrackPic1.0 and CrackPic1.1, other than the obvious addition of a password prompt and store.
    10-21-08 02:56 PM
  14. J_Rock's Avatar
    This works great!!! Thanks a ton!!!
    10-23-08 09:34 AM
  15. cmputrcf's Avatar
    I was able to get my training document done for an application installed on the phone very quickly with the use of CrackPic. My boss was very impressed that i was able to get screenshots out of the phone. Thank you so very much for developing!!!!!!!!!

    Kudos
    Kudos to you!!!
    11-06-08 12:06 PM
  16. rachel0179's Avatar
    I just got this, did the whole vista compatibility thing, I dont have a password, however it keeps asking me for one.. any ideas? this is after I hit *take screenshot*

    I mean, I open, check OK, left the password black, crackpic opens, I hit take screenshot, and then I get incorrect password
    Last edited by rachel0179; 11-07-08 at 07:44 PM.
    11-07-08 07:11 PM
  17. rachel0179's Avatar
    No need to answer I actually found crackutil, which does the trick perfectly
    11-07-08 10:32 PM
  18. azbryan's Avatar
    I just got this, did the whole vista compatibility thing, I dont have a password, however it keeps asking me for one.. any ideas? this is after I hit *take screenshot*

    I mean, I open, check OK, left the password black, crackpic opens, I hit take screenshot, and then I get incorrect password
    Yeah me too. I don't have a password so I dunno what the issue is...
    12-19-08 09:37 AM
  19. jeffh's Avatar
    As rachel0179 posted, CrackUtil will also take the screen picture. You can download it from my sig. You should try it.
    12-19-08 10:04 AM
  20. tekjargon's Avatar
    Wow, thanks. I love the simplicity of the program!
    01-02-09 02:23 PM
  21. Pete6's Avatar
    It was designed to do just one thing.
    01-02-09 02:25 PM
  22. mcangeli's Avatar
    It was designed to do just one thing.
    And it does it well on my bold!
    01-06-09 11:13 AM
  23. username0022's Avatar
    Hate to be a broken record, but thanks for the app. Very clean and simple.
    01-06-09 11:20 AM
  24. hudres's Avatar
    Is CrackPic compatible with the 9530 Storm running OS .85?

    Thanks 73
    01-11-09 10:56 PM
  25. LifeOfVice's Avatar
    Very cool program!
    01-12-09 12:05 AM
64 123
LINK TO POST COPIED TO CLIPBOARD