1. bdr127#CB's Avatar
    I just got a new Curve 8330 and wanted to install the latest desktop software v4.5 on Windows XP SP2.

    I previously had a 7250 and then a 8703e. At the time I got the 7250, I installed desktop software v4.2. When I got the 8703e, I installed the software from its CD which is entitled "BlackBerry v4.1.0 for the 8703e Series Wireless Device". Both are currently showing in Windows "Add/Remove Programs".

    When I try to uninstall desktop software v4.2, it prompts me for the "BlackBerry Desktop Software 4.2 disk". I don't have a disk (I can't even remember if I installed it off a CD or from the web), so I downloaded v4.2 from Blackberry's website and tried to re-install it with the hopes that it would unpack the install files or something so I could trick the uninstall program into thinking I had the CD. No such luck... It tells me I have a newer version already installed.

    OK, so I try to uninstall the 8703e software, and it prompts me for "BlackBerry 8703e.msi" which is not on my computer anywhere. I actually have the install CD, so I pop that in and look for that file.... Nope, not on the CD. I even try pointing the prompt to the msi install file that is there ("BlackBerry Desktop Software.msi" ), but it doesn't accept it. Thinking that maybe I can re-install the software to see if it unpacks that necessary msi file, it tells me that I have a newer version already installed. (Presumably the two versions are looking at each other, thinking the other is the newer version.)

    I tried installing a newer version, with the hopes that perhaps it would automatic uninstall or overwrite the older versions. When it gets to the end of the installation process for v4.5, it wants to uninstall v4.2 and asks me for the disk. The same message I got when I tried to uninstall it by itself.

    This is really frustrating... I can't uninstall the older versions, and I can't even install the newer version! I'm basically in an endless circle. Can anyone please help me with this? Thanks in advance!
    07-27-08 04:28 PM
  2. Spawn#CB's Avatar
    I'm experiencing the same problem after trying to use my Bell Mobility 8703e as a tethered modem. I installed the Bell Mobility Voyageur software, and then restarted my laptop, and then was prompted exactly as you are being prompted. Unable to find this mysterious "Blackberry 8703e.msi" file. Tried downloading a newer version and it won't install due to the previous version being installed and being unable to uninstall it.
    It's very frustrating to be caught in a vicious circle like this where you can't install or uninstall! I'm at the point where I'd be happy just to get rid of the message and not worry about having anything installed for it! If someone out there is able to help, please let me know!
    12-17-08 07:02 PM