1. sibex's Avatar
    i have a blackberry 8900 ... i had to have mine replaced due to a fault. my new handset has been registered with my provider which is Orange all the services books are up to date. on my previous handset when i went on to the brower it took me straight to the blackberry home page where you could for instance download a few freeringtones pic's etc etc etc and you could go to certain sites i.e if i went to the sports section it to you to another page where you could access the bbc site or the espn site well with my new phone when i try to do that i get the following message


    thanks for visiting http//mobile.blackberry.com

    your destination to get free stuff for your blackberry smartphone

    such as themes,wallpapers,ringtones and more, unfortunately your

    current device and/or browser are not compatable for this site


    Any suggestions please?

    Simon.
    08-25-09 06:25 AM
  2. BioSciBerry's Avatar
    The same thing happens to me! I have a curve 8330 and have trying to get to the free games on that site but keep on getting the same page as you.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-25-09 07:49 AM
  3. mark-d's Avatar
    Make sure your browser is set to identify as Blackberry instead of Internet Explorer or Firefox

    Posted from my CrackBerry at wapforums.crackberry.com
    08-25-09 08:55 AM
  4. kinmod's Avatar
    I don't have that option in General Configuration....I only have wap, hotspot, and internet......
    08-25-09 09:19 AM
  5. mark-d's Avatar
    You're WAP browser would be the equivalent to my Orange World browser.

    Before careful as there may be a possibility of being charged for data used via the WAP browser as this may be deemed outside your BB data plan allowance.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-25-09 12:16 PM
  6. Dman868's Avatar
    I am having the same problem every time I start the browser. I am configured as Blackberry under browser identification and have tried battery pulls, OS reloads etc. etc.

    The only thing that I can think of is that I purchased my phone through my wife's company that has BES service for its employees. But my phone was never connected to the BES. I took it to the service provider for connection to BIS.

    Did any of you other guys that are having this problem get your phone in a similar way? What I am wondering is if my wife's IT department that blocked access to this page before I got the phone.

    Also when I compare the options/about screen on my phone to friends identical phones obtained from the same provider my Branding version is different.

    My branding version is 1.0.3.161 and theirs is 1.156.179.248. All other software versions are the same.
    09-24-09 12:53 AM
LINK TO POST COPIED TO CLIPBOARD