1. Codulate's Avatar
    I have a Blackberry 8310 curve "smartphone...." (AT&T) I can recieve SMS messages and reply to them. I can initiate SMS messages IF I use the "Use Once" option and then type in the number I am sending to. The problem is I cannot send a message from my address Book (Contacts). If I click on a name and SMS the name (Compose SMS), I get the check mark that it has sent, but the messages end up somewhere in cyberspace (I suspect). I have pulled the battery while the phone is on and waited the mandatory 1 minute (sometimes more) to no positive result. My SMS settings look like this:
    Disable Auto Text: NO
    Leave Messages on SIM Card: Yes
    delivery Reports:OFF
    Validity Period: Max
    Sent As: Text
    Data Coding: 7 BIT
    Service Center: (nothing there)
    network to Send over: GSM
    Number of Previous Items: 7

    Any help will be graciously appreciated (I am new to this phone and forum, so I apologize inadvance for any protocol errors) Thanks
    09-25-09 10:36 AM
  2. btushar's Avatar
    1. Ask your carrier for service center number
    2. Enable Delivery Reports so that you will be sure that your messages was delivered.
    09-25-09 07:37 PM
  3. Codulate's Avatar
    As it turns out the issue was with "Smart Dialing." I discovered this completely by accident. What I didn't know was the phone "Smart Dialing" Feature was defaulted to Trinidad and Tobago (+865) so that every call from the address book or message sent had a prefix attached (+865). I corrected this by pressing on the green call button then clicking on the dotted options button. Scroll down to options then to Smart Dialing. Next click on the country code list, and go to the very top there is an "Unknown" option, save that and like magic no more prefix on calls or SMS messages from my address book....what a headache that was...
    09-25-09 10:25 PM
LINK TO POST COPIED TO CLIPBOARD