1. Foozkin's Avatar
    Hi,

    is there any way i can set up my phone to use wifi for data only and make calls go over the cell network? ive been trying for hours to find how to make this work. i went to options-mobile network and set the connection pref to mobile network preferred but then it never connects to wifi for web browsing.

    Thx, Fooz
    10-06-09 05:21 AM
  2. jamesshuford's Avatar
    I'm not sure. I thought that by using UMA you had a better connection for making calls.
    10-06-09 05:55 AM
  3. Radius's Avatar
    I'm not sure you can just switch UMA off like that. What's the reason anyhow, costly data plan?

    Posted from my CrackBerry at wapforums.crackberry.com
    10-06-09 07:28 AM
  4. visualpurple's Avatar
    mobile network options > connection preference > mobile network only

    will turn off UMA and leave wifi for browsing.

    FYI, radius, I turned off UMA because it gave terrible call quality at home.
    10-06-09 09:00 AM
  5. 3CISSBB's Avatar
    mobile network options > connection preference > mobile network only

    will turn off UMA and leave wifi for browsing.

    FYI, radius, I turned off UMA because it gave terrible call quality at home.
    Take a look at my UMA setup guide in my sig. I wrote that for people having problems like yourself.
    10-06-09 11:17 AM
  6. Foozkin's Avatar
    mobile network options > connection preference > mobile network only

    will turn off UMA and leave wifi for browsing.

    FYI, radius, I turned off UMA because it gave terrible call quality at home.
    this doesnt make any difference. the wifi logo stays dim and calls connect to edge.

    i dont want to disable uma, just prefer the cell network for calls and prefer wifi for data. it actually worked this way for a long time when i first got my phone a few months ago. actually i made some change to the settings to make it work that way but i forgot what it was. i think i read about the config on crackberry somewhere but i cant find the post anymore.
    10-06-09 05:45 PM
  7. visualpurple's Avatar
    this doesnt make any difference. the wifi logo stays dim and calls connect to edge.

    i dont want to disable uma, just prefer the cell network for calls and prefer wifi for data. it actually worked this way for a long time when i first got my phone a few months ago. actually i made some change to the settings to make it work that way but i forgot what it was. i think i read about the config on crackberry somewhere but i cant find the post anymore.
    UMA refers to calls over wifi. If you do what I say, then calls will only be sent out over the mobile network (edge) and not wifi. The wifi logo stays on because your wifi module is still turned on. Trust me, this is the setting to turn off UMA for calls but leave wifi preferred for browsing.
    10-06-09 07:57 PM
  8. gm85's Avatar
    this doesnt make any difference. the wifi logo stays dim and calls connect to edge.

    i dont want to disable uma, just prefer the cell network for calls and prefer wifi for data. it actually worked this way for a long time when i first got my phone a few months ago. actually i made some change to the settings to make it work that way but i forgot what it was. i think i read about the config on crackberry somewhere but i cant find the post anymore.
    I agree with visualpurple. If you set your connection preference to Moblile Network Preferred, or Mobile Network Only, then your calls will be routed over the Mobile Network, but the data will be routed over WiFi (Blackberrys are set up to take advantage of WiFi for data whenever WiFi is is available).

    If you are getting a gray WiFi symbol, this is a separate issue. If it is grey, your phone is not connected to the blackberry infrastructure over WiFi (you either have a WiFi, internet or service problem). If you have your phone set to WiFi Preferred or WiFi only (thus enabling UMA), is your WiFi symbol white?

    EDIT: If you are having connection problems over WiFi, go to Manage Connections > Wi-Fi Options > (BB Key) > Wi-Fi Tools > Wi-Fi Diagnostics

    Your WiFi logo turns white when you get three checkboxes under Blackberry Infrastrcture (Connecting, Authenticating Router, Authenticating Server). This of course assumes you have a Blackberry (BIS) plan associated with your phone.
    Last edited by gm85; 10-06-09 at 10:43 PM.
    10-06-09 10:33 PM
  9. aristile's Avatar
    I agree with visualpurple. If you set your connection preference to Moblile Network Preferred, or Mobile Network Only, then your calls will be routed over the Mobile Network, but the data will be routed over WiFi (Blackberrys are set up to take advantage of WiFi for data whenever WiFi is is available).

    If you are getting a gray WiFi symbol, this is a separate issue. If it is grey, your phone is not connected to the blackberry infrastructure over WiFi (you either have a WiFi, internet or service problem). If you have your phone set to WiFi Preferred or WiFi only (thus enabling UMA), is your WiFi symbol white?

    EDIT: If you are having connection problems over WiFi, go to Manage Connections > Wi-Fi Options > (BB Key) > Wi-Fi Tools > Wi-Fi Diagnostics

    Your WiFi logo turns white when you get three checkboxes under Blackberry Infrastrcture (Connecting, Authenticating Router, Authenticating Server). This of course assumes you have a Blackberry (BIS) plan associated with your phone.
    WOW ... so a bunch of bad information here.

    For starters, if you want to have the Browser to use the WiFi Connection instead of the Mobile Network connection then you need to adjust the settings for that:

    Browser > BB Button > Options > Browser Configuration > Browser = Hotspot
    Browser > BB Button > Options > General Properties > Browser = Hotspot

    Secondly, A Grey WiFi symbol has nothing to do with UMA. If your WiFi Symbol is gray then it isn't connected properly to the WiFi network. In this case, check the WiFi Guide link in my signature to get that sorted out. If you do have a good WiFi Connection but still have issues with UMA then check out the UMA Guide link in my signature.

    UMA and WiFi are separate but related services. You can have a WiFi connection without UMA but you cannot have a UMA connection with out WiFi. Also, a Blackberry Data Plan is required for full UMA functionality.
    10-07-09 01:04 AM
  10. sdomingues's Avatar
    I have said this a few times and noone seems to listen or agree but you DO NOT need to switch to the Hotspot browser to browse over WiFi. If you are connected to a WiFi network, the browser will send data over the that network. I have proven this many times, I just tried again for my own piece of mind.

    I am connected to my wireless network, chosen "Mobile network ONLY" (no UMA) and turned off the mobile network radio. So my radio says OFF and WiFi is on. Now go into the browser and access any page that I goto and check which browser it's using and it is "Internet Browser".

    You can even just tell by the speed and watching the activity on you router/modem. Even with the mobile radio turned on, you are still downloading over the wireless network.

    The hotspot browser is for certain "Hotspots" like in Starbucks and such where you need to log in in order to access the WiFi Hotspot. The browser will *automatically* switch to hotspot if/when it needs to.

    Automatic Hotspot Browser selection

    The BlackBerry smartphone automatically selects the Hotspot Browser whenever the BlackBerry smartphone user attempts to access a non-routable Internet Protocol (IP) address. These addresses are widely used in private networks such as those operated by hotspot service providers, home networks, and enterprise local area networks. A non-routable IP address falls in the following ranges:

    10.0.0.0 - 10.255.255.255
    172.16.0.0 - 172.31.255.255
    192.168.0.0 - 192.168.255.255


    The above is directly out of a RIM knowledge base update for WiFi in the 4.6 OS.
    10-07-09 05:59 AM
  11. jamestbrewer's Avatar
    I had a similar problem last month where I could connect to the wifi network, but the logo would stay grey. Took me a while to figure it out but it just needed the service books to be resent to the phone.
    10-07-09 07:08 AM
  12. DogFromHell's Avatar
    All, I have WiFi and UMA (I work from home it's my VOIP line). To use the EDGE network set your Mobile Network Options to Mobile Network Only under Connection Preferences. To use the WiFi for browsing you do not need to turn it to Hotspot Browser (ask T-Mobile, Hotspot Browser is the Pay Service for when you are at a Tmobile Hotspot location, Hotspot locations do not include your own personal WiFi network, nor a free WiFi network floating about, it is a subscription you pay for, basically it's WiFi in locations you don't live), just connect it to your WiFi. Trust me on this all of you I know more about UMA service and BlackBerry's interactions with them than the UMA PDA Support Team at T-Mobile does! I had major issues in the past with my UMA service. I got a new Router had my ISP redrop and clean the lines to my house, and I made T-Mobile send me a brand new 8900 to replace my 8120 that was having UMA issues and dropping calls regulary.

    I got my 8900 yesterday and besides the UMA network in my area failing (T-Mobile is having issues the last couple of days) it has worked great all morning. I was even on UMA with no Lag for a bit before the network issues at T-Mobile dropped my UMA connection. Hope this helps all.
    Last edited by DogFromHell; 10-07-09 at 01:11 PM. Reason: Adding more...
    10-07-09 01:06 PM
  13. aristile's Avatar
    I have said this a few times and noone seems to listen or agree but you DO NOT need to switch to the Hotspot browser to browse over WiFi. If you are connected to a WiFi network, the browser will send data over the that network. I have proven this many times, I just tried again for my own piece of mind.

    I am connected to my wireless network, chosen "Mobile network ONLY" (no UMA) and turned off the mobile network radio. So my radio says OFF and WiFi is on. Now go into the browser and access any page that I goto and check which browser it's using and it is "Internet Browser".

    You can even just tell by the speed and watching the activity on you router/modem. Even with the mobile radio turned on, you are still downloading over the wireless network.

    The hotspot browser is for certain "Hotspots" like in Starbucks and such where you need to log in in order to access the WiFi Hotspot. The browser will *automatically* switch to hotspot if/when it needs to.

    Automatic Hotspot Browser selection

    The BlackBerry smartphone automatically selects the Hotspot Browser whenever the BlackBerry smartphone user attempts to access a non-routable Internet Protocol (IP) address. These addresses are widely used in private networks such as those operated by hotspot service providers, home networks, and enterprise local area networks. A non-routable IP address falls in the following ranges:

    10.0.0.0 - 10.255.255.255
    172.16.0.0 - 172.31.255.255
    192.168.0.0 - 192.168.255.255


    The above is directly out of a RIM knowledge base update for WiFi in the 4.6 OS.
    Actually, yes you do need to adjust the settings. The reason that it switches automatically for you is because you have UMA through your provider. Not all users have UMA and so the settings need to be adjusted automatically. Trust me, I do not have UMA and I know from personal experience.

    Also, the "Hotspot" Browser is not for Starsucks, etc. It is for WiFi Browsing. Check the "Browsers Explained" link in my signature for more information.
    10-07-09 02:10 PM
  14. sdomingues's Avatar
    To use the WiFi for browsing you do not need to turn it to Hotspot Browser (ask T-Mobile, Hotspot Browser is the Pay Service for when you are at a Tmobile Hotspot location, Hotspot locations do not include your own personal WiFi network, nor a free WiFi network floating about, it is a subscription you pay for, basically it's WiFi in locations you don't live), just connect it to your WiFi.
    Exactly, this is what I am trying to say. When you are at home you are not on a "Hotspot". A hotspot is service that you have to log into in order to gain access.

    And the italic part of my last post is out of a RIM knowledge base...and clearly says that it *automatically* selects the Hotspot browser when it needs to.
    Last edited by sdomingues; 10-07-09 at 04:35 PM.
    10-07-09 04:33 PM
  15. sdomingues's Avatar
    Well I had UMA off when I tested all this and will definitely say that if it's because of the UMA and without UMA you have to manually change the browser...that is a rediculous design!!
    That would just make me angry if that's the way it is...oh well, at least some of us don't have to deal with that!
    10-07-09 04:44 PM
  16. aristile's Avatar
    Its not ridiculous at all. The functionality is so that you have full control of what your device is doing, not the other way around.
    10-07-09 05:37 PM
  17. vdubguy2k's Avatar
    I'm kinda confused, maybe because I didn't read each reply completely.....but going into mobile network options and setting it to "mobile network only" works perfect for me. When I go to work I don't have control over the wireless and the UMA sucks, but data works great....so I just do that and my data goes over wifi and voice stays on cell towers. I have some speed test app on my berry and have confirmed beyond doubt my data is going through the wifi. I don't have to make any changes to my brower or anything either.
    10-07-09 06:26 PM
  18. Miss Chaos's Avatar
    I'm pretty much having the same problem with the UMA. I want to be able to use my home wifi because at the present time I had to take away my data plan because I cant afford it right now. But I cant seem to get my phone to connect without the UMA... By the way the phone I have is the 8520 with Tmobile
    10-20-09 03:12 AM
  19. Pete6's Avatar
    This thread is a bit of a failure. Everyone is trying hard but I don't think that the OP has an answer and part of the problem comes from not talking from a common base.

    I am not a T-Moble customer and am not familiar with UMA calling.

    The phone has two seperate connections over the GSM network. The phone signal and the data connection. You can make phone calls and send SMS messages without a dataplan but you cannot use the internet unless you have a dataplan.

    EDGE is displayed when your dataplan is fully working and connected. If you see edge (lowercase) then the signal is being detected but the phone cannot use the dataplan. Sometimes in poor signal areas or crap coverage areas or due to network faults, the EDGE sign will change to GPRS which will still give you data coverage but with slower throughput. lowercase gprs means the same as lowercase edge.

    WiFi on an 8900 has three states. Off (no WiFi icon), On but not connected to a WiFi Access point (gray WiFi icon), On and fully connected (white WiFi icon). WiFi can generally be used with or without a dataplan for general browsing and some apps can make use of WiFi without a dataplan. Once connected ti WiFi, on T-Mobile, UMA becomes available for calls and here my knowledge fails so I'll quit while I'm ahead.

    UMA will not work at all if you do not have a dataplan and a calling plan. After all, someone has to pay for your calls.

    Perhaps others can build on what I don't know about UMA calling.
    10-20-09 03:42 AM
  20. Pete6's Avatar
    I'm pretty much having the same problem with the UMA. I want to be able to use my home wifi because at the present time I had to take away my data plan because I cant afford it right now. But I cant seem to get my phone to connect without the UMA... By the way the phone I have is the 8520 with Tmobile
    Welcome to Crackberry.

    You posted in the 8900 forum and not in the 8520 area. Actually it doesn't matter since you found the correct thread for your problem. I'll leave your post where it is and I hope you find an answer.

    Have a look over in the 8520 forum here http://forums.crackberry.com/f143/ for discussion specific to your phone.

    Crackberry is a biiig place so have a scout around and check out the 101 lecutures as well as the general Blackberry discussion.
    10-20-09 03:47 AM
LINK TO POST COPIED TO CLIPBOARD