1. hlevin's Avatar
    ***This was posted as a response in the Bold forum. Wish I'd looked to see if there was a WiFi forum first......

    Well, I'm all connected to my WiFi with an IP address, good signal, and good network status, but I can't even ping myself when I try it. No matter what I do, the WiFi icon stays gray. I tried turning off bluetooth as suggested in some other posts and for a minute, that seemed to do it, but then it just fell back to 3G. When I look at my connection status, I see that Wifi is on and I'm connected to my home network (and the router sees me as well), but I never seem to get the elusive green check mark.

    I'm running .167 and this is a brand new AT&T Bold (well, a week old, but who's counting?). Any help? This is starting to make me angry.....

    UPDATE: When I looked at the WiFi diagnostics, I had a little red X next to Connecting for Enterprise and the same for BlackBerry Infrastructure. I turned off the Mobile Network Connection (i.e., disconnected from AT&T) and WiFi became active and I got a connection to BlackBerry Infrastructure (whatever that is). At that point, I could actually ping my router and myself, but still not reliably (a few timeouts, which is what I get all the time when my AT&T connection is active). I still could not get the Hotspot web browser to connect like that, which I assume has something to do with AT&T crippling the browser if your data connection isn't up. Any thoughts out there?

    UPDATE 2: I was in a local coffee shop and hooked up to WiFi with no problem at all. Browsed the web and everything. The only 2 things I see differently on my home network are WEP and that there is another open network in range using the same channel. The channel thing doesn't bother all my other wireless devices. Anyone?
    Last edited by hlevin; 11-13-08 at 02:54 PM.
    11-13-08 10:59 AM