1. sphogat's Avatar
    I have a fairly new BlackBerry Pearl Flip 8220 and all of a sudden, out of nowhere, my bluetooth stopped working. if i go to Manage Connections, and try to turn it on, it processes for a second and then nothing happens, and the box doesn't check. The Set-Up Bluetooth menu has the usual Add Device by Search, Listen or Cancel menu, but nothing happens because it says Bluetooth: Disabled on the top, and won't enable, even if i try to Search or Listen. The Bluetooth Options page is completely blank except the top which says, Bluetooth: Disabled. I can't add any devices at all, and other devices and phone can't find me. It used to work fine and all of a sudden it just died. Also, in Settings->Options->Advanced Options->Default Services, the page is also blank. I thought I'd reset the phone that way but it's blank so i can't. I tried to do a battery pull, and also disabled the Bluetooth for a while and tried to enable it but it won't work. The Mobile Network and Wi-Fi work fine though. Any ideas? I'm running Desktop Manager 4.7. Also about a month ago, my phone got a bit wet during a concert, but it worked fine after being a little glitchy for a few hours, then the next day it died, and didn't work for about a week because the backlight was dead. it works fine now, but suddenly the bluetooth is dead. the batter water indicator is pink, but the phone water indicator is almost completely white..it has a tiny pink spot in a corner but perfect besides that...any ideas?
    06-15-09 07:05 PM
  2. zwood's Avatar
    I would try upgrading the OS and see if that works, if not then it may be a hardware issue. Backup fist and don't let DM backup and restore your phone during the upgrade so you can test it fist with a clean install. Later after testing you can restore the backup you made, this will rule out 3rd party app conflicts or corrupt settings.
    06-15-09 08:48 PM
  3. mpgerber's Avatar
    Your bluetooth functionality is hammered. Don't spend alot of time messing with the software. You need a replacement phone.

    I had exactly the same thing happen.....right in the middle of a streaming song the bluetooth disabled and would "enable" never again. Hours troubleshooting. Hours with T-Mobile BB tech support..super shocker they've never heard of the problem before. Run a google search. It's happened many times before.

    I just received my replacement 8220 and it has another bluetooth problem....separate post.
    06-24-09 08:48 AM
  4. sphogat's Avatar
    Your bluetooth functionality is hammered. Don't spend alot of time messing with the software. You need a replacement phone.

    I had exactly the same thing happen.....right in the middle of a streaming song the bluetooth disabled and would "enable" never again. Hours troubleshooting. Hours with T-Mobile BB tech support..super shocker they've never heard of the problem before. Run a google search. It's happened many times before.

    I just received my replacement 8220 and it has another bluetooth problem....separate post.
    hmm...good call! thanks for your help!
    06-25-09 06:23 PM
  5. morlie822's Avatar
    Yep, New phone is the route to go. I had the same thing happen; bluetooth would not enable.

    I took it to a T-Mo store and they did the warranty exchange there, but first they had me do the backup so most everything was in place when I did restore on the new phone.
    06-25-09 08:22 PM
  6. gretchenb25's Avatar
    I am having problems with my bluetooth too. I thought it was "user error". i took phone into the store and they said it's a software issue. Talked to tech support w tmobile and said to upgrade the os. did it...still not fixed. i am getting upset. i love my phone otherwise. I just want it to work darn it why does everything take upgrades/installs/reinstalls and lose info/and still not work!!! ARGH. I don't want to have to get a new phone and transfer all my junk just to have another phone w same problem. this is annoying. can't i just pay one of you people to fix this? $100bux anyone?
    08-06-09 08:32 PM
  7. gretchenb25's Avatar
    any other great ideas? I love my phone and want to keep it. I need bluetooth though. i tried upgrading to the tmobile new version 4.0.6.181 but bluetooth is still 1.1 version. can't i just reload the bluetooth or upgrade that function and fix this bug? gretchenb25 at yahoo com
    08-10-09 07:37 PM
  8. gretchenb25's Avatar
    oh I "wiped" the phone and downloaded the new os per tmobile's instructions. now i've got nuttin on this phone but bare minimum until i can try to get this bluetooth reloaded....somehow.
    08-10-09 07:39 PM
  9. gretchenb25's Avatar
    so does the new phone have bluetooth issues now too?
    08-10-09 07:39 PM
  10. gretchenb25's Avatar
    Yep, New phone is the route to go. I had the same thing happen; bluetooth would not enable.

    I took it to a T-Mo store and they did the warranty exchange there, but first they had me do the backup so most everything was in place when I did restore on the new phone.
    so did the new phone work correctly? just wondering 'cause they are sending me a new phone too. oh, and they had never heard of this phone having a problem like this before.....weird huh? :-)
    08-10-09 07:42 PM
  11. JAR1's Avatar
    The phone is 2 months old. My bluetooth quit also. Had it going once and lost it again. New phone is on the way. Canada [Telus] I thought it might be the GE Cell Fusion house phone doing it, but after reading your posts I'm not so sure.
    08-13-09 09:51 AM
  12. lifeinview's Avatar
    My daughter's phone did the exact same thing this week. Spent hours on the phone with Tmobile and RIM bb support staff. Finally, they decided that it must be the phone and are sending her a new phone. Wish I had seen these posts before the marathon phone calls.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 10:36 PM
  13. SaabScott's Avatar
    I was just having the same problem with my 8220 and BT.

    Called the Rogers support line.
    Got a tech who knew his stuff cold and he walked me through a wipe and reinstall.
    Asked me to test the BT once the reinstall was done but before restoring my stuff.
    BT connected no problem.

    Restored all of my data and custom settings, BT is still on without issue.

    I've also noticed that my phone is responding faster now.

    I guess I'm one of the "lucky" ones.
    10-25-09 12:14 PM
  14. ctgo4it's Avatar
    I have the same problem. Today, in the middle of a call the bluetooth shut off, and it won't let me enable again. I tried upgrading the software (to v4.6.0.305) and still nothing.

    The problem is, I have an unlocked flip with AT&T and I'm not sure who i can call for help with this. I believe there is a warranty from RIM, but the only way for me to contact them is through AT&T. Anyone have any ideas?

    Thanks
    10-28-09 12:30 AM
  15. Bajanbastard's Avatar
    Its a common flip problem it seems. I have a friends flip here that has this issue and another friends BT stopped working the 2nd day after he got it.
    10-29-09 04:28 PM
  16. morlie822's Avatar
    If you have a Pearl flip and the Bluetooth stops working, don't mess with trying to upgrade the system or hours on the phone with "Service", or "Support". You simply need a replacement phone. Plain & simple, no if's and's or but's, take it to a Service Center/Store and ask for a warranty replacement.
    10-31-09 08:32 PM
  17. SaabScott's Avatar
    If you have a Pearl flip and the Bluetooth stops working, don't mess with trying to upgrade the system or hours on the phone with "Service", or "Support". You simply need a replacement phone. Plain & simple, no if's and's or but's, take it to a Service Center/Store and ask for a warranty replacement.


    Can't always do that.

    Mine crapped out on me again on Sunday (we just passed a handheld devices law in Ontario recently so it became a necessity).

    I called Rogers that night and she just looked at the file "it says here if it happens again just to replace it".
    I got the phone today (less than 48 hours later) when they say 3-5 business days.

    Battery is charging ... will do everything with it tonight to set it up.

    Now to go look for some protective covering for it ... didn't like the way the original held up to scratches, etc.
    11-24-09 02:33 PM
  18. SaabScott's Avatar
    Phone replaced, all good ... except that I can't receive e-mail on it now.

    I will be calling tech support this evening to see what they suggest.
    11-25-09 04:15 PM
  19. SaabScott's Avatar
    Phone replaced, all good ... except that I can't receive e-mail on it now.

    I will be calling tech support this evening to see what they suggest.


    Tech support to the rescue.
    All set up and receiving e-mails in a couple of minutes.
    11-26-09 05:53 PM
  20. Sistastrong1's Avatar
    I currently have this issue and have seen many posts of users with other models having the same issue. I have updated the software, OS, done pulls, nothing works! Any rumors if rim is doing something about this? I have seen numerous posts were the only consistent thing is they had to replace the phone. Even then it has gone out again on people! I love my BB but I have come to need my bluetooth functionality
    12-12-09 12:33 AM
  21. itsivan's Avatar
    I got a Bold 2 just a few weeks ago and the same problem happened to me. Now I can't enable bluetooth. If I go to manage connections there will be a box for me to enable bluetooth. but no matter how many time I click it just won't check.

    what should I do now?
    12-28-09 03:58 PM
  22. M_rk's Avatar
    Guys anyone here having problems with bluetooth connectivity with other Mobile phone brands??

    i have no problem sending data (pics/mp3s) from my BB 8520 to a Nokia for example, but vice versa, my BB on the receiving end, the other phone will display connection failed.

    i paired the devices before trying and even used a third phone, LG KS360 to isolate the issue, but it gets the same error when im sending from it.

    Bluetooth icon comes up, it scans and pairs, but just wont receive data!!!

    what could be causing this???
    12-30-09 11:54 AM
  23. mbellot's Avatar
    Guys anyone here having problems with bluetooth connectivity with other Mobile phone brands??

    i have no problem sending data (pics/mp3s) from my BB 8520 to a Nokia for example, but vice versa, my BB on the receiving end, the other phone will display connection failed.

    i paired the devices before trying and even used a third phone, LG KS360 to isolate the issue, but it gets the same error when im sending from it.

    Bluetooth icon comes up, it scans and pairs, but just wont receive data!!!

    what could be causing this???
    I've got a very similar problem with my BB 8350i.

    It pairs/connects with my laptop (Lenovo W500) no problems and can successfully send data (contacts, pics and ringtones) but absolutely refuses to receive anything.

    The same laptop has no issues sending pics and ringtones to a Moto i465 Clutch via BT, so I have to believe there is something whacked with the BB when it comes to receiving data via BT.

    12-30-09 02:15 PM
  24. pasky210's Avatar
    I currently have this issue and have seen many posts of users with other models having the same issue. I have updated the software, OS, done pulls, nothing works! Any rumors if rim is doing something about this? I have seen numerous posts were the only consistent thing is they had to replace the phone. Even then it has gone out again on people! I love my BB but I have come to need my bluetooth functionality
    I have the same problem.but why haven BB done any thing to fix this.
    04-19-12 07:46 PM
  25. kgntechnologies's Avatar
    Some times Blackberry Bluetooth is not catch in within area range . it is a big Problem For Blackberry Users

    Magento Development
    Wordpress Development
    05-18-12 01:45 AM
LINK TO POST COPIED TO CLIPBOARD