1. jackyindubai's Avatar
    Everytime I replace my battery i get a message on my blackberry torch saying "A media card has been inserted that contains errors. Do you wish to repair the media card now?" then when i click yes message says if lost clusters are found during repair, do you want to save them? then i click yes the a message comes up saying media repair failed

    Can someone tell me what this means and how i can fix this please?
    06-02-11 01:55 PM
  2. ethylove's Avatar
    this exact same thing just happened to me and I've had a working media card in my torch for MONTHS. I'm currently reloading the OS and hope that works. I had to reformat the media card on my PC to wipe it... AGH I'm going into ATT tomorrow as my phone won't receive emails either and then the media card craps out. plus I've been getting a million java error's that battery pulls do nothing for.
    06-05-11 02:27 AM
  3. ngoogs's Avatar
    I'm having that same problem with my curve. Can't figure it out arrRrgggg!!

    Posted from my CrackBerry at wapforums.crackberry.com
    06-05-11 07:46 AM
  4. thecoach1999's Avatar
    Everytime I replace my battery i get a message on my blackberry torch saying "A media card has been inserted that contains errors. Do you wish to repair the media card now?" then when i click yes message says if lost clusters are found during repair, do you want to save them? then i click yes the a message comes up saying media repair failed

    Can someone tell me what this means and how i can fix this please?
    What type of card are you using?
    06-05-11 08:13 AM
  5. sleepngbear's Avatar
    Suggestion:
    Connect your BB to a pc and copy everything from the media card to a temporary location on the pc.
    Eject and disconnect the BB, then reformat the media card (Options >Device > Storage > Menu > Format > Media Card).
    Before moving files back, do a battery pull and see if the errors show up again. If they do, you've probably got a bad card and it needs to be replaced. If no errors, you should be able to reconnect and copy your files back.

    Hope this helps.
    ppw123 likes this.
    06-05-11 08:19 AM
  6. thecoach1999's Avatar
    My 16gb gives me this error but my 4gb doesn't. Used 16gb in other devises and no problem.

    What I did to fix my issue was to reformat card and the error went away. This error seems to pop up everytime I do an upgrade.
    06-05-11 08:39 AM
  7. mark-d's Avatar
    I've had the same problem as well but I said no to the fix, ejected the card from the BB, put it into the SD card adaptor and straight into the laptop and run a Scandisk on it. Absolutely no errors detected.

    Strange but it happened again the next time I rebooted as well but has only happened twice and touch wood not for a while!
    06-05-11 08:42 AM
  8. ppw123's Avatar
    Sleepnbear suggestion fixed it, get the message after every upgrade RIM issue nothing wrong with card. Thanks SB
    reformat the media card (Options >Device > Storage > Menu > Format > Media Card).
    06-08-12 10:23 PM
  9. Rahman Edo's Avatar
    What type of card are you using?
    11-27-13 05:41 AM
  10. Rahman Edo's Avatar
    Everytime I replace my battery i get a message on my blackberry torch saying "A media card has been inserted that contains errors. Do you wish to repair the media card now?" then when i click yes message says if lost clusters are found during repair, do you want to save them? then i click yes the a message comes up saying media repair failed

    Can someone tell me what this means and how i can fix this please?
    11-27-13 05:43 AM
LINK TO POST COPIED TO CLIPBOARD