1. emperoradz's Avatar
    This is exactly what I tried so far:

    1) Installed Desktop Manager 4.7 from the Blackberry Website
    2) Installed OS version 4.1.0.534 from the "Software Download for Nextel Communications Inc." download page for the 7520
    3) Connected BB to computer. It shows the hourglass for around 5-6 seconds, and gives a 507 error.
    4) I went to update. It asked me for the password, which I entered.
    5) It asked which software to install. I just chose BB 3.1 System Software, Core apps and phone (version 4.1).
    6) Connection to ROM (almost instantaneous, Erasing Applications (around 20 secs), Loading system software (around 20 secs), Waiting for device initialization (15 secs), the 507 error appears, uploading RAM image, connection to boot ROM (hangs for around 10 seconds)

    And I get an error "A fatal error has occurred while updating your device's software. Please try again"

    OK...so I tried to use Jl_Cmdr 1.9.1.
    1) Press the key to continue
    2) Y my bb has a password, entered password
    3) Pressed 4 for wipe. Y I want to continue, typed blackberry. 1 second later goes back to that screen. 507.
    4) Tried the Update again. Same exact thing happened as above.

    Then I tried this on my other comp (my current one runs windows 7, the other runs xp). Same thing happened...Tried doing that fix....disabled power off on all the hubs

    1. On your computer, click Start > Settings > Control Panel.
    2. In the Control Panel, double-click the System icon. The System Properties window opens.
    3. Click the Hardware tab of the System Properties and click Device Manager.
    4. In the Device Manager, double-click Universal Serial Bus Controllers.
    5. Right-click the first USB root hub, and click Properties.
    6. In the Properties window, click the Power Management tab.
    7. Clear the Allow the computer to turn off this device to save power check box.
    8. Repeat for all other USB root hubs.
    9. Restart your computer.


    After that I went into C:\Program Files\Common Files\Research In Motion\AppLoader and did:

    loader.exe /nojvm

    went through the screens...and I noticed a few things:
    1) Where it said "Blackberry 4.1 System Software" the action was UPDATE
    2) Even though I just selected the bare minimum (phone, system software, core apps) it gave an error "This device does not have sufficient storage..."
    3) Tried doing loader.exe (without /nojvm). It did the same thing as with the desktop manager...but now gave an error "

    Unable to communicate with the radio hardware. Please ensure that a charged battery is installed in the device and try the loading operation again. [P:0x0000000F]"

    Interesting huh...

    So what do you recommend I do?


    Edit/Delete Message
    03-21-09 12:09 AM
  2. Heresy's Avatar
    I reccomend uninstalling dekstop manager 4.7. It doesn't play well with devices other than bold and storm. Download DM 4.5 or 4.6 without media manager. Both are stable enough to do what you want to do. Try this on your pc with xp. Do that and see where it takes you.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-21-09 09:14 AM
  3. vndlewis's Avatar
    I agree. Hey rid of 4.7.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-21-09 09:17 AM
  4. emperoradz's Avatar
    thanks for the quick response

    This is what I did (on my Windows 7 Comp):
    1) Uninstalled old Desktop Manager and Device software
    2) Restarted
    3) Downloaded and installed Desktop Software v4.2 SP2 without Media Manager (English) from the website (this btw took a CONSIDERABLY longer time than it did before...don't know whether that plays a role in anything)
    4) Downloaded and Installed BlackBerry Handheld Software v4.1.0.534
    5) Used Jl_Loader to wipe the blackberry (which btw took <2 seconds + around a 10 second restart...)
    6) Deleted Vendor.xml from C:\Program Files\Common Files\Research In Motion\AppLoader
    7) Used Application Loader Wizard to update the blackberry (read radio software configuration took around 20 seconds, selected only the default components, erasing applications around 15, loading system software around 10, waiting for device initialization around to (507 screen...), connecting to boot ROM (around 10) )
    8) error: Unable to communicate with the radio hardware. Please ensure that a charged battery is installed in the device and try the loading operation again. [P:0x0000000F]

    so I went on my xp comp...
    Followed exact same procedure...and minus the 20 second reading radio software config it went exactly the same way...

    Then (only on the XP Computer):
    1) uninstalled BlackBerry Handheld Software v4.1.0.534 and Desktop Software v4.2 SP2 without Media Manager (English)
    2) Decided to give it one last shot and installed Desktop Manager 4.5.0 B17 Multilanguage - Without Media Manager
    4) Asked me to restart, so I restarted
    4) Installed BlackBerry Handheld Software v4.1.0.534
    5) Wiped using Jl_Loader (again took < 2 seconds....)
    6) Deleted C:\Program Files\Common Files\Research In Motion\AppLoader\Vendor.xml
    7) Followed the same exact procedure and before (same exact timing, screens and whatnot showed) aaand fatal error

    Well I am completely out of ideas
    03-21-09 11:54 AM
  5. pkcable's Avatar
    Maybe it's time for a new BB?
    03-21-09 11:58 AM
  6. emperoradz's Avatar
    well...I don't feel like paying for a new bb, paying that monthly fee, etc. I got this bb from a friend and the only thing I use it for is task management, calendar, contact management, games when I'm bored, writing stuff, etc. So getting a new bb + monthly service would kinda defeat the whole purpose...
    03-21-09 12:13 PM
  7. Norsk's Avatar
    Maybe it's time for a new BB?
    This.

    I think there reaches a point where the best solution to a problem is to erase the entire drawing board and start anew.
    03-21-09 12:14 PM
  8. ArmaK's Avatar
    I suggest trying to install the .241 OS and see if the problem occurs. There has been known problems with bricked BBs when trying to update and the error you are getting appears. The only solution was to load the last workable OS back onto the device and then attempting to do the update once again. When attempting to do the installation of .241 use the nojvm option from the command prompt.

    https://www.blackberry.com/Downloads...ED52A8ED6537E1

    Posted from my CrackBerry at wapforums.crackberry.com
    03-21-09 12:52 PM
  9. emperoradz's Avatar
    using Desktop manager 4.2.2 and .241 I get: Unspecified error encountered [A:0x00000001]
    03-21-09 01:42 PM
  10. emperoradz's Avatar
    So....is there any hope?
    03-25-09 07:46 PM
  11. tye dye's Avatar
    Trying to convert a 7520 BB w/Boost , I can't seem to open ( or even find ) the Desktop Manager ( after downloading it three times).
    10-27-09 06:34 PM
LINK TO POST COPIED TO CLIPBOARD