1. Zzoram's Avatar
    So after BIS 2.8, apparently my calender is now 4 colour coded calenders. Device default and my 3 email accounts have calenders. I assume those are synced to the respective calender services offered by the email providers. When I try to enter a new calender item now, I have to choose between the 3 calenders but it doesn't give me the option to create the entry only for my device. Why not? How do I fix this? I never use the calenders from my email providers and I don't want to start.
    10-04-09 01:09 AM
  2. whsbuss's Avatar
    First, the BIS upgrade had nothing to do with multiple calendars linked to your email accounts. If you want to remove the calendars associated with the email accounts, go to Options->Advanced Options->Service Books. There you will find each email account with [ICAL].
    10-04-09 07:02 AM
  3. Zzoram's Avatar
    That may be so, but my calender app never used to have my email calenders in it. Ever since they all merged, I can't create entires specific to my device only. I have to pick one of my emails. Even when I choose to only view the device specific calender it won't let me create a device-only entry.
    10-04-09 05:52 PM
  4. Tom Munch's Avatar
    I finally found the definitive answer to the Device Default Calendar entries. It's in a BlackBerry support article here:

    View Document

    It explains all about how calendar entries are associated with your email accounts & tells you how to fix it when your appointments get moved to the Device Default calendar. You can merge Device Default calendar data with an email account & recover it pretty easily.

    This article would have solved countless hours of frustration for & me & lot of others here.
    10-04-09 07:08 PM
  5. cavingjan's Avatar
    That may be so, but my calender app never used to have my email calenders in it. Ever since they all merged, I can't create entires specific to my device only. I have to pick one of my emails. Even when I choose to only view the device specific calender it won't let me create a device-only entry.
    Your phone was always set up this way unless you did not have any email going to your phone through the BIS/BES servers. With it working properly, you probably just never noticed it.

    Tom posted an article that will help you correct the issue.
    10-04-09 08:56 PM
  6. Zzoram's Avatar
    Your phone was always set up this way unless you did not have any email going to your phone through the BIS/BES servers. With it working properly, you probably just never noticed it.

    Tom posted an article that will help you correct the issue.
    Could you please direct me to that article?

    Also, it was not like this before. The change was sudden and obvious, there is no way I just didn't notice this before. The colour of my entries changed from the old blue to orange, and orange now apparently stands for device default. When creating new entries, the top under "Send Using" has 3 colour options, one corresponding to each email I have set up. There is no option for orange, my device default. Before it used to say Device Default with no options.
    10-04-09 11:48 PM
  7. cavingjan's Avatar
    It is right in Tom's post above mine.

    Blue is the default for the first email address attached to your calendar entries. Trust me, they were attached to an email address (unless you did not have email attached to your phone at all).

    Device Default is used when the email address that was associated with calendar entries is removed from the phone for one reason or another. It is not user selected. Again read the article that Tom posted (post #4) and it will explain it and how to fix it.
    10-05-09 07:56 AM
LINK TO POST COPIED TO CLIPBOARD