1. stefko's Avatar
    Hello Everybody,

    I have a problem with my girlfriends Blackberry Bold 9900. She can't connect to the wifi network at her home. The SSID of this network is hidden. Everytime when i try to connect it says it failed to establish the connection.

    When i try to connect the network with my own HTC Sensations there is no problem. It connects right away.

    The modem here is the SpeedTouch 570i, I know it's not a very new one.
    The SpeedTouch has an registration button on the back wich i activate while i try to connect, but it still fails everytime.

    The SSID is hidden and is not protected with some protocol as WPA or whatever.

    I manually try to set up the network in the blackberry, the option in the menu of SSID broadcasted is set off.

    Does someone have an suggestion of what to do?
    04-15-12 06:56 AM
  2. Jake90087's Avatar
    Go to 'Manage Connections', then scroll down to Wi-Fi network, then other ways to connect, then manually connect to network. then enter your SSID, then security settings and you should be up and running.
    04-15-12 07:26 AM
  3. stefko's Avatar
    Thanks for the suggestion.

    I Try to set it up manually but it still won't connect.
    It searches for like 20 seconds and shows a message of failed to connect..
    04-15-12 09:26 AM
  4. FBA's Avatar
    Your information is a bit vague. When you setup the connection on the 9900...you MUST specify all of the things - such as network security type...ie; WPA/ WPA2 Personal/ WEP etc...

    It would surprise me if there's no security for that hidden SSID.

    Then, you MUST specify the SSID and the actual password you need for this connection. You used the term "whatever" which leads me to believe, you're not setting up the connection as it needs to be.

    I use hidden SSID's on a few of my networks here with my 9900 and it works perfectly.

    At worst case scenario, you can unhide the SSID and try connecting that way...
    04-15-12 09:47 AM
  5. BlackBerry Guy's Avatar
    Also check to see if MAC filtering is being used.
    04-15-12 10:09 AM
  6. stefko's Avatar
    When i set up the network manually through the blackberry bold, i fill in de SSID (which is hidden). In the next screen i have to set in an security protocol, but the network has no security on it, it is open (personal choice where i have no influence on). Besides it is hidden.
    So i choose for open security (no WEP/WPA/WPA2). On this screen i choose for save and connect, the BB searches for the network and failes after 20 seconds.

    There is no MAC filtering, my HTC Sensation connects to the network right away.
    The BB bold connects to the netwerk when the SSID is broadcasted. Then there is no problem.

    For personal reasons it is not possible to set up the network with broadcasted SSID permanently.
    04-15-12 10:24 AM
  7. scarlett67's Avatar
    Hey Stefko, did you ever get your gf's 9930 to connect in her house? I've had this same problem for the past year since upgrading to the 9930. Both prior BB's could connect just fine in the house but not this latest one so I thought maybe it had to do with the new OS software. It occurred to me, after seeing somewhere that someone had changed the Security Type, that you could even do that (I thought it automatically defaulted) so I changed mine from WPA2 Personal to None, and guess what? I can now connect to the internet from my 9930 in the house! I don't have to go stand out front or on the patio! LOL The only box I have marked is "automatically obtain IP address and DNS." Now I have to figure out how to get my new PlayBook to do the same bec I can't connect to the internet in the house on that either and I beileve with the PB, you HAVE to have a WiFi connection. Good luck, I hope this solution works for you!
    10-07-12 03:50 PM
  8. gariac's Avatar
    FWIW, hiding the SSID isn't much security. Maybe a better solution is to enable it.

    Sent from my BlackBerry 9780 using Tapatalk
    10-25-12 02:23 AM