1. Sam Moussally's Avatar
    I have been on 10.3.1 for 5 days never installed a leak, and still battery drain
    Battery 10.3.1-img_20150223_163107.png

    Posted via CB10
    02-23-15 08:31 AM
  2. diegonei's Avatar
    You titled your thread in a way nobody can ever guess what the thread is about. Nice going!! #not.

    Can you post an screenshot of something useful? Like... The processes the CPU is running, so we can try and guess the culprit?
    02-23-15 08:41 AM
  3. RigoMonster's Avatar
    Also having battery life issues. Since the update to 10.3.1, I'm down to an average battery life of 7 hours. Strangely enough, Input Services is averaging over 20% in 48 hours. Will try to attach a screen shot via the CB10 app, but attachments hasn't been working.

    Passport on AT&T
    02-23-15 08:54 AM
  4. Bbnivende's Avatar
    Deleted
    02-23-15 09:00 AM
  5. RigoMonster's Avatar
    Attempt to post screen shot unsuccessful. That said, I can confirm that over 48 hours, System is at 30%, Input Services is at 26%, Standby is at 23%, Android Player at 6.2% and PIM Services at 3.6%. Updated the OS on Friday morning, so has been over 3 days since update. Have done many hard reboots during this time. Have only had official OS releases on the phone.

    Passport on AT&T
    02-23-15 09:00 AM
  6. Bbnivende's Avatar
    My Z10 battery has improved significantly. I have a model 3 running 10 3.1.1581.

    Posted via CB10
    02-23-15 09:02 AM

Similar Threads

  1. Battery Life Improved After 10.3.1
    By acescanuck in forum BlackBerry Z10
    Replies: 91
    Last Post: 03-17-15, 09:18 AM
  2. Os 10.3.1 and Link 1.1.1 Do they fit each other?
    By iNeoEon in forum Ask a Question
    Replies: 10
    Last Post: 02-25-15, 01:20 PM
  3. blackberry os 10.3.1
    By tendymaks in forum BlackBerry Z10
    Replies: 1
    Last Post: 02-23-15, 08:46 AM
  4. Anyone else forced into updating to 10.3?
    By kazza295 in forum General BlackBerry News, Discussion & Rumors
    Replies: 5
    Last Post: 02-23-15, 08:45 AM
  5. blackberry 10.3.1 sim card problem
    By tendymaks in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 02-23-15, 08:36 AM
LINK TO POST COPIED TO CLIPBOARD