1. TheQuietRioter's Avatar
    What are the signs of a bad battery on the Z10???

    Posted via CB10
    03-17-14 08:57 PM
  2. Omnitech's Avatar
    What are the signs of a bad battery on the Z10???

    Phone doesn't work.

    Instead of playing 20 questions, what is going on?

    "Sign of bad battery" could be many things.
    03-17-14 09:25 PM
  3. propeller10's Avatar
    What are the signs of a bad battery on the Z10???

    Posted via CB10
    Sounds like a question for webMD forum.
    03-17-14 09:56 PM
  4. TheQuietRioter's Avatar
    It won't hold a charge. It drains while on the charger whilst me using it.

    Most the time it charges so slow it takes 8 hours to fully charge, and lately it only charges to 86%.

    Now, it started doing this after the 10.2 update I performed last Thursday, but this is extreme.

    Posted via CB10
    03-17-14 11:25 PM
  5. Omnitech's Avatar
    It won't hold a charge. It drains while on the charger whilst me using it.

    Most the time it charges so slow it takes 8 hours to fully charge, and lately it only charges to 86%.

    Now, it started doing this after the 10.2 update I performed last Thursday, but this is extreme.

    As I mentioned to your question in a different thread here about battery drain, you have a battery drain issue with the OS that needs to be resolved.

    That very high battery drain is causing your battery not to charge because the power is being siphoned elsewhere while it is charging.

    When that problem is corrected (see suggestions in other post), then this "bad battery" issue should resolve itself.
    03-18-14 05:52 AM
  6. TheQuietRioter's Avatar
    But why didn't it do this before the update?

    Posted via CB10
    03-18-14 02:46 PM
  7. Bold_until_Hybrid_Comes's Avatar
    when the device is on.
    03-18-14 06:04 PM
  8. Omnitech's Avatar
    But why didn't it do this before the update?
    The same reason the battery didn't magically go bad at the same time you updated: it's not the battery.

    The PIM services thing is either an idiosyncracy with this OS build, or the reconfiguration that happens during an update changed certain parameters that exposed it.

    I'm trying to collect info on the issue to get to the bottom of it.

    In the meantime, please try the suggestions in the thread I linked earlier.
    03-19-14 04:15 AM

Similar Threads

  1. Replies: 40
    Last Post: 04-01-15, 09:40 PM
  2. Mugen Battery for Blackberry Q10
    By Andreas Kimishis1 in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 03-21-14, 09:15 PM
  3. Seidio Prime Battery Case stopped charging... fixed
    By yamahammer in forum More for your BlackBerry 10 Phone!
    Replies: 2
    Last Post: 03-17-14, 08:41 PM
  4. discharge battery?
    By NVERL8 in forum BlackBerry Z30
    Replies: 3
    Last Post: 03-17-14, 03:07 PM
  5. Twitter battery drain issue
    By Carterbits in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 03-17-14, 10:34 AM
LINK TO POST COPIED TO CLIPBOARD