1. stev32k's Avatar
    I have recently set-up a second router as repeater bridge in my home. Each router has its own SSID network and the signal strength from each varies quite a lot depending on where the phone is located at the time. In some spots there is no signal at all from one or the other networks (which is why I set-up the repeater). With the repeater I get good coverage everywhere.

    The problem is that the blackberry will not automatically switch from one WiFI network to the other based on signal strength. I have to go to Wi-Fi connections and change the selection mode from automatic to manual then choose the stronger network. This is especially annoying when I go out on the patio where one network has no signal at all but the other is very strong - the phone should automatically switch to the other WiFi network, but it does not. Instead it goes to the T-Mobile network edge.

    Am I wrong in thinking that the phone should switch automatically between WiFi networks? Or is there some setting I'm overlooking?
    06-16-09 04:46 PM
  2. zwood's Avatar
    Go to manage connections > WIFI options > WIFI selection mode: "automatic". Also highlight each of your networks click menu > edit > and uncheck prompt before connection. Then move your two networks to the top of the saved WIFI profiles list. Now it should automatically switch to the other network when the signal drops "very Low".
    06-17-09 08:24 AM
  3. stev32k's Avatar
    Go to manage connections > WIFI options > WIFI selection mode: "automatic". Also highlight each of your networks click menu > edit > and uncheck prompt before connection. Then move your two networks to the top of the saved WIFI profiles list. Now it should automatically switch to the other network when the signal drops "very Low".
    I've already done that and it does not work. Just had it happen again I completely lost one network in the middle of a call and phone switched to edge instead of the other WiFI network. Guess I'm going to have to call RIM.
    06-17-09 11:57 AM
  4. zwood's Avatar
    Check that you have "allow inter-accesspoint handover" checked in your WIFI profiles.
    06-17-09 12:24 PM
  5. stev32k's Avatar
    Check that you have "allow inter-accesspoint handover" checked in your WIFI profiles.
    Yup, got that one also. Just got off the phone with RIM and they are scratching their heads also.
    06-17-09 01:01 PM
LINK TO POST COPIED TO CLIPBOARD