1. Anthony_2u's Avatar
    Hello, I installed OS 10.3.1 last night everything works except for Amazon app store, after it loads up completely it crashes I don't see anything just a black screen no apps nothing, Can someone help me please?.

    Posted via CB10
    02-25-15 08:06 PM
  2. Hopper1976's Avatar
    I'm sure you've heard this before but try rebooting. It happened to me today and I had to reboot twice because my android apps were slow to open! Hope you figure it out! SMILE!!!

    Posted via CB10
    02-25-15 08:56 PM
  3. Anthony_2u's Avatar
    Reboot the OS? Give me instructions please.

    Posted via CB10
    02-25-15 09:00 PM
  4. lotuslanderz's Avatar
    Reboot the OS? Give me instructions please.

    Posted via CB10
    http://forums.crackberry.com/blackbe.../#post11011884

    See post #5

    Posted via CB10
    02-25-15 09:27 PM
  5. Anthony_2u's Avatar
    I'll try it now thank you. I reply if it work as well.

    Posted via CB10
    02-25-15 10:08 PM
  6. Anthony_2u's Avatar
    Same result I did the reboot. I held down both volume button wait for BlackBerry logo then it start up. I then went on to open Amazon App store it load up then crash black screen then crash nothing else.
    Amazon App Store Won't Open on  OS 10.3.1  Need Help!!-img_20150225_231743.png

    Posted via CB10
    02-25-15 10:18 PM
  7. anon(1852343)'s Avatar
    Install the app directly from the link at amazon

    Blackberry Passport running 10.3.1.2267
    02-25-15 10:27 PM
  8. lotuslanderz's Avatar
    Yes, try reinstalling directly from amazon.
    http://www.amazon.com/gp/mas/get-app...UvbUpU11402296



    Posted via CB10
    02-25-15 11:11 PM
  9. Anthony_2u's Avatar
    I will try and let you guys know the result thanks I advanced.

    Posted via CB10
    02-25-15 11:21 PM
  10. Anthony_2u's Avatar
    It says it's processing taking forever.

    Posted via CB10
    02-25-15 11:35 PM
  11. lotuslanderz's Avatar
    It says it's processing taking forever.

    Posted via CB10
    Check this setting:
    Go to Settings (pull down from the top of the screen), then select App Manager, then Installing Apps. Make sure you "Allow Apps from Other Sources to be Installed".
    Hopefully that will fix it.
    Reboot.
    02-26-15 12:15 AM
  12. Anthony_2u's Avatar
    Still didn't work trying everything just wana try a few app and see how they work on 10.3.1

    Posted via CB10
    02-26-15 01:06 AM
  13. mcresk's Avatar
    Hey, when I got my Classic yesterday. I updated the device but the Amazon App store bugged?
    Was not be able to find any apps and I couldn't download them. Anyone had the same issues?
    I'm trying to run Spotify on my new device. Anyone knows how to solve?
    02-26-15 04:55 AM
  14. Anthony_2u's Avatar
    I still can't access my amazon app.

    Posted via CB10
    02-26-15 01:20 PM
  15. jamesray0757's Avatar
    Did you ever figure this out? I can't get apks to run on my device
    03-24-16 09:11 AM

Similar Threads

  1. Bright Spot on Passport Screen
    By CdnXxRRODxX in forum BlackBerry Passport
    Replies: 21
    Last Post: 07-04-15, 12:21 PM
  2. 10.3 Automatic Download and install . . . ?
    By playfoot in forum BlackBerry Q10
    Replies: 35
    Last Post: 03-01-15, 06:36 PM
  3. Is there a Dark theme for the Hub in 10.3?
    By BBMBill in forum Ask a Question
    Replies: 5
    Last Post: 02-26-15, 01:22 AM
  4. How do I raise the volume on my Q10?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-25-15, 07:54 PM
  5. 10.3.1.2267 fixed predictive word placement
    By ppeters914 in forum BlackBerry 10 OS
    Replies: 0
    Last Post: 02-25-15, 07:50 PM
LINK TO POST COPIED TO CLIPBOARD