1. cbnoob's Avatar
    My 9800 Torch Text Messaging stopped working the other day and neither AT&T nor my company seems to be able to figure out how to fix it. Here's what's happened so far:

    During my attempts to figure out what happened, I noticed a "Mismatched Key" error in the Firewall menu. But I have no idea if that is the problem, or something totally unrelated to the Text Messaging not working. I ran a key regeneration as tech support instructed (which said it completed successfully), but the Mismatched Key error is still showing at the bottom of the screen in the Firewall menu, it's still showing "3 blocked" beside it, and text messaging still isn't working.

    This is what I know about my original problem with the text messaging...

    When I go into the Text Message Icon from the ALL home screen, I can select "Compose a Text Message", I can put a recipient name in the "To" window, It comes up and asks which phone number I want to use for the contact, and I can enter a text message in the text message box. But when I hit the trackpad center button, nothing happens... I don't get the blue window with 6 selections, (one of which is send). Nothing happens. If I try selecting the "Send" icon at the bottom of the touch screen, it clears out the text in the text message window, and again does nothing. When I press the menu button, also nothing happens.

    When I go into the Contacts menu, I can select a contact, and I can select "Text <contact name". But when I select the number of the contact I wish to send the text to, nothing happens. The text message dialog box never comes up.

    Another symptom is that if someone sends me a text message, I hear my text message tone, I see the red notification star appear on the Text Message icon, and I see the little yellow text message icon on the notification bar above the ALL home screen indicating that I have a new text message. But when I go into text messages, it says I have no messages. When I go back to the ALL home screen, the red star is gone from the text messaging icon, but the yellow notification bar icon is still showing that I have 1 text message.

    AT&T had me do battery pulls a couple times, they reset the connection on their end, they confirmed no outages in my area, they confirmed that everything is working on their end and that my text messaging service is enabled. Their final assumption is that it's a phone, phone software, or BES policy issue, NOT an AT&T service issue.

    In the OPTIONS>SECURITY>FIREWALL screen. The General "Enable" option is checked and has a lock on it, (AT&T seemed to think that meant there was a policy that was blocking text messaging?) But below that in the "Block Incoming Messages" section of the Firewall screen, all the selections are unchecked. But the Text Messages option still says 29 Text Messages blocked to the right of it even though it isn't selected.

    Tech support at my company is suggesting wiping my phone back to factory defaults. But I'm very reluctant to do this since I have dozens of hours into configuring my phone the way I have it now, plus I have lots of 3rd party apps that I don't want to have to reload. (Yes I've done a backup of both the phone and a separated one of the 3rd party apps just in case wiping becomes the only option).

    Does ANYONE have any suggestions that might HELP...???????
    03-03-11 10:32 AM
  2. cbnoob's Avatar
    So far I have tried the following with no change in the problem:

    - Enterprise Reactivation
    - Re-registering the Host Routing Table
    - Had my company re-push the IT Policy & Service Books to my phone
    - Cleaned Memory
    - Battery Pull Reboot
    03-03-11 12:24 PM
  3. cbnoob's Avatar
    Just in case anyone else ever runs into this problem....

    I have a sneaking suspicion that a software update from "Alarms 1.2.7 - Johan Poirier" that was done just prior to this happening had something to do with the failure, but I can't conclusively prove that, since deleting the application after the fact had no effect on the problem.

    In the end, the only way to fix it was to do a security wipe of the phone.

    Luckily I had a recent DM backup and I had also followed some instructions from a Crackberry forum post on how to backup 3rd party apps.

    After a full day of messing with it and 3+ hours of wiping and restoring. It's now back and Text Messaging is working again.

    If nothing else, I know whole lot more about OS6 now...
    03-04-11 09:44 AM