1. lufis's Avatar
    I recently bought a used Blackberry 8820 for at&t on eBay and have only one major complaint with it thus far: the wifi is effectively useless.

    I don't have a data plan so the wifi on this device was a big selling point. But I can't seem to be able to do anything with it.

    I upgraded the device software to the latest 4.5 (AT&T branded) version as soon as it arrived, so it's running an effectively clean slate OS. It either seems like the wifi has been crippled to the point of being useless without a data plan or I'm not configuring it correctly.

    If I turn the cellular network off and leave wifi on and attempt to access a website in the MediaNet browser I get a "The radio on the device is currently turned off ... " error, even when attached to a working wifi network. In the Blackberry browser in the same situation, the wifi icon will appear in the corner, but I get the following error: "Unable to connect to the internet, please try again later ... "

    I installed Opera Mini in hopes that this would work directly over the wifi, but this has been futile as well. The Connection Wizard runs and about midway through I get: The application operette ******** has attempted to open a connection to a location inside the firewall and outside the firewall which is not allowed by your IT policy.

    Is there something I'm missing here? Is it even possible to connect directly through wifi with this version of the OS?
    08-09-09 06:51 PM
  2. DINGSTER1's Avatar
    It sounds like there is an IT policy from the previous user still attached to the phone. Search the forums for the FAQ on how to remove it.
    08-09-09 08:53 PM
  3. dsdawson's Avatar
    In the Browser configuration options, make sure you have selected Hotspot Browser as the browser of choice.

    Doug

    Posted from my CrackBerry at wapforums.crackberry.com
    08-09-09 09:14 PM
  4. lufis's Avatar
    Doh. After playing with my router's settings a bit, I can now browse the web through the hotspot browser. But the issue of Opera not working remains.

    I completely wiped the phone and reinstalled the OS. Could an IT policy from a previous owner still be attached to the phone?
    08-09-09 11:43 PM
  5. Joe4pal's Avatar
    In opera under options did u check wifi?

    Posted from my CrackBerry at wapforums.crackberry.com
    08-11-09 07:54 PM
  6. rsbrux's Avatar
    I have a similar problem, but no "Hotspot Browser" option.
    Instead I have "Blackberry Browser" (Default), "Internet Browser", "Orange World" & "Wi-Fi Browser". I would like the browser to use my home WLAN network if available, and otherwise to use my mobile telephone provider (Orange). Will one of the available browser options do that, or do I need to install another browser? Is there anything else I need to do to ensure automatic access/connection to my infrastructure WLAN?

    P.S. Just found this thread ("/f3/complete-wifi-how-47229"), which probably answers the second question. I'll try it out and report back.
    Last edited by rsbrux; 08-14-09 at 07:41 AM.
    08-14-09 07:35 AM
  7. robbtronic's Avatar
    i'm not sure if this will help anyone, but i couldn't connect my 8820 to UMA status on my home wifi network until i changed my security settings to either open or wpa2. for some reason, it doesn't work on wpa-tkip. tmobile is my service.
    08-17-09 11:52 PM
  8. chesmcd's Avatar
    I have a similar concern.

    I have a 8820 from ATT. I used to have a curve but needed something bigger. I loved always being able to access the internet with my curve now that I have a 8820 I can't figure out how to use the data plan internet when I am not in a wifi zone.



    Is there anyway to cut off the WIFI and just use the data browser?



    (I know how to cut off the WIFI but I can't get it pick up the data internet when it is off)
    08-18-09 12:49 PM
  9. MrAOK's Avatar
    You need to manually connect to your home lan once (and enter any password if there is one). At that point the Blackberry will save it and will automatically connect any time you are home.

    To manually connect, go to "manage connections" and then to "set up wifi network"
    08-18-09 02:57 PM
  10. lufis's Avatar
    I am late to be replying to the suggestions here but turns out an old IT policy actually was still on the phone. Apparently merely upgrading the OS doesn't change that, but with a complete wipe Opera is now working relatively well.

    thanks guys!
    08-18-09 06:40 PM
  11. lufis's Avatar
    I have a similar problem, but no "Hotspot Browser" option.
    Instead I have "Blackberry Browser" (Default), "Internet Browser", "Orange World" & "Wi-Fi Browser". I would like the browser to use my home WLAN network if available, and otherwise to use my mobile telephone provider (Orange). Will one of the available browser options do that, or do I need to install another browser? Is there anything else I need to do to ensure automatic access/connection to my infrastructure WLAN?

    P.S. Just found this thread ("/f3/complete-wifi-how-47229"), which probably answers the second question. I'll try it out and report back.
    You could install Opera and change the network settings to use HTTP through wifi when you're at home and to socket for when you're on the go. Opera isn't tied into the OS like the Blackberry Browser is, but it works just as well and even has some nice bonuses that the BB browser lacks.
    08-18-09 06:45 PM
  12. dachl's Avatar
    I downloaded Mobile.Google or Google.Mobile (not sure which way). When I restarted my unlocked AT&T 8820, turned off the radio, turned on the WI FI, clicked on the Google icon and Voila! Google seems to bypass the UMA and the WI FI works great. The only downside is the battery drains faster. Hope this helps.
    09-03-09 08:50 PM
LINK TO POST COPIED TO CLIPBOARD