1. acedanger's Avatar
    I upgraded my storm to .109 about 2 days ago. Since then, when I run BB Maps, I can't ever get a GPS lock. I've tried it outside, several times. I've waited until I get the message noting that satellites cannot be found.

    Is this related to my upgrading the OS from .75 to .109? Is anybody else having an issue similar to this? I checked the "official .109 leak" thread, scanned the first few pages, performed several searches and I didn't see anything related to GPS issues.

    Is there something else I can try to help my phone find a satellite?

    Thanks in advance.
    03-20-09 09:46 AM
  2. my_2_cents's Avatar
    I didn't associate it, but I also wasn't able to get a satellite lock after upgrading. I was outside, but didn't wait long enough for a message. I got sick of waiting and told it to stop searching. I'll have to try it again tonight after work.
    03-20-09 11:05 AM
  3. staberp's Avatar
    Same here. I can't get a GPS lock with Google Maps or BB Maps and yes I do have location on. This wasn't a problem when I had .75 but I'm now at .109 and noticed the problem today.
    03-21-09 02:31 PM
  4. cadzilla74's Avatar
    I'm running .109 and had to go into Options>Advanced Options>Applications and highlight each of my GPS enabled apps one at a time ... While app is highlighted press the BlackBerry button and select Edit Permissions ... Set Connections, Interactions and User Data to ALLOW ... Had to do it for Google Maps, BB Maps, Poynt, VZW Navigator and Trapster. They had all reverted to Custom instead of Allow as the default setting and would not find my location correctly.
    03-21-09 06:27 PM
  5. acedanger's Avatar
    Thanks for the suggestion. I reviewed the permissions and they all were set to "Allow" for User Data. BB Maps still can't find a satellite.

    Anybody have any other ideas I could try?
    03-23-09 01:12 PM
  6. acedanger's Avatar
    this is fixed, although I don't know how/why.

    I booted up Google Maps this morning and noticed that it was the first time I had done that since I upgraded my OS to .109. I had gMaps detect my location and it worked.

    Then I switched to BBMaps and that was able to find some satellites. I'm not sure why it suddenly started to work, but it did.
    03-24-09 11:54 AM
LINK TO POST COPIED TO CLIPBOARD