1. Dim-Ize's Avatar
    I am unable to get YouTube to work - even if I disable all connections except WiFi.

    When I start the native app with WiFi ONLY - I get the error, "The APN is not configured properly. To stream media, please cofigure the APN." Again, this is WiFi only, all other connections are disabled. All other internet services work: browsing, email, USB tethering & WiFi hotspot when the mobile network is "checked". Why would APN even matter in a WiFi only connection?

    Nevertheless, I've entered various APN's from my carrier, AT&T:
    1) Phone (default) + blank / blank
    2) blackberry.net + blank / blank
    3) wap.cingular + wap.cingulargprs.com / cingular1
    4) isp.cingular + isp.cingular.com / cingular1

    I've deleting browser history and done the battery pull. I've deleted the YouTube app (since it wasn't working) and tried m.youtube.com through the browser. Nada.

    Seems like Player for YouTube Free (App World) works, but, quality is pretty bad (as if 640x480 could be stellar... I still think it could be better). I don't want to pay for the upgrade since it seems like others are getting this to work natively, vs. having to buy an app for it.

    Any other ideas?
    03-30-12 02:49 PM
  2. Dim-Ize's Avatar
    Here is a fix I discovered: delete all the WAP2 services in Service book.

    Options > Advanced > Service book.
    04-02-12 02:37 PM
LINK TO POST COPIED TO CLIPBOARD