1. GreedyMonkey's Avatar
    I have been using Word To Go on my Bold daily. But all of a sudden today, I cannot open any documents in any of the Documents To Go programs. Here are the messages I get:

    * When I try to open a new document--> Permission to your files was denied. Please configure your application permission appropriately.

    * When I try to open a recent document--> Uncaught exception: file system error.

    Here's what I've tried:

    * Went to Options>Security Options>Application Permissions>Documents To Go, and Edit Permissions. All options are on "Allow." Result: problem not solved.

    * Battery Pull. Result: problem not solved.

    * Uninstalled, and then reinstalled Documents to Go. Result: problem not solved.

    * Searched various forums, but thus far have found no cause or solution.

    Can somebody please help? Any ideas?

    04-09-09 10:48 PM
  2. FF22's Avatar
    Where are the documents stored? If on an SD card and your BB was connected to the computer, the files on the SD card may not show.
    04-09-09 11:55 PM
  3. Xopher's Avatar
    If your files are on you SD card, then make sure you can access the SD card from your Bold.

    Acces to the SD card is disabled when the BB is connected to a PC (especially when enabling mass storage mode).

    I have seen times when "Safe Remove" was not used to disconnect the BB from the PC that it disables the SD card until you run CheckDisk on the card (while connected to PC).

    Those are the only things I can think of.
    04-10-09 05:40 AM
  4. GreedyMonkey's Avatar
    The BB is not connected to the PC. The files are located on my SD card, but I can access the card all other files on it (i.e. media, eWallet, .pdf files in RepliGo, etc.). It is only the Docs To Go program that is giving me a headache.
    04-10-09 07:34 PM
  5. Sweetchuck's Avatar
    I am having the exact same problem.

    I have run CheckDisk on my SD card, and it shows up as fine. I've tried to reinstall Documents To Go, and the installation proceeds perfectly, but the minute I try to open a file, I get the message that I do not have permission to view my files. I've tried soft resets and battery pulls, and still it doesn't work. I've tried removing the SD card in case it was corrupted, but even without the SD card in my BB, Documents To Go refuses to launch.

    This is driving me absolutely nuts!
    04-28-09 04:56 AM
  6. Sweetchuck's Avatar
    Quick update: the problem now seems to have been resolved. Hopefully this will work for others too.

    Given that my documents had always been kept on my SD card, I assumed that this was causing the problems. As such, all of my actions had been directed towards solving a problem in relation to the SD card (eg. removing it, formatting it, running CheckDisk on it). However, as mentioned above, none of that worked.

    As a last resort (and after performing a full backup of my BB) I switched the BB into standby, removed the SD card, replaced the battery and powered up. I then connected to my laptop (without running BB Desktop Manager) and ran CheckDisk on BlackBerry1 in My Computer (ie. my BB system storage) with both options for finding and fixing bad sectors checked.

    CheckDisk ran very quickly and immediately told me it had found (and fixed) bad sectors, and also that portions of some files may be missing on the disk checked. After safely removing the BB, I ran Documents To Go, and everything seemed fine.

    I put the BB into stand-by, pulled the battery and replaced the SD, then powered up and lo and behold, everything still works fine.

    Hopefully this works for others, too!
    04-28-09 05:32 AM
  7. uktraveller's Avatar
    Hey Xopher! your tip of 4th April really helped me out - Thanks again!! Rick
    05-06-09 05:31 AM
  8. hjk's Avatar
    I tried all of the suggestions and nothing worked for me.
    05-21-09 11:25 PM