10-02-16 12:04 PM
69 123
tools
  1. GLTruesdale's Avatar
    Heck no. Played out.
    09-28-16 08:56 AM
  2. mh1983's Avatar
    Heck no. Played out.
    Can you be more specific?
    09-28-16 09:15 AM
  3. DrBoomBotz's Avatar
    Can you be more specific?
    The weather report for the bottom of the ocean is wet.
    Jack Chin, mh1983 and TgeekB like this.
    09-28-16 09:18 AM
  4. Jack Chin's Avatar
    In other news, Michael Jackson is still dead.

    Posted via CB10
    DrBoomBotz likes this.
    09-28-16 11:28 AM
  5. Jack Chin's Avatar
    No.

    Posted via CB10
    09-28-16 12:39 PM
  6. evodevo69's Avatar
    Does leaving hardware equate to abandoning their software though. Can't they focus on sofwtare

    So exisitng devices, especially Priv and dtek50 should still be good no?

    I guess if no one licenses their software in the next year then even their android updates will be abandoned...

    #whatisclassic
    09-28-16 12:46 PM
  7. thayvanh's Avatar
    Just bought a passport, can't wait to use it.
    At 270, I cannot regret it.
    It has everything the Z30 lacks right now. (except the formidable speakers).
    I'm sure what's app will work too.

    Posted via CB10
    09-28-16 02:33 PM
  8. roleli's Avatar
    Unless you are a serious Blackberry fan like myself, definitely no.
    09-28-16 02:48 PM
  9. S1lv1o's Avatar
    I would take the decision based on what works now, natively on BB10, which for me is a lot, but for others clearly not enough.
    09-30-16 10:26 AM
  10. Avenzuno's Avatar
    And even though Amazon, Cobalt's Playstore or Snap won't work at one point of time - There are plenty of other Appstors. In the beginning of my time as a OS10 user I just installed the apk via Playstore on my old Android device and then backed the apk up and sent it to my Z10 - it worked.

    And this way or another apks will continue to work for a long time I think.
    I'm not really familiar with the Cobalt or Snap solution to the Google Play Store. Would either essentially get me access to apps requiring at least Android 5.0 Lollipop? If so, which is better? I am intrigued by the Passport's horsepower and recent affordable price.

    Posted via CB10 on my VZW  Z30 STA100-3 on at&t | 10.3.2.2813
    fschmeck likes this.
    09-30-16 10:33 PM
  11. Adif_701's Avatar
    If you want an work horse with a battery that lasts until 10pm then for sure.


    Posted via CB10 on my PP
    09-30-16 11:11 PM
  12. Nguyen1's Avatar
    I got three days once on one charge.

    BTW you won't get lollipop, only jelly bean. The passport is stuck there.

    Passport!
    09-30-16 11:49 PM
  13. Old_Mil's Avatar
    So exisitng devices, especially Priv and dtek50 should still be good no?
    Let's put it this way...given blackberry's record of abandoning installed userbases under Chen (playbook, bb10) I would much rather be starting out with a passport today than any blackberry android...any blackberry Droid will likely be quickly abandoned by the company a year and a half from now and then face the full wrath of the very robust android virus and malware ecosystem unsupported.

    Those of us still on bb10 will continue to enjoy a degree of security through obscurity.


    Posted via CB10
    10-01-16 07:55 AM
  14. Avenzuno's Avatar
    I got three days once on one charge.

    BTW you won't get lollipop, only jelly bean. The passport is stuck there.

    Passport!
    That's what I needed to know. I think I've read that OS version limit before but thanks for confirming. Planning ahead, I better make sure that next summer I have at least one phone that has a decent ecosystem. Hopefully Mercury is it, if it's actually going to be released.
    10-01-16 09:31 AM
  15. markus2107's Avatar
    I'm not really familiar with the Cobalt or Snap solution to the Google Play Store. Would either essentially get me access to apps requiring at least Android 5.0 Lollipop? If so, which is better? I am intrigued by the Passport's horsepower and recent affordable price.

    Posted via CB10 on my VZW  Z30 STA100-3 on at&t | 10.3.2.2813
    Nope, there's no chance you can install an App that needs Android 5.0 or newer. OS10 is using an Android Runtime that is limited to Android 4.3 applications.

    PS:
    Never thought there would be coming something good from Andriod's fragmentation but: There'll be lot's of users out there (today about 18 to 19 percent) using 4.3 or lower Android versions. So unless this number goes down to less then 10 percent most of the apps will technically work for you. Although - as you've seen - there are already applications that need newer Android versions than 4.3
    10-01-16 10:25 AM
  16. california governor's Avatar
    You do whatever you want, if you like it, go get it. It's not even that expensive. I'm talking about 150 +/-.

    Emperor of Texas & California.
    10-01-16 05:11 PM
  17. mamalimt's Avatar
    yes, I would still buy one. if the device is right for you grab one. don't worry so much about support or app development. I'm sure everything will be fine. of course you should also know what you're getting yourself into before doing so. I'm sure you have basic knowledge about bb10 already and if not do some research so there won't be any surprises.
    10-01-16 06:39 PM
  18. Joel Olmedo's Avatar
    The passport price right now is just so tempting. I just got a new Priv the other week, but honestly, I'm still lusting for a Passport SE. I am perfectly happy with the Priv. It's pkb, I'd say, is 90% as good as that of my Q10. But that pkb on the Passport and the dapper chassis of the SE is beckoning me. Need. To. Resist

    Posted via CB10
    10-02-16 03:17 AM
  19. mamalimt's Avatar
    I completely understand where you're coming from. ahah. the passport is a must have BB10 device. I hope one day you are able to get your hands on one. GL.
    10-02-16 12:04 PM
69 123

Similar Threads

  1. WTS: Brand new BlackBerry Passport (QWERTZ model)
    By Aju in forum The Marketplace - Buy, Sell & Trade
    Replies: 16
    Last Post: 10-06-16, 07:10 AM
  2. 22 September: Problems at T-Mobile T-Mobile is having issues since 1:41 AM EDT.
    By coffee-turtle in forum General BlackBerry Discussion
    Replies: 4
    Last Post: 09-23-16, 01:41 PM
  3. Getting Contacts from Passport to Bold?
    By Gebo in forum BlackBerry Bold 9930/9900
    Replies: 6
    Last Post: 09-23-16, 12:21 PM
  4. Transferring Contacts from BB10 backwards to BB 7.1
    By Gebo in forum BlackBerry 10 OS
    Replies: 13
    Last Post: 09-23-16, 01:06 AM
  5. Priv: unable to read .pdf files on Drive
    By plugandwear in forum BlackBerry Priv
    Replies: 2
    Last Post: 09-22-16, 08:38 AM
LINK TO POST COPIED TO CLIPBOARD