1. Sandman333's Avatar
    I have a D-Link home wireless router set to either WPA or WPA2, I forget. Anyway, all my computers work fine. Today I got my 9550 and tried to set up the WiFi connection- only to find that I can't. There's no WPA or WPA2 option. I have SSID Broadcast turned off on the router. I tried to manually set up the WiFi on the 9550- entered the network name and then the closest security option is PSK, but after selecting that, there is nowhere to enter the actual key. I tried to click "Next", but it pops up an error telling me to specify the key- but again there is nowhere to specify it. Is it just my phone- or is this a glaring error from RIM? The manual was no help and I did a search with no results here. Very confusing.
    04-02-10 04:33 PM
  2. sparkerc's Avatar
    I'm using WPA with my 9550 and it works fine. Whether using WEP or WPA, there is no setting change on the 9550... just need to enter the key. I have had one or two times where it was easier to turn on SSID broadcast, set it up and then turn it back off.

    The other thing to check... are you doing MAC filtering on your access point?
    04-02-10 04:45 PM
  3. Sandman333's Avatar
    Nope, no MAC filtering. The problem isn't with the access point- the problem is that I can't even enter the key on the phone. There is no box to enter it in. Makes no sense. The manual is no help at all- it tells you to go to the WiFi setup icon, click on it, and follow the prompts. What a joke.

    If you are using WPA, what security option did you choose when you set up your network?
    Last edited by Sandman333; 04-02-10 at 05:01 PM.
    04-02-10 04:47 PM
  4. tack's Avatar
    It works great on my network with WPA2. I picked the PSK (Pre-Shared Key) option and entered the key. Works like a champ!
    04-02-10 05:11 PM
  5. Sandman333's Avatar
    How did you enter the key? Was there a text box or something? I don't have one. I see another line of text that says PSK, but there is nowhere to click on to enter the key. I don't get it.

    Is there a way to take a screen shot off the BB and post it here?

    This is what I see:

    Security Type: Pre-Shared Key (PSK)
    ________________________________________
    Pre-Shared Key:






    ....and then there are buttons on the bottom for Back, Connect, and Save. Clicking Connect or Save gives me an error telling me to enter the key, but there is no where to enter the key. Seems to be a bug in the software.
    Last edited by Sandman333; 04-02-10 at 05:18 PM.
    04-02-10 05:13 PM
  6. sparkerc's Avatar
    You just need to type next to the area that asks for the key.

    04-02-10 05:24 PM
  7. Sandman333's Avatar
    Well, my phone must be defective, because I don't see that at all. All I get is what I posted above. There is no where to enter a pre-shared key like what is on the screen shot you posted. I called Verizon and they don't know either.
    04-02-10 05:27 PM
  8. Sandman333's Avatar
    Ok, I got it to work finally. The problem wasn't that there isn't a place to enter it, it's that the touch screen is not very good at all- I've played with several apps so far and some are extremely frustrating trying to get the phone to click where you put your finger. This was one of them. I tried over and over to click the screen next to where it said "Pre-Shared Key:" and got nothing. Because there wasn't a text box there either, it looked like there was no where to enter the information. I still don't see everything you have above, but I do believe I have a WiFi connection now- at least it told me it was a success.

    I'm not so sure the 9550 was a good idea if this is all the better the touch screen gets. So far it's horrible. Maybe I just need to get used to it. I tried setting up Navita translator and I was about ready to throw the phone across the room out of frustration trying to get it to realize where I was clicking on the menus. The touch screen seems to randomly click wherever it wants rather than where your fingers are. Very frustrating.
    04-02-10 05:36 PM
  9. sparkerc's Avatar
    That almost sounds like you have Compatibility Mode enabled for the app that you are in. Go to Options -> Applications -> Touch the application in question -> Press the Blackberry key -> Disable Compatibility Mode and then try again.

    Otherwise, I would get your phone replaced. The touch screen is great for me.
    04-02-10 05:40 PM
  10. Sandman333's Avatar
    Yep, the Disable Compatibility Mode was under the BB key menu. What does that do anyway? This was an application that I transferred over from my 8830 WE.

    Might as well hijack the thread a little further- do these phones get a little warm when charging? Mine is.
    04-02-10 05:43 PM
  11. sparkerc's Avatar
    It's used when an App was not designed to work with the Storm and you want to try to do just that. It tries to make the Storm emulate a non-touch screen device. On some apps, it almost makes the touch screen work as if it was a touch pad/track ball.

    Charging... a little warm... yes. Not hot, but I can feel a warm battery through the back cover.
    04-02-10 05:46 PM
  12. Sandman333's Avatar
    Ok, and thanks for the help! Was getting very frustrated here!
    04-02-10 05:49 PM
  13. Sandman333's Avatar
    Ok, posting this from my phone over my wifi connection. Thanks again. Might not have gotten it working without your help.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-02-10 06:00 PM
LINK TO POST COPIED TO CLIPBOARD