1. brevit's Avatar
    I never use wifi on my BB normally but I am home for Christmas and have turned off data roaming (as it costs a lot) so I decided to use wifi to connect to the internet.

    I have connected to the wifi network successfully but no browser pages will load and apps will all say offline, even though I am getting full strength wifi signal.

    I am new to wifi on bb, but is it not like the iPhone where you can use all the apps offline, or am I missing something.

    I am on OS 6, latest leak.

    Cheers.
    12-20-10 07:10 PM
  2. Heavy Fluid's Avatar
    I never use wifi on my BB normally but I am home for Christmas and have turned off data roaming (as it costs a lot) so I decided to use wifi to connect to the internet.

    I have connected to the wifi network successfully but no browser pages will load and apps will all say offline, even though I am getting full strength wifi signal.

    I am new to wifi on bb, but is it not like the iPhone where you can use all the apps offline, or am I missing something.

    I am on OS 6, latest leak.

    Cheers.
    I highlighted the last part. Might be part if not all of the problem. What device are you on, as your profile says 8320?
    12-20-10 07:48 PM
  3. Rootbrian's Avatar
    I never use wifi on my BB normally but I am home for Christmas and have turned off data roaming (as it costs a lot) so I decided to use wifi to connect to the internet.

    I have connected to the wifi network successfully but no browser pages will load and apps will all say offline, even though I am getting full strength wifi signal.

    I am new to wifi on bb, but is it not like the iPhone where you can use all the apps offline, or am I missing something.

    I am on OS 6, latest leak.

    Cheers.
    Update your device profile, it should reflect your most used blackberry if you have more than one unit.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-20-10 08:16 PM
  4. lengend's Avatar
    I believe if you disable data you cannot use wifi on your browser. Also in OS6 leak once you enable wifi your browser will automatically switch to the hotspot one.

    Also for other apps not working can you be more specific on which ones as some need to be from your carriers 3G.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-21-10 04:20 AM
  5. mke67's Avatar
    Well for me the problem on the Torch, before returning it, was having b/g/n enabled on the router. Solved it by setting router to b/g only. Stupid but true. OS5 never had this problem so if you are using a 9700 with OS6 try setting to b/g only.

    Posted from my CrackBerry at wapforums.crackberry.com
    rdefst likes this.
    12-21-10 04:33 AM
  6. brevit's Avatar
    Yea I am on os 6 on a 9700.

    Well for me the problem on the Torch, before returning it, was having b/g/n enabled on the router. Solved it by setting router to b/g only. Stupid but true. OS5 never had this problem so if you are using a 9700 with OS6 try setting to b/g only.

    Posted from my CrackBerry at wapforums.crackberry.com
    I can't seem to find a setting to switch my router to b/g only. I'll call my service provider later and ask. It's pretty annoying, having a blackberry with not internet connection is infuriating.

    No apps are connecting over wifi. Here is a pic of my homescreen. You can see wifi is connected. Twitpic - Share photos on Twitter
    12-21-10 05:50 AM
  7. brevit's Avatar
    Yea I am on os 6 on a 9700.

    Well for me the problem on the Torch, before returning it, was having b/g/n enabled on the router. Solved it by setting router to b/g only. Stupid but true. OS5 never had this problem so if you are using a 9700 with OS6 try setting to b/g only.

    Posted from my CrackBerry at wapforums.crackberry.com
    I can't seem to find a setting to switch my router to b/g only. I'll call my service provider later and ask. It's pretty annoying, having a blackberry with not internet connection is infuriating.

    No apps are connecting over wifi. Here is a pic of my homescreen. You can see wifi is connected. Twitpic - Share photos on Twitter
    12-21-10 07:11 AM
  8. Heavy Fluid's Avatar
    Yea I am on os 6 on a 9700.



    I can't seem to find a setting to switch my router to b/g only. I'll call my service provider later and ask. It's pretty annoying, having a blackberry with not internet connection is infuriating.

    No apps are connecting over wifi. Here is a pic of my homescreen. You can see wifi is connected. Twitpic - Share photos on Twitter
    Do you have an active BB data plan on your account with this phone?
    12-21-10 09:56 AM
  9. brevit's Avatar
    As I said, I have a data plan in Germany, I am now in Ireland and so I have data and roaming switched off. Wi-fi should work regardless, I thought, or do I need to be connected to my data provider. That defeats the purpose, surely?

    I have found out my modem is 802.11g.
    12-21-10 11:35 AM
  10. brevit's Avatar
    Ok, I seem to have got it working. I had switched off "data services" and "when roaming" in mobile network options. I switched "data services" back on and it seems to be connected now via wifi.

    I assume, anyway, I hope I'm not data roaming!
    12-21-10 11:39 AM
  11. rdefst's Avatar
    Well for me the problem on the Torch, before returning it, was having b/g/n enabled on the router. Solved it by setting router to b/g only. Stupid but true. OS5 never had this problem so if you are using a 9700 with OS6 try setting to b/g only.

    Posted from my CrackBerry at wapforums.crackberry.com
    You nailed it, thanks! My girlfriend was having this same wifi problem with her unlocked 9300. I'd spent weeks reformating, trying different OS's, everything I could think of. I switched the router to b/g only and starting working instantly! Ironically, I use a 9700 on OS6 and didn't not have the same problem. oh well, just glad it works.
    03-11-12 04:11 AM
LINK TO POST COPIED TO CLIPBOARD