1. secret_society47's Avatar
    Perhaps this is a dumb question, but I am a new, first-time blackberry owner, as of yesterday.
    I have the newest Pearl 3g (love it), but I want to use my wifi more than data, since 95% of the time I'm in hotspots. My second reason is that I'm traveling to the states soon, and I really would like to avoid roaming charges when I'm down there.
    I can't seem to find a way to turn off my data and use wifi only. Maybe I'm doing something wrong, I don't know.
    If anyone knows how to turn off my data, I'd really appreciate the help.
    Thanks!
    06-04-10 09:52 AM
  2. Pi Guy 3.14's Avatar
    Welcome to the site. And congrats on the 9100!

    I dont have a 9100 (unfortunately) but all those settings should be under:

    options > mobile network

    Hope that helps.
    06-04-10 10:11 AM
  3. bighap's Avatar
    There is no need to turn off anything. If your Wifi icon is white, not gray, it will use wifi as opposed to 3G.
    06-04-10 10:39 AM
  4. secret_society47's Avatar
    Thanks for the advice. I figured out how to turn off the roaming/data. I still can't use wifi though. I can sit right beside my router but the icon is still gray and I can't use it.
    The status of the connection says it's fine and connected, but it's a no go.

    Is anyone else having this problem...or has anyone made it work? Lol.
    06-05-10 09:09 AM
  5. nonpromqueen's Avatar
    Thanks for the advice. I figured out how to turn off the roaming/data. I still can't use wifi though. I can sit right beside my router but the icon is still gray and I can't use it.
    The status of the connection says it's fine and connected, but it's a no go.

    Is anyone else having this problem...or has anyone made it work? Lol.
    I was having issues with mine as well. Went to the wifi options clicked "edit" on my connection and changed it from "manual" to "automatic" that kept it on.
    06-05-10 10:25 AM
  6. secret_society47's Avatar
    I was having issues with mine as well. Went to the wifi options clicked "edit" on my connection and changed it from "manual" to "automatic" that kept it on.
    I tried that and it still doesn't work. Thanks though.

    When I go to connection options, my wifi is on, but instead of an 'x' or a checkmark, I have a little white dash.

    I guess that's what I get for jumping on the bandwagon first. Lol.
    Anybody else have any suggestions?
    06-06-10 03:51 PM
  7. bighap's Avatar
    What type of encryption are you using on your wireless router? You might want to try changing that. Some don't play well with berries.
    06-06-10 04:50 PM
  8. secret_society47's Avatar
    What type of encryption are you using on your wireless router? You might want to try changing that. Some don't play well with berries.
    My best guess is 128-bit (it's a Bell wireless router and modem); so does that make a difference?

    I will admit this is the only signal I've tried so far to connect too. I've had the 9100 all of three days and since I'm not a Starbucks person, I haven't gone to any open wifi hotspots to test things out. I'd still like to connect to my home network though since I am here kinda a lot. Lol.
    06-06-10 06:56 PM
  9. farfrmnormal's Avatar
    This may be a stupid question but gotta start with the basics, have you deleted the network and tried starting from scratch? Enter your security information for the router so that your berry can talk to it?
    06-06-10 07:39 PM
  10. secret_society47's Avatar
    This may be a stupid question but gotta start with the basics, have you deleted the network and tried starting from scratch? Enter your security information for the router so that your berry can talk to it?
    It's not a stupid question. Lol. It was one of the first things I thought of. It didn't work though.
    06-07-10 09:12 AM
  11. Bozed's Avatar
    you are not the only one having that problem, i can't get it to connect to wifi either won't go white it stays grey!

    blackberry pearl 3g with rogers
    06-07-10 04:04 PM
  12. wise men's Avatar
    you are not the only one having that problem, i can't get it to connect to wifi either won't go white it stays grey!

    blackberry pearl 3g with rogers
    I have the same problem, it go white for a few minutes and back on gray. I have a 9100 whit rogers.
    06-21-10 11:48 AM
  13. domisqueek's Avatar
    I can't get my wifi to connect either. Even got the IT guys at work to look at it and they can't figure it out. It just stays grey.

    Hopefully the ppl at the store can get it to work! I travel alot and the wifi is one of the reasons why I went with BB.
    12-03-10 12:05 PM
LINK TO POST COPIED TO CLIPBOARD