1. goldieroper's Avatar
    I went into o2 shop as my signal was constantly crap or sos only, they said my sim card was too old so changed it and said everything would stay the same. since changing my sim card i connot connect to wifi, ive spoken to o2 who doesnt understand why, i went through all the steps they sugested but nothing works. I have noticed that if i click on wifi options click on my home wifi look in wifi tools then look at wifi diagnostics under the bit saying blackberry infrastructure it has a cross next to connecting. Im not sure if this is the problem as briefly this did go to a tick (not sure what i did) but either way i still couldnt get to use my wifi. I also noticed that my signal still crap ( apparently this nis due to a o2 tower been down in my area) and when i used ebay app and went to pay for item usually would take me straight to pappal mobile but now says internal error so cant use that either. Please can anyone help me but i do ask not to use technical jargon as i dont understand it all lol xxx ( ihave posted this in bold 9700 as well but wasnt sure if everyone looked at specific model forums so put it in here too ) x
    08-09-12 05:13 AM
  2. SwitchBeach's Avatar
    Do you have a BlackBerry Data Plan? Are you able to connect okay over the carrier network?
    08-09-12 06:25 AM
  3. goldieroper's Avatar
    not sure what data plan is lol, i can connect to internet sometimes just using mobile with no wifi depending on how strong signal is but not all the time x
    08-09-12 10:33 AM
LINK TO POST COPIED TO CLIPBOARD