1. malita's Avatar
    Hi!
    I am new to BlackBerry phones, therefore I have some questions about the phone. First of all, it is my first BlackBerry and I am not fully informed about its features. Got that phone from Uk t-mobile, asked for the MEP code and unlocked the phone, so now I am using it with prepaid SIM, so basicly without a data plan. I am thinking to select one from my local BlackBerry provider - Bite ( subsidiary company for vodafone? Well they are partner companies ), but that is not the problem.

    I am trying to connect my home wireless router - Airlive Mimo-g - but the connection often disappears, so the device disconnects from the WiFi service. Sometimes it is possible to open few web pages before the connection disappears.. It is almost impossible to use google sync or other applications that use wifi. I got the google sync work at my girfriends house, so could it be my routers problem? It is really annoying when you are standing next to the router but the connection disappears, or the SSID is not found in the available network list.

    The router setting is:


    I'm just curious - do I really need a data plan to access the WiFi? Please help me with this question, it is really anoying.

    + Is it possible to make the caller_ID picture larger?
    + Will the BlackBerry inform me when it is using 3g network and when WiFi ? ( I would like to prioritise which network to use ).

    Well I hope that you will understand my post ( Because of my bad english and disorganised text ).

    Thank You for reading!
    06-29-10 09:07 AM
  2. wnm's Avatar
    What kind of router does your GF have?

    Best bet is to Google "Connecting Blackberry to a MIMO router".

    You don't need a data plan for WiFi, only for wireless network use.

    You can prioritize you connection under Options > Mobile Network. You can set connection preference to WiFi preferred. You can also set it to WiFi only, but if you are out of range of WiFi you won't be able to make or receive phone calls.
    06-29-10 09:23 AM
  3. Phill_UK's Avatar
    You can prioritize you connection under Options > Mobile Network. You can set connection preference to WiFi preferred. You can also set it to WiFi only, but if you are out of range of WiFi you won't be able to make or receive phone calls.
    As the device is originally a T-Mobile UK one, and that carrier does not support UMA, the OP will not have the 'Wifi Preferred' option

    Posted from my CrackBerry at wapforums.crackberry.com
    06-29-10 09:29 AM
  4. wnm's Avatar
    Thanks. Didn't know that about TMO UK. Only thing to do is to turn off the wireless network when you want to be sure to use only WiFi.
    06-29-10 09:40 AM
  5. malita's Avatar
    You don't need a data plan for WiFi, only for wireless network use.
    Oh, well that is great. Could not get the right answer for a while.
    She will be at home after five hours, so I will ask her to tell the name. I am just thinking that it was suprising that the google sync worked there 100%, usually it crashes at ~ thirty percent, and I can't get through - was it luck or did the WiFi really worked.

    Phill is right, I can not find any preferred setting, and that is sad. So if both - WiFi and 3g will be acessable, then it will chose 3g? Is there any way to evade that, for example einstalling the OS, or if I change my carrier and add a data plan?

    It seems weird, that the connection from five bars can drop to two, or even disappear from the network list even if I am standing next to the router.

    I will try to remove any router security, and see what happens then. Well, so it can't be my BB problem? What about the WiFi channels ( 1 - 13 ), do they change anything?

    Thanks. Didn't know that about TMO UK. Only thing to do is to turn off the wireless network when you want to be sure to use only WiFi.
    That is really annoying.
    Last edited by malita; 06-29-10 at 09:54 AM.
    06-29-10 09:50 AM
  6. wnm's Avatar
    Different routers set up differently. At home I have Linksys and all I had to do was scan for networks and enter the password. My mom has a different style Belkin Router and you have to get the router code and enter it.

    Since I have UMA available, I know for sure I'm on WiFi, when the WiFi icon is white and I get the cell tower icon on my home screen for UMA. Otherwise I'm never sure if I'm on WiFi or 3G.
    06-29-10 10:08 AM
  7. malita's Avatar
    Removed the password, seems like it is working better, sometimes disconnects, but works better than secured WiFi. Any ideas? What to do next? Few times got

    Since I have UMA available
    How can I enable the UMA ( whatever it is ) ? And how will it effect me? It seems quite dumb, that I can not control 3g and WiFi usage..

    Oh, why could there be problems with the WiFi, if there are no problems with connecting a laptop or psp to the router?

    + Could there be any problems when I switch to a new carrier - Bite, if the phone is from tmo?

    Few times got this -
    Code:
    Reason: Failed to connect to the network
    
    
    Unable to connect to the internet, please try again later.
    If the problem persists please contact your service provider.
    Last edited by malita; 06-29-10 at 10:59 AM.
    06-29-10 10:55 AM
  8. exelant's Avatar
    That is sad T-Mo in England doesn't support UMA but T-Mo USA does.
    06-29-10 11:02 AM
  9. wnm's Avatar
    Removed the password, seems like it is working better, sometimes disconnects, but works better than secured WiFi. Any ideas? What to do next? Few times got


    How can I enable the UMA ( whatever it is ) ? And how will it effect me? It seems quite dumb, that I can not control 3g and WiFi usage..

    Oh, why could there be problems with the WiFi, if there are no problems with connecting a laptop or psp to the router?

    + Could there be any problems when I switch to a new carrier - Bite, if the phone is from tmo?

    Few times got this -
    Code:
    Reason: Failed to connect to the network
    
    
    Unable to connect to the internet, please try again later.
    If the problem persists please contact your service provider.
    Your carrier has to support UMA. Per Phill_UK's post, TMO UK doesn't support it so it's not available. If UMA is available, you don't have to do anything, it will come on by itself.
    06-29-10 11:05 AM
  10. malita's Avatar
    Tried to google what is UMA, but did not get my mind clear. So if I subscribe for a BlackBerry data plan with a new carrier, then nothing with the WiFi connection problems will not change?

    Found on google what some user posted about my potential carrier -
    "About 3G and WiFi. Bite doesn't support BIS trough WiFi, so if you ar planning to use the phone in the WiFi network, most of the BlackBerry applications will not work. You will have to switch off and use 3g."

    Is it true? If the service provider does not support UMA, then the applications will go through 3G?
    Last edited by malita; 06-29-10 at 11:30 AM.
    06-29-10 11:20 AM
  11. wnm's Avatar
    The Wifi issue itself is most likely your router. Best way to check is connecting to other security protected routers at work or friends to see how the WiFi works.

    The main advantage for UMA is that if you are in area with really back cell service, if UMA is available, you can make call and receive phone calls. I have this situation at one of my sisters in laws houses. I can barely make a call on the mobile network, but when I connected to her router and got UMA I had no problems.

    Also, when I get the white WiFi icon, I can switch my browser to Hotspot browser to get the fastest internet speeds.
    06-29-10 11:27 AM
  12. Phill_UK's Avatar
    Tryed to google what is UMA, but did not get my mind clear. So if I subscribe for a BlackBerry data plan with a new carrier, then nothing with the WiFi connection problems will not change?
    Forget about UMA. Your carrier probably doesn't support it, and your device certainly doesn't, so you won't get it anyway.

    Like wnm said, your wifi problem is likely down to your router, so concentrate on fixing that first
    Last edited by Phill_UK; 06-30-10 at 10:28 AM.
    06-29-10 11:33 AM
  13. malita's Avatar
    Yes, I agree with you that the first thing to do is to fix my wifi router, but I need your advices or suggestions - what to do, what to try.

    So, the total information:
    Access point with password:
    * Laptop - Ok
    * PSP - Ok
    * BB, standing next to router - Bad signal, easily can drop from 5 to 2 to 0 bars and even disappear from network list. If it connects to the point, you can use the connection for a whil, then it disappears.

    Access point without password:
    * The same
    * ----||----
    * BB - Better signal, more chances to connect to the network and stay connected to it, although the connection can disappear. There are times when the hotspot browser is showing requesting and then "unable to find the requested server." althought the SSID is showed next to my service provider name on the home screen, after few refreshes, it goes to that web page.

    Eh, needed to disable APN, so I can register the WordToGo - so it used WiFi after that?

    Anyway, I ran the diagnostics test when the router security was disabled - did not knew how to get the data here, so I posted it on my web page trough hotspot browser, so now I can post it here -
    Code:
    Wi-Fi Diagnostics (Advanced): 
    Jun 29, 2010 18:50:47 PM 
    Wi-Fi 
    Current Profile: malita.air
    SSID: malita.air
    AP MAC Address: *:*:*:*:*:*
    Security Type: No Security
    Association: Successful
    Authentication: Successful
    Local IP Address: 192.168.0.73
    Signal Level: -38 dBm
    Connection Data Rate: 54 Mbps
    Status: Network acquired
    Authentication Failure Reason: 
    Network Type: 802.11b/g
    Network Channel: 6
    Pairwise Cipher: None
    Group Cipher: None
    Gateway Address: 192.168.0.1
    DHCP: Successful
    Primary DNS: 1*5.1**.12.**2
    Secondary DNS: *0.232.2**.**2
    DNS suffix: apollo.lv
    Subnet Mask: 255.255.255.0
    Server Domain Suffix:
    Certificate: Not Applicable
    Software Token: Not Applicable
    Hotspot Code: 
    Hotspot Message: Not Applicable
    Hotspot Status: Not Applicable
    
    VPN 
    Current Profile: 
    Concentrator Address: 
    Contact: N/A 
    Authentication: N/A 
    Secure Device IP: 
    Status: 
    VPN profile is not found. 
    Resolving Concentrator: N/A 
    Concentrator IP: 
    Primary DNS: 
    Secondary DNS: 
    DNS Suffix: 
    Secure Subnet Mask: 
    Retry at: 
    Session Lifetime: 
    Re-login at: 
    Failed Login Attempts: 0 
    Certificate: Not Applicable
    Software Token:
    06-29-10 12:23 PM
  14. malita's Avatar
    Sorry for the double post.
    wnm, the router at my gf house is airstation buffalo.
    So still no ideas what could I check? Could it be that my router is to weak? Althought I am sitting next to it.
    06-29-10 04:43 PM
  15. wnm's Avatar
    I'd like to help more, but I'm getting to the limits of my knowledge on these things. If I had the stuff in front of me, I could help you more, but obviously that won't work. The only other question I have is what OS are you using on your Blackberry? A newer or older OS may work better, though I've used .586 and .743 on mine and .714 on my wifes and WiFi works great. Your best bet may be to contact the Airlive support.

    Sorry I can't help more.
    06-30-10 07:37 AM
  16. malita's Avatar
    hey! Just got over to a new carrier and now I have a data plan activated.
    Still want to resolve this problem. First of all - the wifi icon isn't constantly white - it switches from white to grey ( it is connected to my WiFi router ). Although I can surf the web with no problems - but i would like to know is the blackberry using WiFi or my mobile network.
    If the WiFi icon is grey while the blackberry browser is being used, then on the top left ( next to the signal bars ) it gives me a 3g or EDGE sign, if the WiFi icon is white, then a WiFi banner. So, dose it means if my device is showing a grey WiFi icon, then it will be using mobile network? I'm sure it will use mobile network if the WiFi isn't enabled ( because when trying to play a youtube video it warns me about the possible charges.. ).

    Well that was the first question, the second one is about youtube videos - I can't play them over WiFi network ( On 3G and EDGE everything is working ), I searched around this site and found out something about port triggering - why is it needed and what should I do? You can see in the attachment what I tryed. Any advices? I know that it's my router, because at my friends house ( he has a ASUS router ) wideos played quite fine without a data plan..

    And the third question - seems like app world isn't supperted at my country, is it possible to get those apps somehow?

    Well I know that I would need to buy a new router, but I don't want to if this one is working. Hoping for some good replys

    EDIT: oh, the forth question Can I switch from my original T-mobile os to mt new carriers ( bite ) ? So I would have some features that t-mobile UK have removed? Will I lose my warranty? And how hard / easy is it?
    Last edited by malita; 08-09-10 at 07:06 AM.
    08-09-10 07:03 AM
  17. wnm's Avatar
    hey! Just got over to a new carrier and now I have a data plan activated.
    Still want to resolve this problem. First of all - the wifi icon isn't constantly white - it switches from white to grey ( it is connected to my WiFi router ). Although I can surf the web with no problems - but i would like to know is the blackberry using WiFi or my mobile network.
    If the WiFi icon is grey while the blackberry browser is being used, then on the top left ( next to the signal bars ) it gives me a 3g or EDGE sign, if the WiFi icon is white, then a WiFi banner. So, dose it means if my device is showing a grey WiFi icon, then it will be using mobile network? I'm sure it will use mobile network if the WiFi isn't enabled ( because when trying to play a youtube video it warns me about the possible charges.. ).
    If the WiFi icon is white, you are using data via your home network and internet service provider. You can check by disabling the mobile network and see if you can browse the web. Also, if your carrier supports UMA, you may see that rather than the 3G or EDGE.

    If the icon is grey, wifi is active, but your data is not using the network.


    Well that was the first question, the second one is about youtube videos - I can't play them over WiFi network ( On 3G and EDGE everything is working ), I searched around this site and found out something about port triggering - why is it needed and what should I do? You can see in the attachment what I tryed. Any advices? I know that it's my router, because at my friends house ( he has a ASUS router ) wideos played quite fine without a data plan..

    And the third question - seems like app world isn't supperted at my country, is it possible to get those apps somehow?
    Not sure about youtube. In addition to your router, it could be your security software.

    You can purchase apps from other sources such as MobiHand (which powers the CB App Store and other BB site App Stores). Handango is another option.

    Well I know that I would need to buy a new router, but I don't want to if this one is working. Hoping for some good replys

    EDIT: oh, the forth question Can I switch from my original T-mobile os to mt new carriers ( bite ) ? So I would have some features that t-mobile UK have removed? Will I lose my warranty? And how hard / easy is it?
    You can use any carriers 9700 OS on your BB. Can't tell you about warranty issues, but for 95% of the time I've owned BB's (2+ years) I have not used my carriers OS. As for upgrading OS, check out Blackberry 101 for instructions. Make sure that you first backup your data and 3rd party apps.
    08-09-10 11:39 AM
  18. malita's Avatar
    Well, disabled the mobile network, and enabled wifi, although the WiFi icons was grey I could downloadweather plus from crackberry. But I'm not sure will it use my mobile network when I'll connect to it. What is the best os?

    And what about the port triggering? Have you heard anything about that?
    08-09-10 11:55 AM
  19. lysithea's Avatar
    so did you do anything to your BB or router to fix the problem with the wifi? I ask because I also have an airlive router and it won't work either. Works perfectly fine when I use wifi at work, friend's houses, etc, but at home it just won't work.
    09-25-11 04:09 PM
  20. malita's Avatar
    I switched to a better router - linksys wrt54gl Everything works perfect!
    10-08-11 01:03 PM
LINK TO POST COPIED TO CLIPBOARD