1. Hotdogtree's Avatar
    Im new to the CrackBerry forums, and first off, Id like to say, its amazing! I recently purchased the BlackBerry 8520, and connected it to my home wifi, it doesnt stay connected, like my laptop, disconnects alot, and is virtually unusable. It doesnt help that I have bad signal at home to, so I cannot use the GPRS internet on it either.

    Any help would be great, and if you need any more info, please let me know!
    Last edited by Hotdogtree; 04-09-10 at 06:34 AM.
    03-31-10 06:15 PM
  2. Nozzles Brewin's Avatar
    I guess I'm just confused as to what you're asking, if your wifi service @ home is shaky with your laptop there isn't anything you can do to improve it with your BB...
    03-31-10 06:18 PM
  3. papped's Avatar
    If it's a general signal issue for any device, there might be nothing you can do short of buying a new router.

    Try upgrading to the latest firmware for your router.
    03-31-10 06:30 PM
  4. Hotdogtree's Avatar
    Sorry, what I want is for my BlackBerry to connect to my home network, and stay connected, when I am in the house. When I use it, it will connect to the wifi for a short while, but disconnect again. Is there anyway to connect it, and keep it connected?

    What I was saying about my laptop, is that when that connects to the internet, via my wifi connection, it stays connected, just like all the other phones and computers in the house. The connection on it is fine, and I want my BlackBerry to stay connected, just like my laptop.
    Last edited by Hotdogtree; 04-05-10 at 10:52 AM.
    04-05-10 10:50 AM
  5. g_patkar's Avatar
    Try switching your router's Wifi security to WEP 64 Bit Hex and only use a 10 digit numeric key! (E.g. 0503429111)

    I was facing this problems forever with my D Link router when a D Link technician suggested the change. Gets connected fast and stays connected!

    Please let me know if this worked for you!
    Last edited by g_patkar; 04-06-10 at 08:34 AM.
    04-06-10 08:30 AM
  6. kwkid's Avatar
    Try switching your router's Wifi security to WEP 64 Bit Hex and only use a 10 digit numeric key! (E.g. 0503429111)

    I was facing this problems forever with my D Link router when a D Link technician suggested the change. Gets connected fast and stays connected!

    Please let me know if this worked for you!
    I wouldn't recommend downgrading your router's security for this issue. There has to be a better answer. I use WPA2 with my BB without any problems whatsoever. WEP 10 digit key takes less than 3 minutes to break for someone who knows what they are doing.
    04-06-10 08:46 PM
  7. dalethesnail's Avatar
    how far away frrom your router are you? if there is alot of solid walls between you and it, that the signal wont be grat, because the BB's wifi signal is smaller that a laptop, that might be the reason...
    04-07-10 06:54 PM
  8. maxfieldd's Avatar
    I am also having a wifi issue with my wife's curve. When I try to activate the wifi in the "manage connections" icon it never turns green. If I do a battery pull, I can get the wifi to come on momentarily; then it shuts off and I have to do another battery pull. I have tried multiple os's with no luck. I am starting to feel like this is a hardware issue.

    Any one else have this problem? I have searched the board and google and it looks like I am alone.
    04-08-10 03:34 AM
  9. M.T.A.C.'s Avatar
    Sorry, what I want is for my BlackBerry to connect to my home network, and stay connected, when I am in the house. When I use it, it will connect to the wifi for a short while, but disconnect again. Is there anyway to connect it, and keep it connected?

    What I was saying about my laptop, is that when that connects to the internet, via my wifi connection, it stays connected, just like all the other phones and computers in the house. The connection on it is fine, and I want my BlackBerry to stay connected, just like my laptop.
    manage connections disable mobile network and make sure WiFi is check marked.
    04-08-10 04:17 AM
  10. Hotdogtree's Avatar
    The router is down the stairs, I am using it upstairs, should I try it sat nearer the router? Thanks for all the help/suggestions so far!
    04-08-10 07:28 PM
  11. papped's Avatar
    WEP is so useless that you might as well disable the encryption and just use mac address filtering + hidden SSID at that point...

    Besides I use wpa2 as well with no issues, so if it works on WEP and not WPA/WPA2, it's probably your router or the router firmware that is causing the issue...
    04-08-10 07:43 PM
  12. mangcool's Avatar
    Im new to the CrackBerry forums, and first off, Id like to say, its amazing! I recently purchased the BlackBerry 8530, and connected it to my home wifi, it doesnt stay connected, like my laptop, disconnects alot, and is virtually unusable. It doesnt help that I have bad signal at home to, so I cannot use the GPRS internet on it either.

    Any help would be great, and if you need any more info, please let me know!
    Your wireless router is probably the problem. If you have a big house, I don't really recommend G Wireless Networking. It slows down the network when the signal's low.
    04-08-10 10:53 PM
  13. Hotdogtree's Avatar
    If wifi is ruled out, is there anything to do to boost the T-Mobile signal around my house to make better use of the free internet I have?
    04-09-10 06:35 AM
LINK TO POST COPIED TO CLIPBOARD