1. MattSpartans20's Avatar
    So I am on vacation down in Florida so I dont was to use my data on my phone as Rogers will charge me a bundle for it, so ive connected to the wifi in the house and its got full signal but I cant access anything, it keeps coming up saying "Unable to connect to the Internet, please try again later. If the problem persists please contact your service provider."

    Also cant send BBM or emails.

    I have reset my phone done battery pulls, and also reset the router......

    Now heres the kicker....obviously I was able to connect my laptop to the network with no problems and the worst part is my dad has the same phone (9800 Torch) but on Bell in Canada and his wifi is working perfectly down here.

    PLEASE HELP I'm getting sick and tired of this piece of S#!@ phone
    12-01-10 11:01 PM
  2. gardengnome's Avatar
    try under "Manage Connections" - Mobile Network Options - there should be a choice to prefer data over wifi or over 3G.
    12-01-10 11:03 PM
  3. MattSpartans20's Avatar
    try under "Manage Connections" - Mobile Network Options - there should be a choice to prefer data over wifi or over 3G.
    No i dont want to use data, i was to use wifi...thats the whole point so i dont get charged
    12-01-10 11:07 PM
  4. dochouse7's Avatar
    Pretty sure you can't send BBM messages, and can't send/receive emails from your @blackberry account if you aren't connected via the mobile network (I'm not 100% sure about this though, so if anyone does know for sure, feel free to correct me here)

    As gardengnome suggested, set your preference to use the wi-fi rather than the mobile network.

    If that doesn't work, turn off the wifi radio for a minute or so to confirm your BB is actually receiving messages.

    Also, check to see how the wifi is set up at the house. Is it encrypted? Have you entered the password correctly? Is it a managed open network (as in, anyone can connect their device to the network, but cannot use the network in any way until they successfully log in through an internal portal page via their browser)? The company I work at has a setup like this for any personal devices such as laptops or phones.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-01-10 11:30 PM
  5. luvmywhitetorch's Avatar
    try under "Manage Connections" - Mobile Network Options - there should be a choice to prefer data over wifi or over 3G.
    No i dont want to use data, i was to use wifi...thats the whole point so i dont get charged

    garden is right. you need to turn on data services under mobile network options. this doesn't eat up anything from your data plan.
    12-01-10 11:39 PM
  6. Matrix Leader's Avatar
    Make sure you are running os 6.0.0.246 or 6.0.0.337
    12-01-10 11:57 PM
LINK TO POST COPIED TO CLIPBOARD