1. koolme's Avatar
    Hi Gurus,

    I know this has been posted before but I can't seems to find the solution. I have a Blackberry Bold 9000 (Japan) then I have upgraded it to OS 5 posted on this forum too.

    I am using a D-Link router for WIFI for 2 laptops and 1 desktop without problems. But when I try connecting the Blackberry Bold 9000, it doesn't connect (no IP obtained). I already changed the channel on the router but still not working.

    Any help?

    Thanks!
    01-22-10 05:31 AM
  2. cellfservices's Avatar
    Interesting. I'm guessing your wifi logo is still greyed out? Check your service books to make sure you have the wifi tcp/ip browser and transport files. Also, you may want to try changing your settings to "hotspot browser" in options -> advanced -> browser. Hopefully it works for you! I had the same problem before. It wouldn't let me 'obtain an ip', but after changing my settings, it worked. Turn your mobile network connection off and play around with it. Hopefully it works!
    01-23-10 12:30 AM
  3. koolme's Avatar
    I did that already and all settings are correct but still the WIFI icon is greyed out. Even with the old OS, I have encountered this problem. Under Service Book, I have the following entries.

    MMS Client [MMS]
    WAP SMART [WPTCP]
    WAP Browser (SMART) [BrowserConfig]
    WAP Push Config [WAPPushConfig]
    Wi-Fi TCP/IP Browser [BrowserConfig]
    Wi-Fi TCP/IP Transport [WPTCP]

    Anymore suggestions?

    Thanks!
    01-25-10 02:48 AM
  4. CrackBerryNewBB's Avatar
    You can try to highlight the Service books (one at a time) and delete, then click the BB key (option key) again and you should get an option that says undelete or something similar. this will re-add and refresh your service books on your device. also, try to login to your BIS account and click "Help" then "Send Service Books", that should fix your Email problems.

    Honestly, i would just downgrade and wait for an official release for you. OS 5.0.x.x is too buggy right now for my likings. I downgraded to 4.6x (whatever is most current for ATT - US) and am much happier with the overall performance (and battery life) of my phone. Ill just hang tight until the official ATT release is dropped, hopefully soon.
    01-25-10 12:32 PM
  5. koolme's Avatar
    I tried older and latest OS but still same problem. Any suggestions?
    02-15-10 03:16 AM
  6. koolme's Avatar
    What is the Service Book for WiFi? Please let me know which Service Books should I delete/restore. Thanks!
    02-16-10 08:33 PM
  7. bradbrownjr's Avatar
    So, I found the newly released OS 5 on blackberry.com and installed it. I had to remove the vendor.xml, as the directions on the Interwebs suggest because AT&T still aren't on the bandwagon. The update went smoothly, even transferred my ringtone profiles, contacts, etc. I just had to reorganize my app folders and re-setup some of the apps.

    The update also kept my wireless settings for the previously accessed WAPs. However, I could not connect anymore to any of these SSIDs. For giggles, because I had nothing else to lose, I deleted each SSID from the list. Once I rescanned and readded my WAP with WPA2, it connected without issue. So, somehow, the old settings were confusing the BlackBerry.

    I hope this helps anyone else looking for the solution.
    02-24-10 05:30 PM
LINK TO POST COPIED TO CLIPBOARD