06-20-10 08:58 AM
38 12
tools
  1. clubowner's Avatar
    Might as well be the first to post. The wifi on my 8820 is driving me crazy. I turn the wifi on, search for my home network...It finds it, no problem...Then I enter the wep key and it comes back with the error message "unknown network failure" I have called ATT, more then a few times, the router company which is 2wire home portal (and more then five years old), they sent me instructions that are way above me to start changing codes on my router...I have tried everything from changing my password on my router, using six different wep key's...nothing works..I'd like to know if some routers are just not compatible with the 8820?? For the record, I ordered a new router yesterday from ATT/Cingular, I think its called a Westville Gateway....is there anything on the 8820 that I have to re configure? Or, anything on the new router I must do when setting it up to get it to work? Any suggestions would be greatly appriciated.
    09-26-07 09:05 AM
  2. clubowner's Avatar
    Figured it out...it was my old 2wire router..Installed a new Westell router and it connected in a minute....
    09-26-07 11:46 AM
  3. spike41615's Avatar
    im having the same problem, router is only 1-2 years old. Even with the right pass key it says it failed. AND on the open network at school it failed too. what gives?
    09-26-07 12:30 PM
  4. kasperapd's Avatar
    Sometimes if the right ports are not open on the router you will not get connected.
    09-27-07 04:00 AM
  5. axksolar's Avatar
    do you have any ideas how we can determine which ports need to be open? thanks.
    10-15-07 12:56 PM
  6. somthinsim's Avatar
    I was having the same issue with my Tmo Curve and the rep was helping me out with my dlink that I have had for years now DI 524, anyways, she said that some BB's need to have 500 UDP and 4500 UDP open (when I entered in the firewall port settings, I entered in a * rather than udp for the protocol section, so you may need to use * instead of UDP for the open ports on you FW). Try checking out your routers logs it see if the packets are being dropped and then match the ports to your firewall
    10-15-07 01:34 PM
  7. avi#CB's Avatar
    I have the 8320 Curve (TMo) trying to setup the Wifi and all I get is the W010(error), WiFi association failed. I called TMo, their useless, Rim couldn't really do much. I am running a Linksys WRT54GX2 w/ WEP.
    Anyone have any ideas?
    10-19-07 02:23 AM
  8. shadowsports's Avatar
    Good Morning,
    I was able to connect my ATT 8820 to my Linksys wrt54g pretty easily. I am using WPA-PSK and MAC address filtering. Like you, I am new BB user. Let's confirm a few things:

    -You know your SSID
    -Router is only using WEP for security
    -You are not using MAC Address filtering

    Start by deleting any wireless profiles you tried to setup that failed previously. Create a wireless connection manually. Type your SSID. This must match exactly, case, spaces, etc. Now select WEP for encryption. Next type your WEP key. Ensure the setings you are entering match your routers settings. They must match (exactly). Save, then select the profile you created, menu button, then connect. The device should associate with your router and connect. No ports on the router are required to be open for connection, as they do not affect a wireless devices ability to connect to a router or AP. Ports should always be closed, or stealthed. Open ports are pingable from the internet and contribute to a less secure network.
    10-19-07 08:46 AM
  9. dtd's Avatar
    Hoping I can help...
    I experienced the exact same problem with the same W010 error message.
    I had Linksys on the phone for well over an hour and the tech finally had me do the following three things and my Curve is now connected on my home WiFi....

    1. Upgrade the Firmware
    2. Change channel to 3 or less
    3. Change ACK Mode to: No ACK

    Unless you know where to find these three things, I advise you to place a phonecall to your router manufacturer; but to speed things up, let them know this is what you need to do.

    Good luck. Once this was done, I power cycled both the modem and router and the Curve connected with ease.
    10-23-07 09:04 PM
  10. jherbold's Avatar
    I've been having probelms connecting my 8320 with a D-link DI-614+ 802.11b router/access point. Sometimes the blackberry would see it and sometimes not, but I could never connect.
    I messed with everthing in the blackberry and on the router. I had to enter the ssid manually many times. I tried different channels used an open system for a while and finally I've had success. I want to share my experience in the hopes of helping someone avoid this frustration.

    Throughout my attempts the blackberry always seemed like it was about to connect but then it would say the the Wi-Fi connection failed with an error code of W002 or W010.

    Sometimes I would get an error about DHCP. So I followed the advice in forums and told the router to assign a specific IP address to the blackberry's MAC address. I also moved that IP address into the DMZ (outside of the router's firewall) just incase the problem was the firewall blocking some ports that the blackberry uses.

    These are good things to try if you're having a problem. I don't have conclusive proof but I believe my problem was something different.

    The D-Link 614+ supports more than the 802.11b standard it has enhancements that allow 22 Mbps when paired with the proper D-Link PC card. I believe that turning off these and other wireless preformance enhancement features was the key to making the Wi-Fi connection.

    In performance dnder the advanced tab of the DI-614+ web management interface I limited the speed to 11Mbps and turned off 4x mode (don't know what that is).

    I've been able to turn WEP back on. The the point of all this writing is have a look a see if your access point has some advanced wireless settings that you can change giving it "plain vanilla" standard compliant behavior. That said, your mileage may not be much better than mine. I'm not seeing very fast page loads so it seems the blackberry and access point are not playing well together. So maybe the best thing is to save a headache and buy a new access point.
    11-08-07 09:29 PM
  11. jherbold's Avatar
    I just followed the advice of dtd. I switched from channel 6 to 2. Signal level in blackberry Wi-Fi diagnostics is about the same (near 30dBm) but data rates (web pages, maps) are dramatically different. I don't know the details of Wi-Fi radios but this seems strange to me.

    Well I waited a few minutes before posting this and it looks like I'm back to the same slow connection. What gives?
    I bounced around to other channels and noticed in site survey I have neighbors on channels 6, 9, 11 which could be the root of this problem even though they are very weak at -90dBm. So I'm back at channel 2 and getting good performance again. This only lasts for a few minutes after I change the channel and restart the access point. Then maps won't get new data as I scroll or zoom, new webpages won't load and some pings get timed out.

    I also notice that switching between apps and looking at Wi-Fi diagnostics gets slow. I'm guessing that the AP and blackberry radios don't work well together and the blackberry is seeing lots of bad packets that must be eating CPU time to process.

    My conclusion: time to get a new access point.

    I frustrated to splash out for a new handheld and now I have to buy a new access point to work with it? More interoperatibility testing please.
    11-09-07 01:35 AM
  12. hashby's Avatar
    I also was getting the W010 error message using a Linksys WRT54G router. I upgraded the firmware to 1.02.2 and all is well.
    12-08-07 08:43 AM
  13. Dreamzboy's Avatar
    Hi,

    The problem here I think everyone is having is not getting an IP Address. I can connect to any wireless router, but not being able to get an IP Address. I tried connecting to a Linksys WRT54GL and D-Link Router with Wireless Security Disabled, no luck. Tried it with WPA as well and no luck. Any idea? Do I have to turn anything on from my BB to receive an IP Address?

    Also, I heard a rumor saying that we get charged if we use our Wifi (not Mobile Network) since it uses GRP something, is that correct?

    Any help is a blessed to us all who own this device.

    Thanks,
    Dreamzboy
    12-10-07 12:57 PM
  14. jfk's Avatar
    I just figured this issue out on my Belkin router. I was getting the same error "w010 wifi association failed". Turns out all I needed to do is disable the 802.11e QOS option. I left the ACK mode at "Immediate ACK" but I think it ignors this when the 802.11e QOS option is disabled. Btw my bb is a 8320. Hope this helps...
    01-11-08 08:58 PM
  15. aardvarq's Avatar
    Thanks to all above, I finally have success connecting my wifi to my 8820.

    Router: D-Link 614+ (with the two antennas)

    =============
    Here are the settings that I think may matter from the Advanced Tab --> Performance screen:

    Basic Rates :
    1-2-5.5-11(Mbps)
    TX Rates :
    1-2-5.5-11(Mbps)
    Preamble Type :
    Long Preamble
    Authentication :
    Auto
    SSID Broadcast :
    Enabled

    4X Mode :
    Disabled

    ======
    On the DHCP settings, I too assigned a static address to the Blackberry's MAC
    ======
    I am using MAC filtering
    ======
    I changed the channel number to 2


    So far, this works.
    -Varq
    sandeepdanil likes this.
    01-18-08 10:39 AM
  16. yumdimsum's Avatar
    Thanks to all above, I finally have success connecting my wifi to my 8820.

    Router: D-Link 614+ (with the two antennas)

    =============
    Here are the settings that I think may matter from the Advanced Tab --> Performance screen:

    Basic Rates :
    1-2-5.5-11(Mbps)
    TX Rates :
    1-2-5.5-11(Mbps)
    Preamble Type :
    Long Preamble
    Authentication :
    Auto
    SSID Broadcast :
    Enabled

    4X Mode :
    Disabled

    ======
    On the DHCP settings, I too assigned a static address to the Blackberry's MAC
    ======
    I am using MAC filtering
    ======
    I changed the channel number to 2


    So far, this works.
    -Varq

    Hi Varg,
    I have tried your instructions it did not work for me...using Dlink di-624
    I got as far as assigning static ip on my BB and router using mac address.
    my BB showing connected but when I checked the status the ip shows 0.0.0.0 does anyone else have any ideas for me to get my BB 8320 working with my router? (also tried at my friends house using Linksys router to no avail)
    thanks,
    yumdimsum
    01-22-08 02:27 PM
  17. kittyranma's Avatar
    I just figured this issue out on my Belkin router. I was getting the same error "w010 wifi association failed". Turns out all I needed to do is disable the 802.11e QOS option. I left the ACK mode at "Immediate ACK" but I think it ignors this when the 802.11e QOS option is disabled. Btw my bb is a 8320. Hope this helps...
    I cannot tell you how much this has HELPED me in troubleshooting my office connection!!!

    If anybody uses any Cisco Aironet AP, use this command to get your WiFi working:

    Code:
    interface Dot11Radio0
    [...]
    no dot11 qos mode wmm
    This is for any IOS after 12.3(2)JA, which is where 802.11e Wi-Fi Multimedia mode was introduced.

    I would also recommend configuring your DHCP server to only give one domain name, just like the 98/2k/XP restriction. In ISC-dhcpd config, that would be this in your subnet:

    Code:
    if substring (option vendor-class-identifier, 0, 10) = "BlackBerry" {
                           option domain-name "nobody.com"; }
    Vendor-class is case sensitive here.

    THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    02-27-08 06:24 PM
  18. Dreamzboy's Avatar
    Hi Varg,
    I have tried your instructions it did not work for me...using Dlink di-624
    I got as far as assigning static ip on my BB and router using mac address.
    my BB showing connected but when I checked the status the ip shows 0.0.0.0 does anyone else have any ideas for me to get my BB 8320 working with my router? (also tried at my friends house using Linksys router to no avail)
    thanks,
    yumdimsum
    This is the root of most problems. It doesn't get an IP address. I've tried it with 3 different networks, routers, and still no luck. My router (LinksysWRT54GL) sees the bb device on the network, but BB doesn't bring up the home page.

    This is what I've tried:

    Set to Static IP
    Open wireless, no wireless encryption
    I can see the bb on router.
    I can connect to my SSID
    VPN is off
    Call AT&T and RIM to get replacement and this is my 3rd replacement.

    No luck as of this point.

    I'll try to change the router channel and set the acknowledge thing tonight.
    03-06-08 05:29 PM
  19. farfromthesoul's Avatar
    I was having a similar problem as well, i couldn't connect from my home network after I have done it before. If i scanned the network and tried to change my network security option, it wouldn't let me open it to use a wep key. And if i tried to do it manually it wouldn't accept my wep key, saying it needed to be 10 character or longer even though my wep key password was exactly 10 characters. So I deleted the specific network, turned it off, opened up the back and took out the battery. When it started up, i entered it manually, switched the security option to a wep key, entered my wep key and it connected me. somtimes something so difficult does take something as simple as just taking out the batter :P.
    04-02-08 01:10 AM
  20. th3rapy's Avatar
    I had the same problem with my wifi. i have a motorola sbg900 and a TMo Curve. I just changed the channel to 2 (as it was suggested previously) and it worked.
    04-08-08 08:41 PM
  21. mdx's Avatar
    I had the same problem - the fix was easy (after over 3 hours on the phone with various tech support). Unplug your router, wait 15 seconds and plug it back in.

    PS: tech support at RIM didn't know this - I found it at Crackberry while I was on hold with a tech.
    04-18-08 05:42 PM
  22. -sandman-'s Avatar
    For you At&t users with 8820's...any of you using WiFi successfully with NO data plan?


    thanks!
    04-20-08 11:13 PM
  23. mjsalt42's Avatar
    I just got the pearl 8120, and had trouble getting on the WRT54g V6 wireless router. It was the firmware upgrade that I needed(1.02.5). Took about 5 minutes to get the firmware and upgrade it. Super easy.
    04-22-08 03:04 PM
  24. kalbo08's Avatar
    I need help I cant connect to my Netgear WGR614 wifi with my 8320 curve. I keep getting that W1020 error. But at my friends house it connects to his Linksys. Is it the Netgear not compatiable with my BB? I upgraded the firmware but still the same. Im using a WEP setting.
    04-25-08 01:18 PM
  25. Reed McLay's Avatar
    NETGEAR WGR614 54 Mbps 802.11g Wireless Router

    ...
    Modulation Type: 802.11b: DSSS, CCK, DBPSK, DQPSK, 802.11g: BPSK, QPSK, 16QAM, 64QAM ...
    It should work, the product specifications include 802.11g and should be BlackBerry compatable.

    If you have been using it prior to the BlackBerry joining the newtwork, there may be some conflicting settings.

    The best way to find out is reset the router to it's default settings and try to connect while it is Open. If you can do that, it is simple enough to introduce security for the Wifi device.
    04-25-08 02:18 PM
38 12
LINK TO POST COPIED TO CLIPBOARD