1. Canadianfly101's Avatar
    Hi! I've had my blackberry almost a year and for the last 3 months my wifi isnt working. I thought it was just at home but every wifi i connect to the same thing happens. It will connect at first but within a couple mins it doesnt work anymore. Then randomly it will re connect then then stop. I've done everything, reset my phone, done upgrades, taken the battery and sim card out. Nothing seems to be fixing the issue. Now for the last 2 weeks it won't connect at all. I still have warranty through Telus, should I just take it in??
    12-28-10 10:11 PM
  2. adamfalkofske's Avatar
    Yeah, I'd take it in and ask for an exchange. When you say you've "done upgrades," do you mean you've updated the operating system?
    Canadianfly101 likes this.
    12-28-10 10:38 PM
  3. BeyondTheBox's Avatar
    Yup, in this case you've taken all of the necessary steps to troubleshoot, it's time to take it in for warranty repair or replacement. Were it happening in just a single instance, such as at home or work only, then I'd say it's more likely a problem with connecting to the specific router having issues, but this seems a clear cut case of faulty equipment.
    Canadianfly101 likes this.
    12-28-10 10:47 PM
  4. Canadianfly101's Avatar
    I don't know if it was the operating system. I plugged it into the computer and it did upgrades then it did something that took about an hour and when it was done all my info and everything on my phone was gone. It wiped it completely.
    12-28-10 11:26 PM
  5. adamfalkofske's Avatar
    I don't know if it was the operating system. I plugged it into the computer and it did upgrades then it did something that took about an hour and when it was done all my info and everything on my phone was gone. It wiped it completely.
    Yeah, that sounds like you upgraded the firrmware (operating system). Just take it to your carrier and exchange it for a new one. Sometimes parts fail.. it happens.
    12-29-10 01:17 AM
  6. Rootbrian's Avatar
    When it wiped, it didn't back anything up. Seems like bad behavior from desktop manager. I would just do it the loader.exe way, or with BBSAK since it's a shortcut like the load disc button on the remote of a DVD or CD player

    Taking it in would be best. For one, by any chance, did you have a belkin/mimo, airport or netgear router?

    Posted from my CrackBerry at wapforums.crackberry.com
    12-29-10 01:59 AM
LINK TO POST COPIED TO CLIPBOARD