1. CammieB's Avatar
    Not sure why this is happening. But I am trying to use wifi on my Bold at home. And I keep only getting the "dash" in wifi signal, never the "checkmark" for full signal...is there a reason behind this? I'm trying to connect to my home wifi connection. Any suggestions? Thanks.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-06-10 03:34 PM
  2. apbthe3's Avatar
    Does it work elsewhere? Have you gone to "Setup WiFi Network" under the connections screen and set it up?

    If you have done this and it does work elsewhere, try rebooting your wireless router.
    05-06-10 03:37 PM
  3. owlyn's Avatar
    Let me guess... You definitely have security enabled on your router, and, possibly, the router is a Netgear.

    No solution, just denials from RIM that there is a problem.
    05-06-10 06:16 PM
  4. Frehley's Avatar
    I have a netgear router and after entering the password I have no issues connecting to wi-fi. Just make sure that you select the correct format for your pass code. My router is set up to use the 26 hexidecimal pass code.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-06-10 06:28 PM
  5. owlyn's Avatar
    I have a netgear router and after entering the password I have no issues connecting to wi-fi. Just make sure that you select the correct format for your pass code. My router is set up to use the 26 hexidecimal pass code.

    Posted from my CrackBerry at wapforums.crackberry.com
    And how do you set that up on the BB?
    05-06-10 09:07 PM
  6. narci's Avatar
    I use a netgear as well and no issues with wifi

    Posted from my CrackBerry at wapforums.crackberry.com
    05-06-10 09:24 PM
  7. Frehley's Avatar
    And how do you set that up on the BB?
    When I open the Manage Connections and select wi-fi, I searched for available networks. Once I selected my network I was prompted to enter the pass code (password). After successfully connecting, I saved. It currently takes about a minute to successfully link to my wi-fi when I walk in the door.
    05-07-10 07:03 AM
  8. 5picker's Avatar
    Let me guess... You definitely have security enabled on your router, and, possibly, the router is a Netgear.
    No solution, just denials from RIM that there is a problem.
    I connect to several security enabled Netgear routers (at work and several other places) and never have/had a problem. I have a TrendNet and a 3Com at home that work flawlessly as well.
    05-07-10 08:54 AM
  9. owlyn's Avatar
    To all who have it working- that's great, but I can't get it to work at home, though it will work on any public wifi spot I've tried. I'm not the only one, many others here have posted this problem. I've searched the net, and the only common themes I've found are security-enabled (WPA-PSK), and Netgear router.

    Yes, I've done the automatesd setup where it prompts you for everything including the password. It connects to my router, and will even get BES email via WiFi, but as soon as I try to use a browser, the WiFi icon dims, and I get the dash in the WiFi setup area. And, yes, I've tried the hotspot browser. I've tried all the browsers.

    If anyone has a solution, I'm all eyes...
    05-07-10 06:10 PM
  10. apbthe3's Avatar
    Will it work if you disable security? It may help you narrow down the problem (or not...)
    05-07-10 06:40 PM
  11. owlyn's Avatar
    Will it work if you disable security? It may help you narrow down the problem (or not...)
    Yes, but of course, I don't want to do that.
    05-07-10 07:10 PM
  12. Willardv's Avatar
    Is there a possibility that you could flash the router's firmware to an updated version or a public domain version like the dd-wrt firmware for linksys models?

    Else it appears that your down to trying another router I guess.
    05-08-10 06:34 AM
  13. owlyn's Avatar
    Is there a possibility that you could flash the router's firmware to an updated version or a public domain version like the dd-wrt firmware for linksys models?

    Else it appears that your down to trying another router I guess.
    I already have the latest firmware. No generic version available that I know of.
    05-08-10 07:47 AM
  14. owlyn's Avatar
    Is there a possibility that you could flash the router's firmware to an updated version or a public domain version like the dd-wrt firmware for linksys models?

    Else it appears that your down to trying another router I guess.
    I just tried using WiFi at home to see what would happen. At first, same results as before. So, I looked at the WiFi diagnostics, and everything was green except in BES, where "connecting" was red. Looks like it's not connecting to BES. Our network admins tell me that they have no restrictions set up on BES. My guess is that BES defaults to using itself to connect to the internet, and the default policy for the BB is to use BES.

    So, I tried using turning off the AT&T connection (to force use of WiFi) and using the Media browser, as that supposedly does not go through BES. Didn't work. In fact, the media browser didn't try to use WiFi. Then I tried switching the default browser to Hotspot, and sure enough- everything works- including Pandora and Sirius.

    I don't understand why the hotspot browser didn't work in my earlier trials, but in any event, it is working now.

    So my conclusions:

    1. The issue exists if you are on BES.
    2. For some reason, with PSK enabled, you can't connect to BES.
    3. The Internet and BB Browsers and other internet programs (e.g., Pandora) use BES to connect to the internet, so the WiFi connection drops to gray (WiFi still connected but not usable) when you attempt to use them
    4. The Media browser, which does not use BES, will not use WiFi.

    Notes: I found that it did drop to gray when I switched from the Sirius app to Pandora, but it prompted me and did reconnect just fine. It seems to do the "drop and prompt" whenever you close the app that was using the internet connection. For example, I closed Pandora, and did not open anything else, and got the prompt. Re-connected fine again.

    Also- I clicked on a link in an email (personal email, not BES). It launched the Blackberry browser, which reported that it couldn't find the requested server Then the WiFi connection went gray.

    So, the bottom line is:

    If you are using PSK on a BES BB, the Hotspot browser must be enabled as the default browser to use WiFi. You will receive email that is pushed, but you will not be able to click on embedded links. Sending email worked, although the messages stayed in the "not yet sent" mode.

    I also found some other strange behaviors that required turning off WiFi and back on again to regain use. Too complicated to go into details, but if the WiFi drops to gray and stays there, turn WiFi off and back on again and reconnect.
    05-08-10 09:08 AM
  15. hollygolighty's Avatar
    I am able to connect to my home wifi (the wifi name appears on top of the time), but the dash is still there in my wifi connection and the wifi icon is still gray. why is this so? hope you guys can help. Thanks!
    08-13-10 11:05 AM
LINK TO POST COPIED TO CLIPBOARD