1. rodtheplod's Avatar
    Hey all,

    I've been trying to get my son's Blackberry Curve 8520 xmas pressie online since yesterday but cant. This is on the Orange (UK) network on Pay As You Go.

    Whenever I try to open a web page in the Hotspot Browser I get about 15 seconds of "Requesting" and then the following error: "Unable to connect to the server"

    I have a Belkin router which I've been using for over two years now. This services an iPod touch over WIFI, two Mac Minis and also a couple of Windows (XP/Vista) laptops - so I know the WIFI connection/Router is working well.

    I've set up a WIFI connection on the Curve and specified the relevant WPA password, etc.

    When I look in Manage Connections, WI-FI Connections, Saved WI-FI profiles, I see my WIFI network but with a dash "-" symbol. I'm guessing I should see a tick/check here instead.

    So the Curve seems to see my network and is connected to it (I see this on the 'home' screen) but I cannot access any websites.

    I've pulled the battery with the Curve on and waited 60 secs before re-inserting and resetting.

    Any ideas?

    Thanks,

    Rod.
    ps. Merry xmas!!
    12-26-09 12:06 PM
  2. JackStorey's Avatar
    try going into the settings and if it has a password add the Password

    Setup > set up wifi
    12-26-09 12:11 PM
  3. rodtheplod's Avatar
    Hi Jack,

    Thanks for the reply. No luck there - I've tried entering the password for my network. I've also just deleted the entire network profile from the BlackBerry and added it again taking care to specify the correct password.

    No dice - I still get the error when trying to launch the browser.

    I removed the SIM and rebooted just to be sure it was nothing to do with Orange - I can still access functions on the phone without the SIM in place but, unfortunately, WIFI still doesn't work.

    I've did a quick google and found a few people having the same problems - but I can't see a solution!!

    Rod.
    12-26-09 12:28 PM
  4. diegonei's Avatar
    See if this helps.
    12-26-09 12:35 PM
  5. rodtheplod's Avatar
    Thanks for the link! Went into Browser, Options and then selected the General Properties and Browser Configuration. The browser was already set to Hotspot Browser so there was nothing to change there.

    I've run the wizard a few times (and also set the WIFI network up manually) but i still have the same problem. Arrrrrrrghh!!!!!

    BTW: The WIFI logo on the home page is still gray and not white.

    Any other ideas? (Sorry!!!)

    Rod.
    12-26-09 01:03 PM
  6. diegonei's Avatar
    Gray won't give you access, you can only browse once it goes white.

    If you are connecting to the hotspot and it isn't turning white, you have some sort of problem (and one I cannot help you with :/).
    12-26-09 02:06 PM
  7. vmeertens's Avatar
    Hey,

    I had the same error: "Unable to connect to the server"
    The network here has an encrypted WPA2 key. Seems the router also supports a security option where you have to enter a PIN code in the router acces software. Maybe that helps?

    Sorry for my bad english
    12-26-09 04:29 PM
  8. rodtheplod's Avatar
    OK - the router is set up with a pre shared WAP key encrypted using AES. I'll change this to TKIP encryption to see if it makes a difference...

    Not sure about the PIN code you mention - I'll have a poke around in the router config to see if anything matches this.

    Thanks for everyone's help so far!

    Rod.
    Last edited by rodcambridge; 12-26-09 at 08:55 PM. Reason: corrected spelling
    12-26-09 08:54 PM
  9. diegonei's Avatar
    Good luck!
    12-26-09 09:30 PM
  10. rodtheplod's Avatar
    Success!!! it's now working

    After the hint by vmeertens, I changed the shared key encryption method on the router from AES to TKIP. I then disabled the network on the Curve and enabled it again. Unfortunately, this didn't work - the WIFI logo on the home screen was still gray.

    So I decided to reboot the phone... As soon as the restart/reboot process completed and the Curve attempted to connect to the network, the WIFI logo turned white!

    I then fired up the browser and all is well - the Curve can now browse the web via WIFI

    I'm just posting this for completeness' sake (I hate it when people solve their issues on other forums but don't reply to the thread to say how they did it). Hopefully this will help someone else who comes across the problem.

    So thanks everyone for the input. I'm sure my son will come across other issues as he learns how to get the best out of his Curve and so I'll be pointing him to these forums and the users on here who I've found extremely helpful.

    I hope everyone had a happy and safe Christmas - and best wishes to you all for a prosperous and healthy 2010.

    Rod.
    Last edited by rodcambridge; 12-27-09 at 10:31 AM.
    12-27-09 10:25 AM
  11. diegonei's Avatar
    Yahoo! Good to know!
    12-27-09 10:31 AM
  12. JRF_1986's Avatar
    Hey guys, I've been having trouble lately with my wifi connection. I had it working great but a few days ago I started to notice that my wifi logo turns grey after like 10 seconds of "requesting". I always wait for it to detect my connection automatically and it does very quickly. But once I try to open a site it gives 2 different errors: "unable to connect to server" and that there was an error connecting and to see my service provider if the problem persists. It's only been going on for like 3 days, my laptop and iTouch connect no problem. Any help? I've already done the battery pull, deactivated and reactivated it the profile, and set it to select mode auto and manually, and still nothing.
    01-03-10 11:02 AM
  13. rmbawa's Avatar
    I had the same problem and it took me days to get over the same. Ultimately it was the router setting which had to be changed to get the wifi working.

    why is wifi of BB 8520 so complex?. Iphone connects to anything in a jiffy !!
    01-05-10 09:25 AM
  14. JRF_1986's Avatar
    Yeah, my iPod touch never gave me this kind of trouble... oh well, atleast I got it working again
    I deleted the profile and added it again like 2 or 3 times and now it's working!
    I don't know how to manage my modem settings so I wouldn't know what to do if I ever entered the settings menu xD
    Anyway, wifi was just for a while since my prepaid BB BIS will be activated tomorrow
    01-05-10 11:47 AM
  15. emersondi's Avatar
    hi.. i have problem to conect to the work network, the phone surf in the web pages of the work but dont surf outside of the work. here is the two config.. the office manual say:

    Name: wpeapunal
    Security: WPA/WPA2 or WPA Enterprise
    Tipo de Cifrado: TKIP
    Mtodo de autenticacin de Red: EAP Protegido (PEAP)
    Otros:Secured Password EAP MSCHAP v2

    In My blackberry 8520 I Put:
    Name: wpeapunal
    SSID: wpeapunal
    Band Type: 802.11b/g
    Security Type: PEAP
    Usser : My user
    Pass *****
    CA Certificate: None selected
    Inner Link Security: EAP-MS-CHAT-v2
    Token: None selected
    Server subject:
    SAN Server:
    Dissable Server certificate validation: OFF
    Conection mode: Automtic
    Automatic obtain IP adress and DNS: ON
    Allow ininteraccess ponti handover: ON
    SSID Broadcast: ON

    Where is the mistake
    In the phone cant find where can I put "TKIP" option....

    Thanks for your help, and hope you can undestand me!!
    07-06-10 11:01 AM
LINK TO POST COPIED TO CLIPBOARD