1. X3T's Avatar
    I'm having problems with the Wifi connection on my Blackberry 8120. It keeps going on and off. I can be standing next to the wireless router, and it will suddenly say "OFF" next to the signal indicator. A few minutes later it will come back with full signal strength.
    02-28-09 09:28 AM
  2. controversialfigure's Avatar
    Sorry to hijack your thread but I've got a similar problem. I find that when mine connects after a few minutes it will disconnect and that will, in turn, disable the wireless on my router (even though the active wireless indicator is still on) usually meaning I have to pull the plug on my router for it to reboot.
    03-17-09 05:56 PM
  3. Reed McLay's Avatar
    Have you checked the built in Wifi Diagnostics?

    Connections / Wifi Options. Menu / Wifi diagnostics.

    The diagnostics page should show your connection details including your IP address.

    When you get a failure, look for an error message for information about why it failed.

    03-17-09 06:06 PM
  4. Zipman_13's Avatar
    I am on A Storm 2 (9550) and am having the Disconnection issues as well. It will randomly d/c itself and then reconnect after I have reset the WiFi in the phone.

    Any Suggestions?
    11-13-09 03:35 PM
  5. alextop30's Avatar
    I am having a very similar problem it simply does not stay connected - it says network acquired in freken diagnostics menu but it is still grayed out and no signal and no connection. RIM seriously needs to fix that.
    04-20-10 10:34 PM
LINK TO POST COPIED TO CLIPBOARD