1. hitemlow's Avatar
    I just went over my data usage on my Torch 9800, and the data usage was abnormally high, so I went over it. There were entries with thousands of KB used. But that's not the strange part; I was home during those times, and I have my Torch connected to my WiFi at home.

    So why am I using my limited AT&T data plan when I have unlimited WiFi?

    I don't download apps, watch videos, or do anything aven remotely data-intensive unless I'm on WiFi, but the data usage entries were about the size of some of the apps I downloaded, so it seems that the browser is defaulting BACK to 3G.


    I have read all of the other articles concerning connecting your BlackBerry to WiFi, but they are either several years old and outdated, say to shut the network antenna off, or are people trying to go without using a data plan, and just use WiFi instead. All of which are useless to me and the Torch, because I still want to recieve phone calls and texts while using WiFi.


    I am a college student, and I have a secured router at home (and have entered the password on my BlackBerry), there is unprotected WiFi (you don't need to enter a password to access the network either) on campus (all with the same name), and WiFi on the bus (with a different name).
    All seem to work fine when I turn the network antenna off, but I don't want to leave it off in case I get phone calls or texts and the like.


    Sorry for the long read, but I am getting frustrated with the lack of info on this topic.


    Essentially, I think what I am wanting to do is set the data usage (not just the browser) to prefer WiFi over 3G, because I need it to switch between multiple WiFi networks, but still be able to use 3G when I am running around town. Does anyone know how to do this?
    01-25-11 01:47 PM
  2. moodypickle's Avatar
    hmm... when i set up wifi networks on my phone it automatically has it set as default. when i look at my "service status" both BIS and BES show wifi connection. however, in some of the apps that i run i had to go into their settings and change them to "wifi preferred". i use my phone all day to stream radio, messenger, browser etc. and it uses the wifi at work and home. i have the lowest data plan and use maybe a fourth of it every month. i suggest checking the settings in the individual apps and making sure the service status on your phone shows wifi connections for the above i mentioned. if that still doesnt work, your phone may not be working properly.
    01-25-11 02:44 PM
LINK TO POST COPIED TO CLIPBOARD