1. a_silent_song's Avatar
    Here's hoping I explain this clearly, as I'm mildly (okay, fine, really really) irritated at the moment.

    I have a BlackBerry Torch 9800. Up until yesterday evening, it has been an absolute joy to own. I have had no problems with it until yesterday evening.

    I normally stay connected to WiFi at home, and I've never had an issue with that. I went to my EMS job yesterday until 5pm. At work over there, it was nothing but issues with their WiFi on my new laptop; I can't say for sure if it was acting up on my Torch too. When I got home, I was surfing the 'net fine on my laptop, but I happened to look at my Torch and tried to pull up BeeJive IM to start a chat with someone, but I discovered it had logged me out automatically. The bar at the top was grayed out, as if I had no signal, and a box was up that said "DNS Error." I shut down the app and tried logging in again, but all I kept getting was "DNS Error." I put it down to BeeJive issues (again!) and went about my business.

    Except this morning I've discovered that I can't use pretty much anything on my phone if my WiFi is turned on. BeeJive is still giving me a DNS Error. If I try to go to a website on the browser, I get a box that says, "Unable to find the requested server." Slacker Radio refuses to work. All of this starts working again if I turn my WiFi connection totally off. The ONLY app that is working is SocialScope.

    Yes, the WiFi symbol is white, not gray. It is fully connected to WiFi.

    It is also causing similar problems on my Bold 9700, but the WiFi symbol is grayed out on that one and won't connect to WiFi at all.

    I have tried the following:
    battery pull
    deleting the wifi profile and re-adding it
    reconnecting and discovering it still won't let anything connect
    yet another battery pull

    Anybody got any suggestions? I'm at my wit's end for anything else to try. I'll supply any additional information you might need to help me fix this issue! (Translation: HALP!)
    03-15-11 07:06 PM
  2. Michael Hepples's Avatar
    Have you tried going to Options>Device>Advanced>Service Book, deleting the two service book entries for WiFi and resending your service books to the device?

    Give that a go, battery pull, then see if it's resolved.
    03-15-11 07:30 PM
  3. a_silent_song's Avatar
    Have you tried going to Options>Device>Advanced>Service Book, deleting the two service book entries for WiFi and resending your service books to the device?

    Give that a go, battery pull, then see if it's resolved.
    Excuse me while i sound like a dummy, because I haven't had to do this on OS 6 and am not sure where to look. Where do I go to resend my service books on a Torch? I know where it was on my Bold, but I'm still a little lost with my options menu lol.
    03-15-11 07:33 PM
  4. Michael Hepples's Avatar
    All good.

    Click the "Setup" icon. Then Mail, then "Internet Mail Access"
    You will see a list of your current email accounts.
    BB Key>Service Books
    Click "Send Service Books"
    03-15-11 07:37 PM
  5. zeelob's Avatar
    Reset the Wi-Fi router by unplugging it for 60 seconds before plugging it back in. You should be able to reconnect then.
    03-15-11 07:40 PM
  6. Michael Hepples's Avatar
    If you can't get the email settings on device to connect, log into BIS here BlackBerry Internet Service and resend your service books from the web. Log in, click "Help" and you should see a link to send your service books.
    03-15-11 07:44 PM
  7. a_silent_song's Avatar
    All good.

    Click the "Setup" icon. Then Mail, then "Internet Mail Access"
    You will see a list of your current email accounts.
    BB Key>Service Books
    Click "Send Service Books"
    And I've rebooted and that didn't work.
    03-15-11 07:44 PM
  8. a_silent_song's Avatar
    Reset the Wi-Fi router by unplugging it for 60 seconds before plugging it back in. You should be able to reconnect then.
    So, zeelob, I think you're officially my new best friend. Why did I not think of this before?
    03-15-11 07:47 PM
LINK TO POST COPIED TO CLIPBOARD